About the pyttsx3 speech module in python

hi ,iam using garuda linux dr460nized for a month, now iam facing a problem on running pyttsx3 module in python.

if i run any code there it says some error that is

Traceback (most recent call last):
File "/home/jking/.local/lib/python3.10/site-packages/pyttsx3/init.py", line 20, in init
eng = _activeEngines[driverName]
File "/usr/lib/python3.10/weakref.py", line 137, in getitem
o = self.datakey
KeyError: None

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/home/jking/Documents/html/jaha.py", line 2, in
File "/home/jking/.local/lib/python3.10/site-packages/pyttsx3/init.py", line 22, in init
eng = Engine(driverName, debug)
File "/home/jking/.local/lib/python3.10/site-packages/pyttsx3/engine.py", line 30, in init
self.proxy = driver.DriverProxy(weakref.proxy(self), driverName, debug)
File "/home/jking/.local/lib/python3.10/site-packages/pyttsx3/driver.py", line 50, in init
self._module = importlib.import_module(name)
File "/usr/lib/python3.10/importlib/init.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "", line 1050, in _gcd_import
File "", line 1027, in _find_and_load
File "", line 1006, in _find_and_load_unlocked
File "", line 688, in _load_unlocked
File "", line 883, in exec_module
File "", line 241, in _call_with_frames_removed
File "/home/jking/.local/lib/python3.10/site-packages/pyttsx3/drivers/espeak.py", line 9, in
from . import _espeak, toUtf8, fromUtf8
File "/home/jking/.local/lib/python3.10/site-packages/pyttsx3/drivers/_espeak.py", line 18, in
dll = cdll.LoadLibrary('libespeak.so.1')
File "/usr/lib/python3.10/ctypes/init.py", line 452, in LoadLibrary
return self._dlltype(name)
File "/usr/lib/python3.10/ctypes/init.py", line 374, in init
self._handle = _dlopen(self._name, mode)
OSError: libespeak.so.1: cannot open shared object file: No such file or directory

this last line says that the libspeak.so.1 is not avail espeak.

but i tried to install it using

sudo pacman -S espeak

it says espeak not found ,please help me to resolve it

Hi there, welcome to the community.

May I know, how did you install pyttsx3?

Also see similar issue solved on Arch Linux forums.



hmm, likely i wrote crap. disregard.

If you're using this upstream package, which could be provided eg by python-pyttsx3 in the AUR, there seems to be more than one open issue with that error reported.
Eg this one seems to somehow match with Naman's comment. Since the suggested lib should be provided by the package in the forum discussion.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.