A new user's pov with Garuda Linux

Hello Garuda forum.

I'm a new Garuda Linux user "almost" for a week and this is my short performance notes on it. Garuda really shocked me with its performance contrary to popular views. Also I thought how would be heavy, slow and possibly buggy, but it's completely not! :clap:

TLDR:

I denied to use Garuda Linux due to internet bois who make negative comments "bloated, heavy" etc. about Garuda. But it's not and works nice even over RAM usages' no freezing proves it.

Other Linux users should give a chance to Garuda via installing on it to real machine instead of Virtual Machines.


As a long period ex-Manjaro user I've been impressed Garuda's performance. Well optimized kernel-ram-cpu combination made my laptop like a flying bird despite huge RAM usages with forcing to stress. In normally I could not use Manjaro when its RAM gets %85+ filled, it always got stuck and my machine either was freezing or had to wait for a long time to be free for working. In Garuda even more RAM usage numbers never frozen my laptop also CPU usages surprisingly stable and well designed for task's needings. Bravo...

Still testing, trying to freeze it :smiley: but cannot succeed yet LOL... Lemme know you my specs and talk a bit more.

System:
Kernel: 6.0.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b9a63755-06cc-46d3-a3a0-84752c0237dd rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04
serial: <superuser required>
Mobo: RO model: Stonic_RNS v: V1.04 serial: <superuser required>
UEFI: Insyde v: 1.04 date: 02/04/2021
Battery:
ID-1: BAT1 charge: 41.9 Wh (79.1%) condition: 53.0/58.8 Wh (90.3%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: not charging
CPU:
Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600103
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 1493 high: 2900 min/max: 1400/2900 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 2900
3: 1400 4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1396 10: 1400 11: 1397
12: 1400 13: 1396 14: 1400 15: 1400 16: 1400 bogomips: 92626
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 520.56.06
alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1f95 class-ID: 0300
Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu
v: kernel arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: none
bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 temp: 35.0 C
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: Najing CEC Panda 0x004d built: 2019
res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon Graphics (renoir LLVM
14.0.6 DRM 3.48 6.0.9-zen1-1-zen) direct render: Yes
Audio:
Device-1: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: Acer Incorporated ALI driver: N/A alternate: snd_pci_acp3x,
snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
snd_rpl_pci_acp6x, snd_sof_amd_renoir pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound API: ALSA v: k6.0.9-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0
chip-ID: 10ec:2600 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2
chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 22.98 GiB (4.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
SDBPNPZ-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 21103900 temp: 29.9 C scheme: GPT
Partition:
ID-1: / raw-size: 165.26 GiB size: 165.26 GiB (100.00%)
used: 22.93 GiB (13.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 1024 MiB size: 1020 MiB (99.61%)
used: 50.3 MiB (4.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 165.26 GiB size: 165.26 GiB (100.00%)
used: 22.93 GiB (13.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 165.26 GiB size: 165.26 GiB (100.00%)
used: 22.93 GiB (13.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 165.26 GiB size: 165.26 GiB (100.00%)
used: 22.93 GiB (13.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.4 C mobo: N/A gpu: amdgpu temp: 36.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 363 Uptime: 27m wakeups: 1 Memory: 15 GiB used: 4.08 GiB (27.2%)
Init: systemd v: 252 default: graphical tool: systemctl Compilers:
gcc: 12.2.0 Packages: 1428 pm: pacman pkgs: 1421 libs: 369
tools: octopi,paru pm: flatpak pkgs: 7 Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-19
Last full system update: 2022-11-24
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

#Performance

There were no hangs, freezes or crashes, even though I tried to stress and strain the system. Believe me, this is something that was not possible with Manjaro, I tried for years with it and was frustrated.

Many apps were working when captured the screen as above image shown. Brave with multi tabs + several hd youtube video Vivaldi with multi tabs + chart-graph tabs and again hd youtube videos playbacking, Virtualbox vms almost three different os.

CPU usage is really impressive, just WOW! No throttle, no stuck even with KDE :smiley:


#Some little bugs

1- Even though my installation of packages gone right and installed, sometimes popup says it failed but did not actually, Why and how this possible no idea. Moreover sometimes packages being removed after reboots even I've installed. That happened with Dropbox and some packages do not remember right now the names.

image

2- Second annoying bug or my wrong setting on WiFi that drops the speed half o it. So I have to relaunch the command after every reboots to get all WiFi speed at top speed limit.

sudo -u $USER /bin/bash -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi 11n_disable=8 bt_coex_active=0'

How can I make those permanent? I do not wanna type it after every reboot.


#Advices

1- Starship Terminal integration as default or optional by Garuda Settings window. I like it and see huge potential on it you may watch.

2- I do not wanna get binary packed chaotic-aur updates over installed from aur. Why and how that happens do not know once again, but system updates catch the aur packages as chaotic-aur maybe for naming as same then update via chaotic repos. You should give an option to users if combine aur/chaotic or only chaotic for Garuda's needed packages.

3- CoreCtrl addition into Garuda Assistant > Settings for AMD CPU users as equivalent intel's one. I need it for nicely configured fan speed and cooling. Also other users can learn it and use.

4- When we go with Garuda Assistant it launches Terminal for us and automates the process but I wanna know which commands are being typed on terminal to teach myself so adding those automated commands to the Garuda's wiki would be very handy.

5- Forum does not allow to create more drafts or new topic without creating new topic with existing draft. It forces to use draft first. NOO, I wanna draft all bugs, proposals when I catch or figure out. So enabling drafts-new topics together can help your users reports and ideas better.


Thanks for your great products guys. I'm gonna
*sorry fır typos or grammar I'm not a native English speaker

4 Likes

Garuda recently split system and essential packages to a seperate repo, named "garuda". You can disable chaotic AUR and still have a functional Garuda system but some functions of Garuda applications may not work because they assume Chaotic AUR is available.

4 Likes

I know it then don't disable chaotic-aur. But how to prevent to update via chaotic don't know.

The above thread I linked explains how to make the iwlwifi configuration options permanent.

Create the conf file /etc/modprobe.d/iwlwifi.conf and add the option you require to the conf file and save, then reboot.

4 Likes

thanks a lot :pray:

another great point of Garuda Linux is this forum and developing help docs. Nice!

EDIT:

Tadaaaa! :partying_face:

options iwlwifi bt_coex_active=0
options iwlwifi 11n_disable=8
options iwlwifi swcrypto=1
options iwlwifi power_save=0

those combinations worked after reboot, and I can use my WiFi at top speed limit.
Thanks again.

2 Likes

BTW,

:slight_smile:

4 Likes