5Ghz wifi connected without internet, 2.4Ghz works

Hey

UPDATE: Seems the issue is with the router, I'm having the same issue in windows 10, but curiously not on my android phone. Sorry for wasting time!

Just installed Garuda, during installation and immediately after 5ghz wifi worked. After install i was prompted to update the system and after that it connects without internet. Is this a driver issue? Can I roll back or update the driver?

I have not attempted any fixes. Trying to figure out how to see drivers etc.
Apologies if this topic already exitsts could not find it. The wifi card is a TP Link AX3000.

Many thanks
pp

terminal output below:

x;XxXB%89b8:b8%b88:             OS: Garuda Linux  
.8Xxd                8X:.          Host: ASUSTeK COMPUTER INC. ROG STRIX B450-F GAMING  
.8Xx;                    8x:.        Kernel: 5.17.9-zen1-1-zen  
.tt8x          .d            x88;      Uptime: 1 hour, 43 mins  
[email protected];          .db:              [email protected];    Packages: 1762 (pacman)  
,tSXX°          [email protected];   Shell: bash  
.SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;   DE: Plasma 5.24.5  
,888S                                     pd!   WM: KWin  
8X88/                                       q    WM Theme: Breeze  
GBB.                                             Terminal: konsole  
x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.         CPU: AMD Ryzen 5 2600X (12) @ 3.6GHz  
dxXd    dB8b8b8B8B08bB88b998888b88x.          GPU: NVIDIA GeForce GTX 1070 Ti  
dxx8o                      [email protected]@;.             Memory: 7.16GiB / 15.61GiB  
dx88                   [email protected]
d:[email protected]                                          
.d988999889889899dd.                                            

╭─[email protected] in ~  
╰─λ garuda-inxi
System:
Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=398795f5-8869-4625-85ab-b23cc027e9ba rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4602
date: 08/17/2021
Battery:
Device-1: hidpp_battery_0 model: Logitech G603 Wireless Gaming Mouse
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 4094 high: 4151 min/max: 2200/3600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3776 2: 4150
3: 4150 4: 4146 5: 4150 6: 4147 7: 3886 8: 4148 9: 4146 10: 4134 11: 4149
12: 4151 bogomips: 86402
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070 Ti] vendor: eVga.com.
driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 09:00.0 chip-ID: 10de:1b82 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
s-diag: 692mm (27.26")
Monitor-1: DP-2 res: 2560x1440 dpi: 65024 size: 1x1mm (0.04x0.04")
diag: 1mm (0.06") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 515.43.04 direct render: Yes
Audio:
Device-1: NVIDIA GP104 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 10de:10f0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0b:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: Creative Sound Blaster Premium HD [SBX] type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:3 chip-ID: 041e:3232
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-9:5 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 4.11 TiB used: 67.69 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDBRPG0010BNC-WRSN size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 111130WD temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM003-1ER162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC45
scheme: MBR
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Kingston
model: DataTraveler 3.0 size: 14.41 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 67.69 GiB (7.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 67.69 GiB (7.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 67.69 GiB (7.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 67.69 GiB (7.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.61 GiB used: 21.2 MiB (0.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: 34.0 C gpu: nvidia temp: 52 C
Fan Speeds (RPM): cpu: 671 case-1: 0 case-2: 761 case-3: 0 gpu: nvidia
fan: 8%
Power: 12v: 9.92 5v: N/A 3.3v: N/A vbat: 3.21
Info:
Processes: 390 Uptime: 1h 43m wakeups: 6 Memory: 15.61 GiB
used: 7.18 GiB (46.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1762 lib: 502 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.3-2):
System install date:     2022-05-20
Last full system update: 2022-05-20 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:~~~

First can you add ~~~ before and after your terminal output.
Second i would reboot the machine as you have not done so after updating
What have you tried so far?
Have you checked your wireless network settings
If you are far away from the access point you will find it will prefer 2.4 instead of 5

3 Likes

I can see some recent regressions related to your driver (iwlwifi) recently.
E.g.
https://bugzilla.kernel.org/buglist.cgi?quicksearch=iwlwifi

Maybe, as a first troubleshooting test, you could try moving to the linux-lts kernel.

5 Likes

Hey
Thank you for your quick reply! I have tried both a restart and changing to the LTS kernel without any difference.

Thank you for replying!
I have made sure the 2.4 is not preferred. The signal strength is very good. The Access point is not far.

Try lowering the channel on the 5 GHz band. Some wifi adapter's have problems connecting on the higher router channels. Select a 5 GHz channel below 40 in your router, (such as 36) and see if you can then connect properly.

6 Likes

UPDATE: I reolved the issiue in windows by changing the channel width from 40 to 20MHz in the adapeter options. How do i go about doing this in Linux?

Preferably you want to do this in your router's settings.

1 Like

I don't have access to those :frowning: I'm renting an apartment where there is only wifi.

As your wifi was working correctly at one point, you may be able to correct your wifi's behaviour. You should perform the following suggestions first as some of these may correct your issue:



Is your computers BIOS up to date?

If not be sure to update it, as doing so may correct your problems in both Linux & Windows.


Install and test different kernels, running connectivity tests on each. I would suggest starting with the linux-hardened and linux-mainline kernels. After installing a new kernel reboot and select the alternate kernel from the grub advanced boot menu at startup.


Install and test the newest Linux firmware available:

sudo pacman -Syu linux-firmware-git

After installation reboot.


Try temporarily disabling Bluetooth to see if your connectivity improves.


If after testing all those fixes nothing helped try running this command and the see if you can connect properly.

sudo -u $USER /bin/bash -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi 11n_disable=8 bt_coex_active=0'
4 Likes

Hey
I've been able to resolve the issue across win and Linux by enabling a random MAC address. I don't know why this works, but I imagine it's a router issue.
Thank you for you kind help regardless!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.