2nd monitor problem on laptop with nvidia gpu

Hello Garuda users.

I am a prior Windows user switching to Garuda KDE Dr460nized, I installed it on bare metal and selected to install it with proprietary drivers. However, my second monitor is not detecting any HDMI output. I open the display config, and my monitor is detected and checked as enabled but nothing.
I went through the Garuda settings manager > hardware config and auto-install proprietary driver but still blank screen. Any idea what to try next?

Please run the command


and paste it into the thread as text, with three tildes (~) before and after
like this
to format as a code block.


Sure thing

Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9482c0f7-46f7-473c-bafb-42b307e89359 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Alienware product: Alienware m17 v: 2.18.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Alienware model: 01F1MV v: A00 serial: <superuser required>
UEFI: Alienware v: 2.18.0 date: 02/14/2023
ID-1: BAT0 charge: 28.7 Wh (100.0%) condition: 28.7/60.0 Wh (47.9%)
volts: 16.8 min: 15.2 model: DELL 8622M957 type: Li-ion serial: N/A
status: full
Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 2129 high: 2894 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 2894 2: 1700 3: 2200
4: 2200 5: 2200 6: 2200 7: 2200 8: 1156 9: 2200 10: 2200 11: 2200 12: 2200
bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
bus-ID: 0000:00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Dell
driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 bus-ID: 0000:01:00.0
chip-ID: 10de:1f11 class-ID: 0300
Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.3:4
chip-ID: 046d:085c class-ID: 0102 serial: <filter>
Device-4: Realtek Integrated_Webcam_FHD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-9:8 chip-ID: 0bda:5765
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
s-diag: 581mm (22.86")
Monitor-1: HDMI-1-0 size-res: N/A modes: N/A
Monitor-2: eDP-1 pos: primary res: 1920x1080 hz: 60 dpi: 128
size: 381x214mm (15x8.43") diag: 437mm (17.2") modes: N/A
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:10f9
class-ID: 0403
Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.3:4
chip-ID: 046d:085c class-ID: 0102 serial: <filter>
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet
vendor: Rivet Networks driver: alx v: kernel port: 3000 bus-ID: 0000:6e:00.0
chip-ID: 1969:e0b1 class-ID: 0200
IF: enp110s0 state: down mac: <filter>
Device-2: Intel Wireless-AC 9260 vendor: Rivet Networks driver: iwlwifi
v: kernel bus-ID: 0000:6f:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp111s0 state: up mac: <filter>
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:7
chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 1.14 TiB used: 10.18 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
model: KXG60ZNV256G NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B tech: SSD serial: <filter> fw-rev: 10604106 temp: 35.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LX015-1U7172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM3 scheme: GPT
ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 10.18 GiB (4.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 10.18 GiB (4.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 10.18 GiB (4.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 10.18 GiB (4.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.42 GiB used: 8.2 MiB (0.1%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 46.0 C pch: 49.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 324 Uptime: 1h 21m wakeups: 1 Memory: available: 15.42 GiB
used: 4.2 GiB (27.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1267
libs: 348 tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-16
Last full system update: 2023-05-16 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

By this, you mean in the system settings menu right? I understand the issue to be the monitor shows as detected and enabled in the settings, but the monitor itself is blank/no signal.

Before going any deeper, take a full reboot and confirm the issue persists.


yes you are correct, monitor is detected and enabled yet no signal on the monitor itself. I will reboot and reply once done.

I've rebooted and the issue still persists.

Hmm, it does not look like this display is being detected correctly. In the settings menu, does it show the make/model/resolution?

Are you plugging it in with the same cable you had when it was working on the other OS?


Yes in the display config settings it is showing the display in the re-arrange box as "ASUSTek COMPUTER INC ASUS VG328 (1920x1080) and it is in the same HDMI port as when I was on windows

Edit: If this helps at all, I went into the setting and disabled and re-enabled my monitor and my monitor flashed like it was plugged in but said "HDMI No Signal"

Same cable though?

Even if it is the same cable, it can’t hurt to test another cable if you’ve got one.

Other than that, it may be useful to test another kernel such as the LTS kernel.

sudo pacman -S linux-lts linux-lts-headers nvidia-lts

You can boot an alternate kernel from the advanced boot options in the Grub menu.

1 Like

Yes it is the same cable, I will try another and I ran the code however I got an error

sudo pacman -S linux-lts linux-lts-headers nvidia-lts
[sudo] password for dakota:
resolving dependencies...
looking for conflicting packages...
:: nvidia-lts and nvidia-dkms are in conflict (NVIDIA-MODULE). Remove nvidia-dkms? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-dkms breaks dependency 'nvidia-dkms' required by garuda-nvidia-config

You don't need nvidia-lts to use the LTS kernel, it works fine with nvidia-dkms. Go ahead and try it with nvidia-dkms. If it doesn't work, you can always circle back and try the other driver if you'd like, for the sake of being thorough, and reinstall the other packages afterward if it doesn't help.

The main thing is to test a kernel that's on a different version.


I’ve tried a different cable, still no display, checked settings and monitor is still shown and enabled.

I’ve installed the LTS kernel, how exactly do I do what is described above?

I made a live usb of manjaro to see if it would work, same problem. I then used the origional cable on my windows laptop and it worked fine. I have never had problems with my hdmi port or anything on my laptop running linux rn.

I have a HDMI to vga cord and I plugged the HDMI into my linux laptop and the vga into my monitor and it worked, I am so confused. The HDMI cord works since I plugged it into my windows running laptop. Any suggestions?

If everything is plugged in correctly and all the cables are good, etc then issue is likely with drivers and firmware. If it is on the PC side, you can make changes to the kernel or graphics drivers in use and try to find a configuration that works. If it is on the monitor side, it’s somewhat harder to address. Keep in mind, some monitor manufacturers will write special drivers for Windows only–other systems do not get the full benefit of whatever functionality the driver provides.

Your issue looks a lot like this one, which unfortunately peters out at the end without a solution being identified: Asus monitor only working on windows not linux - Linux Mint Forums. It may still be worth a read-through if you would like to try some of the troubleshooting they went through to see if it proves helpful in your case.

Reboot, and in the Grub menu choose “advanced boot options” (something like that) where you should be able to choose from among any kernels you have installed.


Would this still apply? also I don’t have grub installed or anything
It seems its on the monitor side as the HDMI to HDMI is not working but HDMI adapted to VGA does

Would what still apply? If you are happy with that result, that is all that matters. Whether or not it is worth it to try to get the HDMI cable working is totally up to you.

I am sure you do, just maybe you didn’t know it was called Grub! The Grub menu is what you see when you first boot up. It looks something like this:

That is just a random picture from the forum, but it illustrates the menu well enough. Yours might look a little different but should have most of the same basic options.

In the “advanced options” menu you can choose to boot with other kernels or the fallback images.

1 Like

I would really prefer to use HDMI over a vga adapter since it limits my monitor to 75Hz, when this is a high refresh rate monitor.

and aahhh yes! I do I didn’t realize I will try the other kernal however I am thinking asus just doesn’t support linux HDMI drivers but VGA works for some reason. I will try plugging my laptops hdmi into my tv to confirm.

@meeg I recently had a similar fight.

I have a laptop with AMD and NVIDIA RTX 3060 hybrid card.
After initial installation only a single external screen beside the laptop would work, when I connected 2nd monitor it would be detected but no output.

From what I researched is due to the way that PRIME handles offloading between two cards and doesn't use other HDMI directly etc.
I read the Arch wiki and tried to reverse PRIME to check if I can make it work that way but failed to do so following official nvidia docs.
If anyone knows how to make that work please let me know!

Now I am currently running a laptop screen with 2 external monitors enabled (one via USB type C and other via HDMI).

The solution for me:

After first installation mhwd -li would show below:

$ mhwd -li
> Installed PCI configs:
NAME               VERSION          FREEDRIVER           TYPE
video-linux            2021.08.29                true            PCI
video-nvidia-prime-render-offload            2023.01.15               false            PCI

so I ended up removing that driver and installing nvidia-dkms instead and garuda-optimus-manager-config which enabled me to use 2nd screen. I am always booting into nvidia card mode (rather than hybrid).

NAME               VERSION          FREEDRIVER           TYPE
video-linux            2021.08.29                true            PCI
video-nvidia-dkms            2023.01.15               false            PCI

Hope this helps!

1 Like