Yellow tint on RTX 3080 makes it nearly impossible to install garuda

I got a new machine recently with an RTX 3080 GPU. When going to install garuda gnome (8-22-2022) my full screen is badly tinted yellow. So bad I can't even see what is going on. If I switch to TTY then I can see just fine. I managed to install by doing side-by-side VM install on my other machine to know what to do. After install and upgrade the yellow tint is still there. I also installed teamviewer and logged in from another computer and see normal screen from the teamviewer client. I also have windows installed and it works great. I tried installing archlinux with the gnome DE and that works great (both open source and nvidia-open).

I found this other thread which seems similar:

The strange part is if I try to install dragonized KDE then there is no yellow tint issue.

There are other bugs preventing install/use of proprietary drivers for the RTX 3080 (see NVIDIA - ArchWiki) and the linux-zen kernel doesn't seem to support nvidia-open kernel drivers which work on archlinux linux image but not linux-zen.

Considering that I must use the open source drivers with linux-zen image, at least for now, is there a timeframe to fix the yellow tint?

1 Like

@TNE I saw you commented on the other thread about a

shared library bug

Does this seem to be the same issue? I did try the latest ISO from today.

I don't know what you're talking about really sorry, it just doesn't make sense to me.

Uhhhh what? I use the proprietary drivers on them for years now.

In Garuda Linux, you don't have to do ANYTHING to make the Nvidia drivers work. Just select proprietary drivers in grub and don't mess around with nvidia-open, etc.

1 Like

Launch GNOME's settings app and adjust colors from there. Also DKMS drivers ie. nvidia-dkms are compatible with different kernels.

I have too and it usually works fine, but the new card I have causes kernel crash and it can't boot or run with proprietary drivers. Besides, telling me to use proprietary instead of open drivers is a total cop-out answer, the open source drivers should still work. The reason I can't use nvidia is why I linked to the arch wiki in my post which says:

I tried the kernel parameter ibt=off but that didn't seem to help at all. So yes there is a big problem with the yellow screen and this is the closest thing I can figure out that is the problem. But perhaps it is a different issue completely. Using proprietary drivers causes a crash and is not a possible solution at this time. I haven't collected any logs because the system freezes.

Installing gnome with archlinux works, so there must be some setting that is causing the issue, perhaps wayland?

I'm not allowed to change colors in the settings.

Oh, and also one other point of data. The boot screen with the hawk head and loading bar that is there when booting and shutting down shows up without the yellow tint

1 Like

After a little more testing and restoring snapshots I have figured out a few more things.

Installing nvidia-dkms and reboot causes kernel BUG and GPU freeze on linux-zen. I can still ping it but display not responsive. Then I tried plugging in HDMI to motherboard and find that I can only access TTY consoles. After examining the dmesg log I see it is the same problem as https://bugs.archlinux.org/task/74886

I tried setting ibt=off again and this time it worked and loads without yellow tint. Though it strangely only allows TTY access from the motherboard HDMI, not the GPU HDMI.

I also just realized there is a nvidia-open-dkms which I tried and works without the ibt=off kernel parameter hack on linux-zen image.

So having confirmed my proprietary drivers problem needs an upstream fix per the wiki page, there is still the issue of the yellow tint on open source drivers. I do think that needs to be fixed because it is completely unusable.

I'm having same problem after updating to latest linux-zen and nvidia-dkms.

Worked fine until now - maybe wait for a fix?

1 Like

Interesting :thinking:

Although I have an AMD GPU (6800XT) I had driver issues as well and it also came from the latest kernel update.
I could resolve my issues with "simply" reinstalling my whole drivers package but it is pain in the butt. Something went wrong there I guess......

2 Likes