Yakuake not working properly

My garuda-inxi is

╭─[email protected] in ~ as 🧙 took 3s
╰─λ garuda-inxi
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_ADDRESS = "en_AG",
LC_NAME = "en_AG",
LC_MONETARY = "en_AG",
LC_PAPER = "en_AG",
LC_IDENTIFICATION = "en_AG",
LC_TELEPHONE = "en_AG",
LC_MEASUREMENT = "en_AG",
LC_TIME = "en_DE.UTF-8",
LC_NUMERIC = "en_AG",
LANG = "en_GB.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
System:
Kernel: 5.18.15-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d216e2f9-c931-43ca-8670-f2b5172b1b03 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=10467cbe-370b-4a44-8b00-387651be0571 loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0
serial: <superuser required> UEFI: American Megatrends LLC. v: H.H0
date: 05/19/2022
CPU:
Info: model: AMD Ryzen 7 3800X bits: 64 type: MT MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3882 high: 4450 min/max: 2200/4559 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4027 2: 4091
3: 4093 4: 3649 5: 3601 6: 3602 7: 3614 8: 4414 9: 4124 10: 4450 11: 3600
12: 3643 13: 4095 14: 3896 15: 3619 16: 3602 bogomips: 124811
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Sapphire
driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
empty: DP-2,DP-3,HDMI-A-1 bus-ID: 2f:00.0 chip-ID: 1002:73bf
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: DP-1 mapped: DisplayPort-0 model: MSI MAG271C serial: <filter>
built: 2019 res: 1920x1080 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 6800 (sienna_cichlid LLVM 14.0.6 DRM 3.46
5.18.15-zen1-1-zen) v: 4.6 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
bus-ID: 5-3.1:3 pcie: gen: 4 chip-ID: 1b1c:0a6b class-ID: 0300
speed: 16 GT/s serial: <filter> lanes: 16 bus-ID: 2f:00.1
chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI X570-A PRO
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Corsair HS80 RGB Wireless Gaming Receiver type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.15-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 2.73 TiB used: 818.87 GiB (29.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte
model: GP-ASM2NE6500GTTD size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EGFM13.0 temp: 46.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 970 EVO Plus
500GB size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7
temp: 35.9 C scheme: MBR
ID-3: /dev/nvme2n1 maj-min: 259:6 vendor: Western Digital model: WD BLACK
SN750 SE 1TB size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 711240WD
temp: 34.9 C scheme: GPT
ID-4: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
Partition:
ID-1: / raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 127.26 GiB
(29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 127.26
GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 127.26
GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 431.07 GiB size: 431.07 GiB (100.00%) used: 127.26
GiB (29.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 1.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.39 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 42.4 C mobo: 34.0 C gpu: amdgpu temp: 41.0 C
mem: 42.0 C
Fan Speeds (RPM): fan-1: 807 fan-2: 905 fan-3: 909 fan-4: 703 fan-5: 652
fan-6: 0 fan-7: 0 gpu: amdgpu fan: 0
Info:
Processes: 395 Uptime: 13m wakeups: 0 Memory: 31.27 GiB used: 4.85 GiB
(15.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.0 Packages: pacman: 1943 lib: 562 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-07-28
Last full system update: 2022-08-03 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Though not sure how that'll help here. ^^ My Yakuake has a weird issue: It doesn't "build up" right, meaning that after pressing F12, first there'll be half of and then like 10ms later it'll be open fully. Which is annoying...

Well in my quest to show you I have learned how to record my screen so here u can see it:

https://www.veed.io/view/645fc95e-9bc7-4179-8baa-b2970aa72a6f

Dunno, probably someone already had the issue and I just couldn't find it. Help would be very much appreciated. Thanks

Have you tried changing the Yakuake screen dimensions in its settings to see if that makes any difference?

Have you searched for similar pre-existing Yakuake bug reports?

Does the same thing happen if you change the settings to activate Yakuake by the position of your mouse cursor?

5 Likes

Well... I have just found out that adding the title bar which I have removed before fixes the issue.

I guess I'll leave it there then? Still, strange. Screen dimensions and mouse cursor doesn't seem to do anything. And I cannot find others with the same issue.

1 Like

What do you see in yakuakerc? Have you tried changing skin?
Here's mine:
cat ~/.config/yakuakerc

[Animation]
Frames=10

[Appearance]
BackgroundColorOpacity=40
Skin=materia-dark
SkinInstalledWithKns=true
TerminalHighlightOnManualActivation=true
Translucency=true

[Desktop Entry]
DefaultProfile=Garuda.profile

[Dialogs]
FirstRun=false

[KFileDialog Settings]
Recent Files[$e]=trashme.txt,file:$HOME/trashme.txt
Recent URLs[$e]=file:$HOME/
detailViewIconSize=16

[SaveHistory Settings]
Recent URLs[$e]=file:$HOME

[Window]
Height=98
1 Like

I suspect this may have something to do with applying non-default skins or system theming.

1 Like

Naa, haven't done anything in the RC.

This is mine

[Dialogs]
FirstRun=false

[Window]
Height=30
ShowSystrayIcon=false
ShowTabBar=false
Width=60

Edit: Well, tbh I don't care too much if there's a title bar or not, so I'll just leave it there and mark this thread as solved. :wink: Thanks you guys

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.