XFCE-lite on uefi32

It seems that the 2GB RAM requirement is a true minimum. My 2-in-1 laptop shares its 2GB with the integrated video hardware. I was able to boot GARUDA-XFCE (lite) (the ISO lightly modified for uefi32). Conky shows about 98MB free when idling at the liveUSB desktop. When I launch a terminal emulator, the terminal usually crashes and free memory briefly drops into the 20MB’s.

My question is: given how tight the RAM is with XFCE on my device, is it worth downloading the lxqt-kwin ISO? I like the concept here, but is my Asus T100CHI just too limited for Garuda?

1 Like

may be

to be honest we did not care about ram usage
only focused on performance
so ram usage is a bit higher.

as we want a fast experience.

you can uninstall preload

it will drop the ram usage

1 Like

At the grub menu I pressed ‘e’ to add 3 to the set parameters line and then booted to a terminal. I ran pacman -Sy and tried to uninstalled preload - it has some dependencies!

sudo pacman -R preload performance-tweaks garuda-xfce-settings

This started Garuda and I actually saw the welcome screen. Previously, the welcome screen flashed once before disappearing and terminal now stays open. However, free memory is still low and firefox won’t start. I think I need to install to a USB on my desktop and then boot that USB on my T100CHI after removing just preload.

1 Like

to remove preload only


sudo pacman -Rdd preload

but i think 2gb is still too low

maybe you need very lightweight os

which garuda isnt

may be i think i will make

garuda wayfire edition

which is wayland

it will be lightweight


I agree that 2 GB may be too low. Conky only reports 1.82GB total available (the rest is video ram.)
Thanks for the guidance!


hi – is there a way to get this modified iso without handcraft



Without handcraft for you or for us? :wink:

1 Like

I never got past the testing the desktop with the liveUSB. It was too unstable to risk trying the installer. I wouldn’t post something that I can’t verify works.

1 Like

I’ve modified the 7/27 version of the lxqt-lite ISO. The live desktop is stable but I’ve had two hangs (freeze/lock up) on my baytrail. I’m trying again with some extra kernel args to set clock source (tsc) and to limit cstates. I’ll report back if this works. No news means I couldn’t get it working!
(Edit: firefox still won’t start - probably running out of memory. Otherwise, the live desktop has been stable so far.)

Exploring the live desktop, I really like how the welcome app has quick access to the tools and maintenance. I’ll have to try Garuda on a more capable system.