XF86* Media Keys Not Working in AwesomeWM

Edit: The keys have started working now for some reason. I have since rebooted, but when I was previously troubleshooting and rebooted it did nothing. I'm not sure why they've started working again, but hey, I'm not going to complain.


Heyo, I'm getting started with AwesomeWM, and I'm having some issues with media keys. They work fine under the GNOME session (xev doesn't show XF86AudioPlay, but it picks up the keypress), and they're picked up fine under the awesome-gnome session (XF86AudioPlay is detected) as well, but xev shows nothing while pressing the media keys on the awesome session.

I removed the keys from my awesome config and tried again with xev, but still no dice.

I plugged in a second keyboard, and it was picking up the keys just fine.

My main keyboard is a Ducky One 2 TKL, which doesn't have media keys, but it can emulate media keys with Fn+Win+D. This is the keypress that isn't picked up. I've also bound that to a separate key, and that keybind didn't behave any differently from just hitting Fn+Win+D, but I wouldn't expect it to.

I'm not sure where else to go from this point, other than re-binding the keys to a different keypress and using that for play/pause from within awesome, but that's a workaround that I shouldn't have to do.

Any help is appreciated, and if you need more info that isn't included below let me know, and I will provide.

inxi -Faz output
System:    Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=4112f275-2336-4419-a2e8-3866ae67cb4e rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: awesome 4.3-1086-g13cd20780 info: kdocker vt: 2 dm: GDM 40.1 Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7C84 v: 1.0 serial: <filter> 
           Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84) v: 1.0 serial: <filter> UEFI: American Megatrends LLC. 
           v: 1.50 date: 01/20/2021 
Battery:   Device-1: hidpp_battery_0 model: Logitech G604 Wireless Gaming Mouse serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: 12-Core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25) model-id: 21 (33) 
           stepping: 0 microcode: A201009 cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 177605 
           Speed: 3595 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 3595 2: 3599 3: 3594 4: 3591 5: 3589 
           6: 3598 7: 3593 8: 3593 9: 3599 10: 3599 11: 3590 12: 3586 13: 3600 14: 3600 15: 3596 16: 3775 17: 3598 18: 3592 
           19: 3598 20: 3591 21: 3599 22: 3602 23: 3599 24: 3657 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 470.63.01 
           alternate: nouveau,nvidia_drm bus-ID: 24:00.0 chip-ID: 10de:13c2 class-ID: 0300 
           Display: x11 server: X.Org 1.20.13 compositor: picom v: git-a8445 driver: loaded: nvidia display-ID: :1 screens: 1 
           Screen-1: 0 s-res: 6400x2160 s-dpi: 108 s-size: 1505x513mm (59.3x20.2") s-diag: 1590mm (62.6") 
           Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 160 size: 608x345mm (23.9x13.6") diag: 699mm (27.5") 
           Monitor-2: DP-0 res: 2560x1440 hz: 144 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:     Device-1: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 24:00.1 
           chip-ID: 10de:0fbb class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus-ID: 2e:00.4 chip-ID: 1022:1487 class-ID: 0403 
           Device-3: SteelSeries ApS SteelSeries Arctis 7 type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-3:2 
           chip-ID: 1038:12ad class-ID: 0300 
           Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel port: e000 bus-ID: 26:00.0 
           chip-ID: 10ec:8125 class-ID: 0200 
           IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 28:00.0 chip-ID: 8086:2723 
           class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
           IF-ID-2: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:0029 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Drives:    Local Storage: total: 3.64 TiB used: 533.08 GiB (14.3%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDS100T3X0C-00SJG0 size: 931.51 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 111110WD temp: 48.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1B6Q scheme: GPT 
           ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0A80 scheme: GPT 
           ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD7502AAEX-00Y9A0 size: 698.64 GiB block-size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1D05 scheme: GPT 
Partition: ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 134.35 GiB (57.8%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 27.9 MiB (9.3%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 134.35 GiB (57.8%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 134.35 GiB (57.8%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%) used: 134.35 GiB (57.8%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 15.55 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 45.0 C mobo: 45.0 C gpu: nvidia temp: 59 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 1010 fan-3: 714 fan-4: 713 fan-5: 905 fan-6: 0 fan-7: 1468 gpu: nvidia fan: 28% 
Info:      Processes: 540 Uptime: 21m wakeups: 2 Memory: 15.55 GiB used: 5.1 GiB (32.8%) Init: systemd v: 249 tool: systemctl 
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1844 pacman: 1838 lib: 413 flatpak: 6 Shell: Zsh v: 5.8 
           running-in: kitty inxi: 3.3.06 

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.