Xbox One S controller is not detected by Garuda

Also try other usb ports, reconnect controller. The usual…

I am using the Wireless controller straight with USB cabel.

I have to start the service every time i start my PC or otherwise my controller is seen as a gc101 and the button layout is all wrong, so maybe that will help you as well.
sudo systemctl start xboxdrv.service

1 Like

You can configure a service to start automatically every time you start your computer by using systemd’s “enable” function like so:

sudo systemctl enable xboxdrv.service

You can also simultaneously start and enable a service by adding the “--now” flag.

sudo systemctl enable --now xboxdrv.service

Once it is enabled, you shouldn’t have to start it anymore–it will start up on it’s own.

1 Like