WoW Dragonflight Unstable

System Specs:
AMD 3600
Nvidia 3060ti
32 GB ram
500 GB nvme drive - only linux installed

System:
  Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=4757eb94-0065-4f96-8914-c77c06fa1e7d rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=d3701c73-f146-42e6-9957-47e42ad885dd loglevel=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Micro-Star product: MS-7C37 v: 3.0
    serial: <superuser required>
  Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0
    serial: <superuser required> UEFI: American Megatrends v: H.20
    date: 07/03/2019
Battery:
  Device-1: hidpp_battery_2 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3924 high: 4097 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3600 2: 3600
    3: 4078 4: 4075 5: 4095 6: 4097 7: 3728 8: 3600 9: 4094 10: 4070 11: 3983
    12: 4075 bogomips: 86401
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] vendor: ASUSTeK
    driver: nvidia v: 525.53 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 2d:00.0
    chip-ID: 10de:2489 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: N/A display-ID: :1 screens: 1
  Screen-1: 0 s-res: 4880x2560 s-dpi: 96 s-size: 1291x677mm (50.83x26.65")
    s-diag: 1458mm (57.39")
  Monitor-1: DP-2 pos: top-left res: 1440x2560 hz: 60 dpi: 118
    size: 311x553mm (12.24x21.77") diag: 634mm (24.98") modes: N/A
  Monitor-2: HDMI-0 pos: primary,bottom-r res: 3440x1440 hz: 60 dpi: 109
    size: 798x335mm (31.42x13.19") diag: 865mm (34.07") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.53 renderer: NVIDIA GeForce RTX 3060
    Ti/PCIe/SSE2 direct render: Yes
Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2d:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI X570-A PRO
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 5-3.3:3 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 1.36 TiB used: 115.68 GiB (8.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 34.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-00WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: MBR
Partition:
  ID-1: / raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
    used: 115.68 GiB (26.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
    used: 115.68 GiB (26.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
    used: 115.68 GiB (26.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 431.04 GiB size: 431.04 GiB (100.00%)
    used: 115.68 GiB (26.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.3 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 34.42 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 48.4 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 388 Uptime: 1d 51m wakeups: 8 Memory: 31.3 GiB
  used: 9.43 GiB (30.1%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1443
  libs: 450 tools: octopi,pamac,paru Shell: fish v: 3.5.1 default: Bash
  v: 5.1.16 running-in: gnome-terminal inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-05
  Last full system update: 2022-11-17
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:      

Not sure if this is the right spot for this, but I'm trying to sus out a very specific problem:
WoW dragonflight is incredibly unstable while playing. I say specific because WoW Classic (currently wrath of the lich king) has zero issues with a ton of addons. And I've re-installed wow dragonflight and tried to play with zero addons and it is still very unstable.
Battle.net and everything else I've tried to run is rock solid.

Things I've done:
I've updated everything I could to the latest versions, including drivers for my gpu. (if I missed something, please let me know)

I've gone through the graphical settings and tuned each setting to see if there was a specific culprit. There is some weird interplay between "view distance", "environmental detail" and "ground clutter". If anyone of them is turned up, then the other 2 must be at 1(lowest setting) otherwise the UI bugs out and the game will crash within seconds. If I don't have those on, it lasts for about 30-45 minutes and then will crash without warning.

I realize this is an incredibly narrow problem, but I'm hoping there's at least one other user out there that has experienced this. also, I've googled around and haven't found this issue on other forums, at least not yet. If there is a better forum to ask this kind of question please let me know.

Thanks in advance!

Didn't Dragonflight just come out? If so, there may be bugs with the game itself and/or no proper linux implementation is available yet for it. Just my 2 cents

So, I've now reproduced the error in WotLK classic. It requires certain environmental effects to be present, which I guess were somewhat new when WotLK original came out over a decade ago, so they don't have many areas with them. However, Dragonflight apparently uses them all over. Which explains what I was experiencing.

I don't know what the deal is, but I'd hate to have to play the game on the lowest settings when my hardware can rip through it no problem. Looking up guide for dual booting windows......