Wireless Connection on keyboard breaks?


Recently I’ve received a new computer keyboard (Logitech G 915 TKL) to my birthday and it doesn’t seem to correctly work on linux.
While connected with a cable every button works as normal and I can do everything I’d need to.
When connected via the Logitech Lightspeed Connection however, all buttons are basically randomly assigned. For example:
S => A
C => E
Enter => M
Return => E

I also can’t connect it via bluetooth I’d like to check if the issue persists there too but I can’t seem to be able to properly connect it. When trying I press the pairing button and connect it to my system. Shortly after it just disconnects.
This happens with my PS4 Controller too so this appears to be a different issue.

I don’t have a way to test this keyboard on windows sadly. Could it work via VM maybe?

If there’s anything else I can try please just let me know and I’ll do my best to help :slight_smile:

Thanks for your read.

P.S.: These are some articles I’ve had a read through but they appear to be about lightning issues mostly which is not a concern for me rn:

  Kernel: 6.6.1-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
    root=UUID=43b24c17-d93b-422c-86a9-512969a67d2a rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
    serial: <filter> UEFI: American Megatrends v: 4702 date: 10/20/2023
  ID-1: hidpp_battery_0 charge: 99% condition: N/A volts: 4.2 min: N/A
    model: Logitech G915 TKL LIGHTSPEED Wireless RGB Mechanical Gaming Keyboard
    type: N/A serial: <filter> status: full
  Info: model: AMD Ryzen 7 5800X socket: AM4 bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA20102B
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 927 high: 3599 min/max: 550/4851 base/boost: 3800/4850
    scaling: driver: amd-pstate-epp governor: powersave volts: 1.1 V
    ext-clock: 100 MHz cores: 1: 550 2: 550 3: 550 4: 550 5: 550 6: 550
    7: 3541 8: 3599 9: 550 10: 550 11: 550 12: 550 13: 550 14: 550 15: 550
    16: 550 bogomips: 121633
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] driver: nvidia v: 545.29.02
    alternate: nvidia_drm non-free: 545.xx+ status: current (as of 2023-10;
    EOL~2026-12-xx) arch: Maxwell code: GMxxx process: TSMC 28nm
    built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 0a:00.0 chip-ID: 10de:17c8 class-ID: 0300
  Device-2: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2
    chip-ID: 046d:08e5 class-ID: 0102
  Display: server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: nvidia gpu: nvidia display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.73x11.85")
    s-diag: 1102mm (43.38")
  Monitor-1: DP-1 pos: primary,left res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  Monitor-2: DP-3 pos: right res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.02
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 980 Ti/PCIe/SSE2
    memory: 5.86 GiB
  API: Vulkan v: 1.3.269 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 980 Ti driver: nvidia v: 545.29.02 device-ID: 10de:17c8
    surfaces: xcb,xlib
  Device-1: NVIDIA GM200 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.1 chip-ID: 10de:0fb0
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2
    chip-ID: 046d:08e5 class-ID: 0102
  Device-4: Focusrite-Novation Focusrite Scarlett 2i2 2nd Gen
    driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 5-2:3 chip-ID: 1235:8202 class-ID: 0102
  API: ALSA v: k6.6.1-AMD-znver3 status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.84 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 05:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-6:7 chip-ID: 8087:0029
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 5.68 TiB used: 1.33 TiB (23.4%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 3B2QEXM7 temp: 39.9 C scheme: GPT
  SMART: yes health: PASSED on: 290d 23h cycles: 993
    read-units: 31,485,603 [16.1 TB] written-units: 128,605,460 [65.8 TB]
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 4TB
    family: based SSDs size: 3.64 TiB block-size: physical: 512 B logical: 512 B
    sata: 3.3 speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 2B6Q
    temp: 27 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 1y 29d 8h cycles: 1048
    written: 23.89 TiB
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 EVO 1TB
    family: based SSDs size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.3 speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 1B6Q temp: 26 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 371d 2h cycles: 992
    written: 6.84 TiB Pre-Fail: reallocated sector: 98 threshold: 10
  ID-4: /dev/sdc maj-min: 8:32 vendor: Toshiba model: Q300. size: 223.57 GiB
    block-size: physical: 512 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 12.3 temp: 25 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 3y 61d 6h cycles: 3494
  ID-5: /dev/sdd maj-min: 8:48 vendor: Verbatim model: STORE N GO
    size: 7.47 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 1.0
    scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 343.52 GiB (36.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 343.52 GiB (36.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 343.52 GiB (36.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 343.52 GiB (36.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 48.4 C mobo: N/A gpu: nvidia temp: 49 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 22%
  Processes: 430 Uptime: 55m wakeups: 0 Memory: total: 32 GiB
  available: 31.27 GiB used: 6.83 GiB (21.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1493 libs: 507 tools: pamac,paru Shell: garuda-inxi (sudo)
  default: Bash v: 5.2.15 running-in: gnome-terminal inxi: 3.3.31
Garuda (2.6.18-1):
  System install date:     2023-09-23
  Last full system update: 2023-11-09
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:  
  1. What are the results if you don’t use Logitech’s software?
  2. Does BT pair with any peripheral?
  3. Did you ever pair with anything in Windows–any BT device?
1 Like

if it’s bt connection, pair it with android device and check

Wine doesn’t support the software I’d need (G-Hub) Logitech G HUB Advanced Gaming Software, RGB & Game Profiles
I’d personally prefer to use that software since then I actually would know how to configure my things since I’ve used it on windows too.

Not as of my knowledge, I don’t have too many Bluetooth devices but I can say it doesn’t pair with my PS4 Controller or my Keyboard. I can try pairing my phone too to see how this goes.

On Windows I did pair my devices and everything went fine. Excluding the Keyboard I got now since I didn’t have it back when I had windows.

It offers 3 ways of connection:

  • Cable
  • Lightspeed (Logitechs proprietary connection)
  • Bluetooth

I can also try connecting it via bluetooth to my phone. I might also be able to connect it to my phone with logitechs connection. Just gotta find a Usb-C to Usb-A Adapter so I can plug the dongle in.

when you plug your keyboard, to garuda, can you check if your keyboard layout isn’t changing to any other?

if it has bt connection, no need to use logitech connection, just pure bt with android, try to pair it

The Keyboard layout was once my thought too, but I only have one setup (german no dead-keys) and it doesn’t change when plugin in the cable or connecting via lightspeed.

This is why I think it’s either a hardware faulty with their dongle/keyboard or an issue with linux and now I’m trying to figure out which of these apply.

i would drop using logitech app, try if it works nicely without it

Alright, I’m now connected via Bluetooth and it seems to work now?
Still a bit strange about that Lightspeed issue.

Now that I know that it doesn’t occur with Bluetooth or Cable connection the only reasonable thing to think is that whatever is using the logitech lightspeed connection is broken. :confused:

If you guys can think of anything else to try let me know, else I’ll send it back in around next week’ish.

Thanks for you help @Bro @wilk85

1 Like

here is some topic with issue you are facing

also check that topic, might be usefull



It has been my personal experience and that of others, that Windows can and does capture BT chipsets. Usually a hardware recognition setting in BIOS’ makes this possible for Windows. What has to happen is that your BIOS needs to re-capture this device, and the BIOS setting that allows or precludes full hardware recognition at-boot-- sometimes called Fastboot (1 of them) is responsible. Windows knew what hardware you have, Linux does not.

The 1st time I ran into this problem was in late 2019 on the Dell desktop I have now. Even Dell’s tech support was unaware of the cause/effect at that time. (Your BIOS is different than mine, but it’s still the same or similar damn setting.)

Anyway, your computer needs to fully scan & recognize your peripherals at boot. It’s usually a BIOS setting that needs to be changed/selected. Hence my Windows question.

Let us know how it goes. Good luck. :slight_smile:


The bug report you’ve got there is very interesting indeed since I just recently updated my kernel too, tho it was before I got this keyboard.

I’ll try another version too see if it occurs there. Might after all be the issue.

I believe to remember that I disabled fastboot back when installing garuda initially since it were mentioned as a “pre-requisite” or something along those lines.
Was that the option you were talking about?

also check if your motherboard do not have any newer bios version to upgrade to
sometimes it can change a lot

now probably you can install lower kernel version and check if issue still exists according to that issue topic

Supported operating systems:
LIGHTSPEED wireless technology: USB port and Windows® 7 or later, macOS X 10.11 or later, Bluetooth®: Bluetooth-enabled device with Windows® 8 or later, macOS later, iOS 10 or later, (Optional) Internet access and Windows® 7 or later (64-bit) or macOS X 10.11 or later for Logitech G HUB software

Try another kernel!

I am, but please check all bios settings again, ours have different BIOS manufacturers, and nomenclature varies. I really hope it’s something so simple and so common. And an easy fix. And if you haven’t already, please completely shutdown & power off, not. Unplug it if it is plugged in.

1 Like

I now am on the Linux LTS Kernel and the issue is resolved.

Conclusion: An issue with the zen kernel :confused:

I’ll check after some updates if the issue is still persisting.

Thanks everyone ^^


Please ask others for tales of the $$$ they wasted on some cool, new Windows device onloy to find out that it’s the software under Windows-only that provides those cool, new features. . :wink:

But you’re new to Linux and certainly can’t be blamed for not buying with Linux in mind. I’m sincere. I blame the software coders.


Do you know of a hardware brand that usually supports linux too?
I searched a bit and only found things like “these work best on linux but you can’t do x,y since it’s only suported on windows” but they don’t even offer a driver or software or anything to costumize it.

Is there really just nothing or can’t I just find it?

linux kernel has a ton of device drivers
but if you are looking for some dedicated apps like on windows, it might be hard

learn to live without it, like i do and many others


Aha! Then it was the newness of your hardware that required a less-than-stellar performing kernel. Zen & other performance kernels will catch up with your new hardware in a short amount of time. Linux is incredible at hardware recog. nowadays, but newer things take a wee amount of time.

Excellent you’re up & running everything!

Welcome to (Garuda) Linux. We may not keep the lights on for you, but we’ll teach you how to build a lightbulb! :rofl:

//kicks self for only considering low-level stuff. :smiley: