Wireguard Issues

I have just installed (and am quite happy with) Garuda. Things are working well, and all of my OpenVPN profiles imported without issue. Wireguard, in contrast, has not.

When attempting to import or create fresh profiles, the computer is able to connect to, but gains no network connectivity with the VPN server computer or any computers on the subnet.

I have tried the wg command, and it appears parsing conf files is having a bit of an issue.

I am not conversant enough with Linux to be able to deterine much more than that.

Here is the output from wg:

wg setconf wg0 test.conf

I get the following returned:

Line unrecognized: `Address=10.6.0.29/24'
Configuration parsing error

I notice that the GUI reports an IP address of 10.6.0.0 for the IP which I have changed to the .29 in the config file, but even with that change, the connection doesn't allow me to even ping 10.6.0.1

I think that maybe the whole Wireguard impelementation is borked, but I have tried reinstalling via AUR and via regular repositories, but haven't made any progress.

Thanks for any help you can offer!

In which case, why are you using Wireguard? It's not exactly a "click and play" bit of software.

The Wireguard module is in the kernel, and the tools are in the repos, so I have no idea what you are installing from the AUR.

You might want to provide more details, or ask for help with Wireguard via the Wireguard help channels.

3 Likes

@johnathon -
Will direct my questions to Wireguard direct, As I've setup WG on 20+ workstations and multiple servers to create my endpoints, I guess saying that I'm not conversant enough just meant that I don't know what else to do other than the normal procedure of troubleshooting. I had tried all avenues I was aware of prior to attempting the AUR since some of the other software I was using didn't work until I obtained updated versions through the AUR . (I am new to arch having been Debian based 10 or so years).

But thank you for your conscientious response. sorry to have taken your time.