Wine-valve taking a lot of time to build

Hey,
So i was trying to install proton but an app wine-valve is building for more than an hour.So could someone plz tell if there is some error ,is it normal for it to take so much time??

BTW,inxi is

System:    Kernel: 5.13.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=78959370-4cf4-4fbb-90fc-a7d8aec52d4b  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=2dd80801-8559-438b-883d-4a4cc0f3c30d loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Acer product: Acer one 14 Z422 v: N/A serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: Acer model: Acer one 14 Z422 serial: <filter> BIOS: American Megatrends v: 1.01  
date: 07/20/2017  
Battery:   ID-1: BAT0 charge: 37.7 Wh (96.9%) condition: 38.9/47.5 Wh (81.8%) volts: 12.5 min: 10.8  
model: standard type: Li-ion serial: <filter> status: Charging  
Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K230 serial: <filter>  
charge: 100% (should be ignored) rechargeable: yes status: Discharging  
CPU:       Info: Quad Core model: AMD A6-7310 APU with AMD Radeon R4 Graphics bits: 64 type: MCP  
arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 microcode: 7030105 cache: L2: 2 MiB  
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 15970  
Speed: 1797 MHz min/max: 1000/2000 MHz boost: enabled Core speeds (MHz): 1: 1797 2: 1797  
3: 1797 4: 1797  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Holco Enterprise Co /Shuttle  
driver: radeon v: kernel alternate: amdgpu bus-ID: 00:01.0 chip-ID: 1002:9851 class-ID: 0300  
Device-2: Chicony USB 2.0 Camera type: USB driver: uvcvideo bus-ID: 2-1.3:4 chip-ID: 04f2:b539  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: ati,radeon  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")  
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8") diag: 354mm (13.9")  
OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.13.7-zen1-1-zen LLVM 12.0.1) v: 4.5 Mesa 21.1.6  
direct render: Yes  
Audio:     Device-1: AMD Kabini HDMI/DP Audio vendor: Holco Enterprise Co /Shuttle driver: snd_hda_intel  
v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403  
Device-2: AMD FCH Azalia vendor: Holco Enterprise Co /Shuttle driver: snd_hda_intel v: kernel  
bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403  
Sound Server-1: ALSA v: k5.13.7-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: yes  
Sound Server-4: PipeWire v: 0.3.32 running: yes  
Network:   Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: AzureWave driver: rtl8723be  
v: kernel port: e000 bus-ID: 01:00.0 chip-ID: 10ec:b723 class-ID: 0280  
IF: wlp1s0 state: up mac: <filter>  
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet  
vendor: Holco Enterprise Co /Shuttle driver: r8169 v: kernel port: d000 bus-ID: 02:00.1  
chip-ID: 10ec:8168 class-ID: 0200  
IF: enp2s0f1 state: down mac: <filter>  
Bluetooth: Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 2-1.2:3  
chip-ID: 13d3:3416 class-ID: e001 serial: <filter>  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
Drives:    Local Storage: total: 232.89 GiB used: 39.65 GiB (17.0%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB block-size:  
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023 scheme: MBR  
Partition: ID-1: / raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 22.09 GiB (29.6%) fs: btrfs  
dev: /dev/sda2 maj-min: 8:2  
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 4 KiB (0.0%) fs: vfat  
dev: /dev/sda1 maj-min: 8:1  
ID-3: /home raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 22.09 GiB (29.6%) fs: btrfs  
dev: /dev/sda2 maj-min: 8:2  
ID-4: /var/log raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 22.09 GiB (29.6%) fs: btrfs  
dev: /dev/sda2 maj-min: 8:2  
ID-5: /var/tmp raw-size: 74.6 GiB size: 74.6 GiB (100.00%) used: 22.09 GiB (29.6%) fs: btrfs  
dev: /dev/sda2 maj-min: 8:2  
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)  
ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3  
maj-min: 8:3  
ID-2: swap-2 type: zram size: 3.64 GiB used: 2.21 GiB (60.8%) priority: 100 dev: /dev/zram0  
Sensors:   System Temperatures: cpu: 81.0 C mobo: N/A gpu: radeon temp: 84.0 C  
Fan Speeds (RPM): N/A  
Info:      Processes: 254 Uptime: 7h 9m wakeups: 44 Memory: 3.64 GiB used: 3.36 GiB (92.4%) Init: systemd  
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1550 lib: 461  
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Anytime you install from sources, building can take a while. Wine-valve has a HUGE number of dependencies. An all-day build on some computers, I'm sure.

Further, it seems to not build or is problematic for a number of people--read the Comments on the AUR page.

Have you tried the -git version yet?

5 Likes

Then i was using package installer.
I checked if al dependancies are there.All were already there.
Now i tried to install using git clone .
This shows again and again

<command-line>: warning: "_FORTIFY_SOURCE" redefined
<command-line>: note: this is the location of the previous definition
gcc -m64 -c -o libs/port/getopt.o ../wine-experimental-wine-6.3-20210616/libs/port/getopt.c -Ilibs/port \
-I../wine-experimental-wine-6.3-20210616/libs/port -Iinclude \
-I../wine-experimental-wine-6.3-20210616/include -D__WINESRC__ -D_REENTRANT -fPIC \
-fasynchronous-unwind-tables -Wall -pipe -fcf-protection=none -fno-stack-protector \
-fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers \
-Wno-packed-not-aligned -Wshift-overflow=2 -Wstrict-prototypes -Wtype-limits \
-Wunused-but-set-parameter -Wvla -Wwrite-strings -Wpointer-arith -Wlogical-op -march=x86-64 -mtune=generic -
O2 -pipe  -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-
protection -fcf-protection -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
<command-line>: warning: "_FORTIFY_SOURCE" redefined
<command-line>: note: this is the location of the previous definition
gcc -m64 -c -o libs/port/lstat.o ../wine-experimental-wine-6.3-20210616/libs/port/lstat.c -Ilibs/port \
-I../wine-experimental-wine-6.3-20210616/libs/port -Iinclude \
-I../wine-experimental-wine-6.3-20210616/include -D__WINESRC__ -D_REENTRANT -fPIC \
-fasynchronous-unwind-tables -Wall -pipe -fcf-protection=none -fno-stack-protector \
-fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers \
-Wno-packed-not-aligned -Wshift-overflow=2 -Wstrict-prototypes -Wtype-limits \
-Wunused-but-set-parameter -Wvla -Wwrite-strings -Wpointer-arith -Wlogical-op -march=x86-64 -mtune=generic -
O2 -pipe  -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-
protection -fcf-protection -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
<command-line>: warning: "_FORTIFY_SOURCE" redefined
<command-line>: note: this is the location of the previous definition
gcc -m64 -c -o libs/port/mkstemps.o ../wine-experimental-wine-6.3-20210616/libs/port/mkstemps.c -Ilibs/port \
-I../wine-experimental-wine-6.3-20210616/libs/port -Iinclude \
-I../wine-experimental-wine-6.3-20210616/include -D__WINESRC__ -D_REENTRANT -fPIC \
-fasynchronous-unwind-tables -Wall -pipe -fcf-protection=none -fno-stack-protector \
-fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers \
-Wno-packed-not-aligned -Wshift-overflow=2 -Wstrict-prototypes -Wtype-limits \
-Wunused-but-set-parameter -Wvla -Wwrite-strings -Wpointer-arith -Wlogical-op -march=x86-64 -mtune=generic -
O2 -pipe  -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-
protection -fcf-protection -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
<command-line>: warning: "_FORTIFY_SOURCE" redefined
<command-line>: note: this is the location of the previous definition
gcc -m64 -c -o libs/port/poll.o ../wine-experimental-wine-6.3-20210616/libs/port/poll.c -Ilibs/port \
-I../wine-experimental-wine-6.3-20210616/libs/port -Iinclude \
-I../wine-experimental-wine-6.3-20210616/include -D__WINESRC__ -D_REENTRANT -fPIC \
-fasynchronous-unwind-tables -Wall -pipe -fcf-protection=none -fno-stack-protector \
-fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers \
-Wno-packed-not-aligned -Wshift-overflow=2 -Wstrict-prototypes -Wtype-limits \
-Wunused-but-set-parameter -Wvla -Wwrite-strings -Wpointer-arith -Wlogical-op -march=x86-64 -mtune=generic -
O2 -pipe  -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-
protection -fcf-protection -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
<command-line>: warning: "_FORTIFY_SOURCE" redefined
<command-line>: note: this is the location of the previous definition
gcc -m64 -c -o libs/port/pread.o ../wine-experimental-wine-6.3-20210616/libs/port/pread.c -Ilibs/port \
-I../wine-experimental-wine-6.3-20210616/libs/port -Iinclude \
-I../wine-experimental-wine-6.3-20210616/include -D__WINESRC__ -D_REENTRANT -fPIC \
-fasynchronous-unwind-tables -Wall -pipe -fcf-protection=none -fno-stack-protector \
-fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers \
-Wno-packed-not-aligned -Wshift-overflow=2 -Wstrict-prototypes -Wtype-limits \
-Wunused-but-set-parameter -Wvla -Wwrite-strings -Wpointer-arith -Wlogical-op -march=x86-64 -mtune=generic -
O2 -pipe  -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-
protection -fcf-protection -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
<command-line>: warning: "_FORTIFY_SOURCE" redefined
<command-line>: note: this is the location of the previous definition
gcc -m64 -c -o libs/port/pwrite.o ../wine-experimental-wine-6.3-20210616/libs/port/pwrite.c -Ilibs/port \
-I../wine-experimental-wine-6.3-20210616/libs/port -Iinclude \
-I../wine-experimental-wine-6.3-20210616/include -D__WINESRC__ -D_REENTRANT -fPIC \
-fasynchronous-unwind-tables -Wall -pipe -fcf-protection=none -fno-stack-protector \
-fno-strict-aliasing -Wdeclaration-after-statement -Wempty-body -Wignored-qualifiers \
-Wno-packed-not-aligned -Wshift-overflow=2 -Wstrict-prototypes -Wtype-limits \
-Wunused-but-set-parameter -Wvla -Wwrite-strings -Wpointer-arith -Wlogical-op -march=x86-64 -mtune=generic -
O2 -pipe  -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-
protection -fcf-protection -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0

This is compilation output. You will have to wait some time for the compilation process to complete (or, quite possibly, fail... ).

4 Likes

i think its the second part :sweat_smile: :sweat_smile:
cuz it took about 3 hrs and yet job not finished-i had to interupt the process

you can install wine-tkg-staging-fsync-git or wine-tkg-fsync-git
from the chaotic-aur it has the valve patches installed and it is already compiled.

You just need to add WINEFSYNC=1 to your environment variable and it will work with valve.

if you run wineboot and you see "futex2: up and running" then the valve patch is working.

2 Likes

If it didn't end with an error then the build didn't fail. Compiling software can take a long time, which is why most people don't use Gentoo.

4 Likes

Or only once. :wink:

5 Likes

Things like this trigger my Gentoo explorations from time to time :rofl:

6 Likes