Windows NTFS drive not detect after restart

I have a ntfs drive which does not mount automatically and I have to run a command to do it

sudo mkdir /mnt/ntfs-broken
sudo mount -t ntfs-3g /dev/sda2 /mnt/ntfs-broken
mkdir: cannot create directory ‘/mnt/ntfs-broken’: File exists

after running above command it detect Ntfs data drive.
How to solve this so it detect automatically after reboot?
one more thing. I broke the windows installation and could not repair it but I still need the drive for the data and I do not have spare hdd to clear it and install it with fresh format and partitioning
garuda inxi

garuda-inxi
System:
Kernel: 6.6.12-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
v: 13.2.1 clocksource: tsc available: hpet,acpi_pm parameters: pti=on
page_alloc.shuffle=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
root=UUID=10b3e5d1-0274-4dc2-aaa2-ae6daa1710d0 rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 amdgpu.dc=0
ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH (MS-7A38) v: 4.0
serial: <superuser required> UEFI: American Megatrends LLC. v: M.I1
date: 05/16/2023
CPU:
Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen level: v3
note: check built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1
stepping: 1 microcode: 0x8001138
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2243 high: 3400 min/max: 1550/3200 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1550 2: 1274
3: 2320 4: 2722 5: 3400 6: 1360 7: 3206 8: 1343 9: 2272 10: 2720 11: 3400
12: 1360 bogomips: 76831
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Sapphire driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1, DP-2, DVI-D-1, HDMI-A-2
bus-ID: 29:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 48.0 C
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung S22E360
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 580 Series (radeonsi
polaris10 LLVM 16.0.6 DRM 3.54 6.6.12-hardened1-1-hardened)
device-ID: 1002:67df memory: 3.91 GiB unified: no
API: Vulkan v: 1.3.274 layers: 5 device: 0 type: discrete-gpu name: AMD
Radeon RX 580 Series (RADV POLARIS10) driver: mesa radv v: 23.3.3-arch1.1
device-ID: 1002:67df surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.3-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 2b:00.3 chip-ID: 1022:1457 class-ID: 0403
API: ALSA v: k6.6.12-hardened1-1-hardened status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
IF-ID-1: enp3s0f0u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:2
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 1.38 TiB used: 1.17 TiB (84.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P1SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P3CR010 temp: 35.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-00MFCA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A01 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: Cruzer Blade
size: 14.91 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 1.27 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 294.61 GiB (78.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.6 MiB (26.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 294.61 GiB (78.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 294.61 GiB (78.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 294.61 GiB (78.5%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.54 GiB used: 5.2 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.8 C mobo: N/A gpu: amdgpu temp: 48.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1852
Info:
Processes: 445 Uptime: 26m wakeups: 0 Memory: total: 16 GiB
available: 15.54 GiB used: 5.87 GiB (37.8%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0
pm: pacman pkgs: 1814 libs: 445 tools: octopi,pamac,paru pm: rpm pkgs: 0
Shell: fish v: 3.7.0 default: Bash v: 5.2.21 running-in: konsole
inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2022-05-25
Last full system update: 2024-01-21 ↻
Is partially upgraded:   No
Relevant software:       timeshift(custom) NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            dev-binderfs.mount nmb.service systemd-networkd-wait-online.service

You could mount it in the fstab. See e.g.
https://wiki.archlinux.org/title/NTFS-3G#Configuring

4 Likes

I would also suggest adding the nofail option to this fstab entry so that in the event your windows drive decides not to mount due to whatever reason like you plugged it out or it’s just not feeling it. You can still boot normally and are not dumped into emergency rescue mode.

6 Likes

Read the fstab examples from preexisting forum posts:

https://forum.garudalinux.org/search?q=%40tbg%20ntfs-3g%20nofail

4 Likes

The ‘swoosh’ says you need to reboot. So reboot please.

4 Likes

I realised that it is easier to format it and repartition. I read ntfs 3g and other forum but I did not understand fully. I realised I should just partition it natively in linux

i reboot many times but still i need to run

sudo mkdir /mnt/ntfs-broken
sudo mount -t ntfs-3g /dev/sda2 /mnt/ntfs-broken

for it to detect. earlier it was working without any intervention

Just make sure you don’t have fast startup or anything as such enabled. Btw I m also having the same issue but I don’t care about it :woozy_face: .

Check your dmesg for errors with ntfs3. Chances are the volume is still marked dirty, and ntfs3 will not mount a partition where that is the case without the force option. ntfsfix without any arguments will actively set the dirty bit, so that a chkdsk from Windows can do a real check/analysis. If you don’t have that handy and want to clear the dirty bit despite ntfsfix not being entirely a good checking tool you can pass the -d argument to ntfsfix
According to here at :ArchForums

I would recommend you to create a winpe usb and boot into it , then run chkdsk to repair any errors and corruption. After which you can try to mount it and it should mount with no issues. Also , please use exfat or ext4 or btrfs instead of this proprietary NTFS crap that tends to break from time to time.

2 Likes

I will read the whole forum word by word. But I am not that techie so i do not understand half of it. I AM JUST NEWBIE

I mean no need to read the wiki for this issue , although it would be nice if you do so if you’re curious .

I would recommend you to run this and see if it fixes the issue:

sudo ntfsfix -d /dev/sda2

Then try mounting it.
If It mounts successfully then see if it persists after a reboot.

1 Like

thanks man. this solved the problem

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.