Windows not found on grub bootloader

After running "garuda-inxi" command:

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f2325791-0031-49df-8130-94cedc16dd2c rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20392 v: Lenovo B40-70
serial: <superuser required> Chassis: type: 10 v: Lenovo B40-70
serial: <superuser required>
Mobo: LENOVO model: Lenovo B40-70 v: SDK0F82990WIN
serial: <superuser required> UEFI-[Legacy]: LENOVO v: 9DCN26WW(V2.07)
date: 09/23/2014
Battery:
ID-1: BAT1 charge: 6.7 Wh (97.1%) condition: 6.9/28.5 Wh (24.3%)
volts: 16.3 min: 14.4 model: LENOVO PABAS0241231 type: Li-ion
serial: <filter> status: charging
CPU:
Info: model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1596 high: 1597 min/max: 800/1600 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1597 2: 1597 3: 1596
4: 1596 bogomips: 13568
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a16
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: BOE Display 0x0644 built: 2015 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81")
diag: 354mm (13.9") ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2) v: 4.6 Mesa
22.2.1 direct render: Yes
Audio:
Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Lenovo driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 09:00.0 chip-ID: 168c:0036 class-ID: 0280
IF: wlp9s0 state: up mac: <filter>
Bluetooth:
Device-1: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
v: 0.8 bus-ID: 2-7:7 chip-ID: 0cf3:3004 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
Local Storage: total: 1.82 TiB used: 119.79 GiB (6.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: RSM4
scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10SPZX-24Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: MBR
Partition:
ID-1: / raw-size: 128.09 GiB size: 128.09 GiB (100.00%) used: 6.39 GiB
(5.0%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
ID-2: /boot/efi raw-size: 256 GiB size: 256 GiB (100.00%) used: 113.4 GiB
(44.3%) fs: ntfs dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 128.09 GiB size: 128.09 GiB (100.00%) used: 6.39
GiB (5.0%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
ID-4: /var/log raw-size: 128.09 GiB size: 128.09 GiB (100.00%) used: 6.39
GiB (5.0%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
ID-5: /var/tmp raw-size: 128.09 GiB size: 128.09 GiB (100.00%) used: 6.39
GiB (5.0%) fs: btrfs dev: /dev/sda6 maj-min: 8:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.55 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 195 Uptime: 6m wakeups: 1 Memory: 15.55 GiB used: 1.58 GiB
(10.2%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1137 libs: 301
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2023-01-24
Last full system update: 2023-01-24
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:
McFly: Importing shell history for the first time. This may take a minute or two...done."

I would like to dual boot Garuda and Windows. So installed Garuda on a new partion. Also the disk is in MBR. Now when I restarted it, the windows boot manager does is not there. Please help me with this.

Welcome :slight_smile:

In /etc/default/grub change to

GRUB_DISABLE_OS_PROBER=false

or # comment it.

Summary

Probing for other operating systems is disabled for security reasons. Read
documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
functionality install os-prober and uncomment to detect and include other
operating systems.

6 Likes

This seems really strange to me. The size, used space and fs.
It could be that you booted and installed in UEFI mode with your MBR disk, and maybe selected a wrong existing partition to install the bootloader. While Windows had been probably installed in BIOS mode.
See also here:
https://wiki.archlinux.org/title/Dual_boot_with_Windows#Bootloader_UEFI_vs_BIOS_limitations
If you can confirm in Windows that it was installed in BIOS mode (you should be still able to boot it from the BIOS), probably the easiest thing could be to reinstall Garuda in BIOS mode too.

5 Likes

Thanks :pray::handshake:
I have also updated Garuda now, it also points to same solution you mentioned. Thank you for active support. :v:
May God bless you. :heavy_heart_exclamation:

1 Like

Uhm. This is not a proper installation of Garuda Linux. None of your core packages seem to be up-to-date. What the hell did you do?

Run update remote fix in terminal to get your system back to a consistent state.

Or rather, I suspect you haven't run the setup assistant yet? You HAVE to run through the setup assistant, no wonder you don't have windows as an option right now.

5 Likes

Thanks for the notice. Yes, I have installed it in UEFI mode. Now changed it to legacy support.
Now that I have updated Garuda, os prober might automatically be turned on as @SGS mentioned.
Now Windows boot manager is visible on the bootloader.

Yes, I have updated the system now, which has helped to fix the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.