Wifi works at home, not public

Hello, first post. I'm having the problem in the title. I have run other garuda versions and distros no problem, but I'm trying out mate and ran into this. Searched for the problem and couldn't find a solution. Not a huge deal if it isn't fixed, just take it to school sometimes, and it's from 2012. Edit: I should mention that it does recognize public networks, but asks me to put a password, after, it tries to connect, and asks me for a password again. This happens at other public WiFi areas, not just my school
6.2.9-zen1-1-zen arch:86_64 bits:64 compiler: gcc v: 12.2.1
Mate v: 1.26.1
Type: laptop system: apple product:MacBookPro 9,2 v1.0
Model:intel core i5-3210m bits:64 type:mt mcp arch: ivy bridge gen:cor3 level: v2 built: 2012-2015 process: intel 22nm
Device: broadcom nextreme bcm57765 gigabit ethernet pcie driver: tg3 v:kernel
Device 2: broadcom bcm4331 802. 11a/b/g/n vendor: apple airport extreme

Welcome :slight_smile:
Please post the complete garuda-inxi.

Use three ~ in first and last line, like

Terminal text
then others can easily expand or copy the text.

Terminal text
then others can easily expand or copy the text in the view. Move the mouse pointer over it in the upper right corner.

Move the mouse pointer over it in the upper right corner.

sorry about that, here it is:

  Kernel: 6.2.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8a8618a4-5f86-4d9e-b2b6-7c5cb6fd4b88 rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: MATE v: 1.26.1 info: mate-panel, plank wm: marco v: 1.26.1 vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro9,2 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-6F01561E16C75D06
    serial: <superuser required>
  Mobo: Apple model: Mac-6F01561E16C75D06 v: MacBookPro9,2
    serial: <superuser required> UEFI: Apple v: 429. date: 03/18/2022
  ID-1: BAT0 charge: 52.9 Wh (96.9%) condition: 54.6/62.9 Wh (86.7%)
    volts: 11.7 min: 10.9 model: DP bq20z451 type: Li-ion serial: N/A
    status: discharging cycles: 728
  Info: model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2963 high: 3044 min/max: 1200/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2893 2: 3044 3: 2893
    4: 3023 bogomips: 19954
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3,
    VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: Apple FaceTime HD Camera type: USB driver: uvcvideo
    bus-ID: 2-1.1:3 chip-ID: 05ac:8509 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: marco v: 1.26.1 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
    s-diag: 398mm (15.69")
  Monitor-1: LVDS-1 model: Apple Color LCD built: 2009 res: 1280x800 hz: 60
    dpi: 114 gamma: 1.2 size: 286x179mm (11.26x7.05") diag: 337mm (13.3")
    ratio: 16:10 modes: 1280x800
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  API: ALSA v: k6.2.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 01:00.0
    chip-ID: 14e4:16b4 class-ID: 0200
  IF: enp1s0f0 state: down mac: <filter>
  Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 14e4:4331 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1- chip-ID: 05ac:821d class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 931.51 GiB used: 68.73 GiB (7.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1K scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 68.73 GiB (7.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 68.73 GiB (7.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 68.73 GiB (7.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
    used: 68.73 GiB (7.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 61.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 243 Uptime: 1m wakeups: 2 Memory: 15.53 GiB
  used: 1.82 GiB (11.7%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: 1592 pm: pacman pkgs: 1586
  libs: 404 tools: octopi,pamac,paru pm: flatpak pkgs: 6 Shell: fish v: 3.6.1
  default: Bash v: 5.1.16 running-in: mate-terminal inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-04-01
  Last full system update: 2023-04-06
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Please edit your text.

sorry, i was really off to a bad start. fixed

Hi there, welcome to the community!

Ahh, its fine. I hope you know now.


This will certainly be a good article to have a look at.

Does this mean that problem does not exist in other editions ( like KDE, Gnome, Cinnamon etc.) ?

Also, you mentioned in title that it works for you personnel wifi network? Only public network is issue?


thank you for being patient with me, it means a lot. yes, i had the kwin version of garuda, and i ran arco linux with the zen kernel and kde, those worked fine out of the box. yes, i'm able to connect here at home, but not at the library or school. going to check that article right now. thank you for your help

Have you tried disabling MAC address randomization?


huge facepalm. i forgot i did that. seriously, thanks. i'm so embarrassed. should i delete this post sense it has nothing to do with the wifi being a problem?

No don't worry about it. Others learn by our mistakes. We've all had those moments. :+1:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.