Wifi won't connect on arch

Hi, I recently switched to arch from garuda. I have a issue with wifi not connecting now. I tried hard enough to look for this issue on the internet, I tried to boot into live arch iso and connecting to my wifi using iwctl (results in "Operation failed"), even asked a few friends, no profit. Whereas when I just boot into live garuda, wifi works just fine.

-Technical details-
Host: Arch Linux x86_64
Kernel: 5.16.14-zen1-1-zen
CPU: Intel Pentium G4400 (2) @ 3.300GHz

lsmod: PrivateBin
lspci: PrivateBin

Wifi adapter: Realtek 802.11n WLAN Adapter
Wifi device: JioFi3

-The issue with my wifi-
Most of the time, my wifi device isn't even spotted when I see on NetworkManager, I then unplug and plug in my adapter, and that at a rare case spots my device and I try to connect, sometimes connects and sometimes just fails after a few seconds and the device is again gone from the list. Another thing I noticed is that, when nm detects my device, nm-applet shows that my device range is too far away ( https://i.imgur.com/o1V42nQ.png ).

What exactly am I doing wrong? Help would be highly appreciated!

If the Arch wiki can't help you I would ask in the Arch forum.

7 Likes

Not a Garuda problem. Belongs with Arch. Unless you're too scared to ask in the Arch forums.

1 Like