Wifi don't work (WEP)

Hello.
wpa_supplicant don't support in 2.10 version WEP security. In my previous archlinux I just stop upgrading and leave 2.9. Now I'm on new installed Garuda system and cannot downgrade.
What are other options to make my wifi work?
Regards.

Try to give a look at the Arch Wiki:
https://wiki.archlinux.org/title/Network_configuration/Wireless#Utilities
Theoretically you could try downgrading anyway, but it could be very very tricky.
PS: your garuda-inxi is missing...

Alternatively, you can install networkmanager-iwd AUR / chaotic-aur, a modified package configured to build NetworkManager working exclusively with iwd , with the main difference being that iwd is required and wpa_supplicant can be uninstalled after building.

See Arch WIki HERE

Note: Make sure to check the archwiki because it warns as such:

  • Do not enable iwd.service or manually configure iwd. NetworkManager will start and manage it itself.
1 Like

Sorry, I write from smartphone because I'm at work now and have fresh system installed.

System:
  Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=89437e7c-58ad-4fa2-b4f0-904e1853a5cc rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=f194a83d-041a-4b69-b5d7-3da2504f9f0c loglevel=3
  Desktop: GNOME v: 42.0 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 7577 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0WTYKT v: A00 serial: <superuser required>
    UEFI-[Legacy]: Dell v: 1.12.1 date: 12/18/2020
Battery:
  ID-1: BAT0 charge: 42.1 Wh (100.0%) condition: 42.1/56.0 Wh (75.1%)
    volts: 17.3 min: 15.2 model: Samsung SDI DELL W7NKD7B type: Li-ion
    serial: <filter> status: full
CPU:
  Info: model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake
    family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEC
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 900 min/max: 800/3500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 bogomips: 19999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:591b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell
    driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:1c8d class-ID: 0302
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x053f built: 2016 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.0.2
    direct render: Yes
Audio:
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 3b:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp59s0 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0 chip-ID: 8086:24fd
    class-ID: 0280
  IF: wlp60s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 672.82 GiB (64.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Plextor model: PX-128S3G
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1.03 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000LX015-1U7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: SDM2
    scheme: MBR
Partition:
  ID-1: / raw-size: 104.48 GiB size: 104.48 GiB (100.00%)
    used: 14.08 GiB (13.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /home raw-size: 931.51 GiB size: 915.89 GiB (98.32%)
    used: 658.74 GiB (71.9%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 104.48 GiB size: 104.48 GiB (100.00%)
    used: 14.08 GiB (13.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/tmp raw-size: 104.48 GiB size: 104.48 GiB (100.00%)
    used: 14.08 GiB (13.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 14.75 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda1 maj-min: 8:1
  ID-2: swap-2 type: zram size: 15.25 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 47.0 C pch: 42.0 C mobo: 38.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 252 Uptime: 1h 17m wakeups: 2 Memory: 15.25 GiB
  used: 3.48 GiB (22.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1491 lib: 480 Shell: fish v: 3.4.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2022-04-25
  Last full system update: 2022-04-26 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            nmb.service 
1 Like

After I install networkmanager-iwd it remove networkmanager and now after reboot I don't see that wifi network at all.

According to the table I linked above, iwd seems to be not supporting WEP.
I think you should try with iw in the command line when you need to connect via WEP (I think NetworkManager can remain installed and be used in any other use case).

I try that iw but it don't see any interface:

iw dev
phy#0
	Unnamed/non-netdev interface
		wdev 0x3
		addr e4:70:b8:50:05:f1
		type P2P-device
		txpower 0.00 dBm
	Interface wlan0
		ifindex 4
		wdev 0x2
		addr e4:70:b8:50:05:f0
		ssid OnePlus 9 Pro 5G
		type managed
		channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
		txpower 22.00 dBm
		multicast TXQ:
			qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
			0	0	0	0	0	0	0	0		0

and then nothing on sudo iw dev interface scan | less

Regards.

sudo iw dev wlan0 scan

?

now it see my work network but don't connect:

sudo iw wlan0 connect kazex_biuro
command failed: Operation already in progress (-114)

and when I disconnect from my smartphone hotspot I try that command and there's no output but I don't have wifi.

Do I need to stop networkmanager or other service before?

I don't know, sorry. I never had a similar use case (only iwctl during arch installation, but always only NetworkManager after).
Just try...

sudo iw dev wlan0 scan

BSS 62:a1:2c:e7:9c:8d(on wlan0) -- associated
	last seen: 2860.788s [boottime]
	TSF: 529192623439 usec (6d, 02:59:52)
	freq: 2412
	beacon interval: 100 TUs
	capability: ESS Privacy ShortPreamble ShortSlotTime RadioMeasure (0x1431)
	signal: -27.00 dBm
	last seen: 937 ms ago
	Information elements from Probe Response frame:
	SSID: OnePlus 9 Pro 5G
	Supported rates: 1.0* 2.0* 5.5* 11.0* 
	DS Parameter set: channel 1
	Country: PL	Environment: bogus
		Channels [1 - 13] @ 20 dBm
		Channels [36 - 64] @ 23 dBm
		Channels [100 - 140] @ 30 dBm
		Channels [149 - 165] @ 14 dBm
	Supported operating classes:
		 * current operating class: 81
		 * operating class: 83
		 * operating class: 84
		 * operating class: 121
		 * operating class: 122
		 * operating class: 123
		 * operating class: 125
		 * operating class: 128
		 * operating class: 129
	ERP: <no flags>
	Extended supported rates: 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 
	RSN:	 * Version: 1
		 * Group cipher: CCMP
		 * Pairwise ciphers: CCMP
		 * Authentication suites: PSK
		 * Capabilities: 16-PTKSA-RC 1-GTKSA-RC (0x000c)
	HT capabilities:
		Capabilities: 0x1ad
			RX LDPC
			HT20
			SM Power Save disabled
			RX HT20 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 2 usec (0x04)
		HT RX MCS rate indexes supported: 0-15
		HT TX MCS rate indexes are undefined
	HT operation:
		 * primary channel: 1
		 * secondary channel offset: no secondary
		 * STA channel width: 20 MHz
		 * RIFS: 0
		 * HT protection: no
		 * non-GF present: 1
		 * OBSS non-GF present: 0
		 * dual beacon: 0
		 * dual CTS protection: 0
		 * STBC beacon: 0
		 * L-SIG TXOP Prot: 0
		 * PCO active: 0
		 * PCO phase: 0
	WMM:	 * Parameter version 1
		 * u-APSD
		 * BE: CW 3-7, AIFSN 2
		 * BK: CW 3-7, AIFSN 2
		 * VI: CW 3-7, AIFSN 0, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 0, TXOP 1504 usec
	VHT capabilities:
		VHT Capabilities (0x33807192):
			Max MPDU length: 11454
			Supported Channel Width: neither 160 nor 80+80
			RX LDPC
			TX STBC
			SU Beamformee
			RX antenna pattern consistency
			TX antenna pattern consistency
		VHT RX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT RX highest supported: 866 Mbps
		VHT TX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT TX highest supported: 866 Mbps
	VHT operation:
		 * channel width: 0 (20 or 40 MHz)
		 * center freq segment 1: 0
		 * center freq segment 2: 0
		 * VHT basic MCS set: 0xfffa
	Extended capabilities:
		 * Extended Channel Switching
		 * Operating Mode Notification
		 * Max Number Of MSDUs In A-MSDU is unlimited
	HE capabilities:
		HE MAC Capabilities (0x010182100840):
			+HTC HE Supported
			Minimum Payload size of 128 bytes: 1
			Broadcast TWT
			OM Control
			RX Control Frame to MultiBSS
			A-MSDU in A-MPDU
			UL 2x996-Tone RU
		HE PHY Capabilities: (0x00334c090d0080c8000c00):
			Punctured Preamble RX: 3
			Device Class: 1
			LDPC Coding in Payload
			STBC Tx <= 80MHz
			STBC Rx <= 80MHz
			Full Bandwidth UL MU-MIMO
			DCM Max Constellation: 1
			DCM Max Constellation Rx: 1
			SU Beamformee
			Beamformee STS <= 80Mhz: 3
			PPE Threshold Present
			Max NC: 1
			STBC Tx > 80MHz
			STBC Rx > 80MHz
			TX 1024-QAM
			RX 1024-QAM
		PPE Threshold 0xfa 0xff 0xfa 0xff 0x19 0x1c 0xc7 0x71 
BSS b0:48:7a:f2:fc:ae(on wlan0)
	last seen: 2860.788s [boottime]
	TSF: 13467436271752 usec (155d, 20:57:16)
	freq: 2412
	beacon interval: 100 TUs
	capability: ESS Privacy ShortPreamble ShortSlotTime (0x0431)
	signal: -60.00 dBm
	last seen: 937 ms ago
	Information elements from Probe Response frame:
	SSID: kazex_biuro
	Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0 9.0 12.0 18.0 
	DS Parameter set: channel 1
	Country: US	Environment: Indoor/Outdoor
		Channels [1 - 13] @ 20 dBm
	ERP: <no flags>
	Extended supported rates: 24.0 36.0 48.0 54.0 
	WMM:	 * Parameter version 1
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
BSS b8:69:f4:2f:33:27(on wlan0)
	last seen: 2860.788s [boottime]
	TSF: 1560235417984 usec (18d, 01:23:55)
	freq: 2412
	beacon interval: 100 TUs
	capability: ESS Privacy ShortPreamble ShortSlotTime (0x0431)
	signal: -83.00 dBm
	last seen: 937 ms ago
	SSID: ArtmetalHala2
	Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0 9.0 12.0 18.0 
	DS Parameter set: channel 1
	TIM: DTIM Count 0 DTIM Period 1 Bitmap Control 0x0 Bitmap[0] 0x0
	ERP: <no flags>
	HT capabilities:
		Capabilities: 0x102c
			HT20
			SM Power Save disabled
			RX HT20 SGI
			No RX STBC
			Max AMSDU length: 3839 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: No restriction (0x00)
		HT RX MCS rate indexes supported: 0-7
		HT TX MCS rate indexes are undefined
	RSN:	 * Version: 1
		 * Group cipher: CCMP
		 * Pairwise ciphers: CCMP
		 * Authentication suites: PSK
		 * Capabilities: 1-PTKSA-RC 1-GTKSA-RC (0x0000)
	Extended supported rates: 24.0 36.0 48.0 54.0 
	HT operation:
		 * primary channel: 1
		 * secondary channel offset: no secondary
		 * STA channel width: 20 MHz
		 * RIFS: 0
		 * HT protection: no
		 * non-GF present: 0
		 * OBSS non-GF present: 0
		 * dual beacon: 0
		 * dual CTS protection: 0
		 * STBC beacon: 0
		 * L-SIG TXOP Prot: 0
		 * PCO active: 0
		 * PCO phase: 0
	WMM:	 * Parameter version 1
		 * u-APSD
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec
	WPS:	 * Version: 1.0
		 * Wi-Fi Protected Setup State: 2 (Configured)
		 * UUID: 00000000-0000-0000-0000-b869f42f3326
		 * RF Bands: 0x1

Is it possible to install wpa_supplicant 2.9?

I see it is currently in v2.2.10-4:

So maybe you're looking for a v2.2.9-???
You could install the downgrade package from the AUR and try using it.
There is a certain risk of breaking something due to the dependencies.
If it is really important you can try, and in case of issues, you can update again (in the worst case you can restore a snapshot if your networking will not work at all to update).

Thanks, downgrade works OK. I think in new installed system it will not downgrade if I don't upgrade from 2.9 before :smiley:
Regards.

1 Like

My question would be, why on Earth are you still using WEP? It is old and fundamentally broken. I don't know of any device from the past 20 years that doesn't support at least WPA (even though WPA1 is also insecure, it's at least better than WEP).

4 Likes

I write to my ISP why they don't change that WEP to WPA/WPA2 and they risk that our company is exposed at attacks. I'm waiting for answer.
Regards.

You/admin changes it in your router/switch/access point yourself??? Has nothing to do with your isp

2 Likes

I don't have access to router settings.

The admin at your work should? or the msp running your network

2 Likes