Wifi adapter not showing 5GHz access points

Hi All,

I am using Garuda linux with the zen kernel . Here is the output of my lshw .

Linux ganesan-asusdesktop 5.11.16-zen1-1-zen #1 ZEN SMP PREEMPT Wed, 21 Apr 2021 17:22:09 +0000 x86_64 GNU/Linux

description: Generic USB device
product: 802.11ac WLAN Adapter
vendor: Realtek
physical id: 1
bus info: [email protected]:1
version: 2.00
serial: 00e04c000001
capabilities: usb-2.10
configuration: driver=rtl88XXau maxpower=500mA speed=480Mbit/s

The adapter is a TP-Link Archer T2U PLUS [RTL8821AU].
Installed the rtl88xx-aircrack-dkms.git package. it was working earlier.

Any help is appreciated.

what exactly doesn't work? What way do you use to see 5G access points?
Read

And post your

inxi -Fxxxza

As text. Even if you think it's unnecessary.

2 Likes

Be sure you have the crda package installed and that your country code (regdom) is set correctly.

You may also find if you lower the channels on the 5 GHz band to 40 or below in your router settings that your adapter will now be able to detect the 5 GHz access point.

As already mentioned:

5 Likes

Just adding a bit more, I can't see any issue with driver. According to your device specs:

High-Speed WiFi: 256QAM support increases the 2.4 GHz 
data rate from 150 Mbps to 200 Mbps. 200 Mbps on the 2.4 GHz 
band and 433 Mbps on the 5 GHz band provide fast AC WiFi*.

Of course with ideal conditions 2.4GHz can go up to 450Mbps but does not seems that your device support it.

Try iwconfig on a terminal, it will give you a better clue of frequency and speed you are currently using.

At last, check your Access Point/Wifi Router, you can use iwlist <device> scanning or even an Androind application - you choose.

I'm glad that fixed things up for you @chickooiyer, however please state which of my suggestions fixed your issue (for other users benefit in the future) .

Welcome to Garuda.

1 Like

Hi tbg,

You may also find if you lower the channels on the 5 GHz band to 40 or below in your router settings that your adapter will now be able to detect the 5 GHz access point.

This Solved my issue...

Thank you so much.

2 Likes

Thank you for posting that.

It's not really much of a solution if you're using it on a laptop as other networks when roaming may still have issues on the 5 GHz band.

However, it is a reasonable solution if used on a home desktop computer accessing only a single network.

Glad that helped.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.