Why does my shell say that I'm using fish not zsh?

Hello.

This is my first time posting so be nice :wink: especially since I'm posting in the newbie corner.

I want to run zsh but it is saying that my shell is fish and I can't seem to change it.

inxi -Faz
System:
  Kernel: 5.16.0-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=5ea32362-776b-4a64-a2e7-1e1492b1137b rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=99213909-149f-4663-8cb0-b7431f100328 loglevel=3
  Desktop: sway 1.6.1 vt: 1 dm: N/A Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9350 v: N/A
    serial: <superuser required> Chassis: type: 9
    serial: <superuser required>
  Mobo: Dell model: 0PWNCR v: A01 serial: <superuser required> UEFI: Dell
    v: 1.11.1 date: 08/01/2019
Battery:
  ID-1: BAT0 charge: 32.3 Wh (94.2%) condition: 34.3/56.0 Wh (61.2%)
    volts: 8.7 min: 7.6 model: LGC-LGC7.3 DELL 5K9CP5A type: Li-ion
    serial: <filter> status: Charging
CPU:
  Info: model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake
    family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 491 high: 500 min/max: 400/3100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 466 2: 500 3: 500
    4: 500 bogomips: 20799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Microdia Integrated Webcam HD type: USB driver: uvcvideo
    bus-ID: 1-5:4 chip-ID: 0c45:670c class-ID: 0e02
  Display: wayland server: N/A compositor: sway v: 1.6.1 driver:
    loaded: i915 note: n/a (using device driver) display-ID: 1
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.0-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 3a:00.0
    chip-ID: 8086:095a class-ID: 0280
  IF: wlp58s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
    v: 0.8 bus-ID: 1-3:3 chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
Drives:
  Local Storage: total: 465.76 GiB used: 18.54 GiB (4.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
    model: SSD 860 EVO M.2 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q
    scheme: GPT
Partition:
  ID-1: / raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
    used: 18.54 GiB (4.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
    used: 18.54 GiB (4.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
    used: 18.54 GiB (4.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
    used: 18.54 GiB (4.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  ID-2: swap-2 type: zram size: 7.63 GiB used: 1024 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 49.0 C pch: 45.5 C mobo: 41.0 C
    sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 242 Uptime: 53m wakeups: 1 Memory: 7.63 GiB
  used: 3.25 GiB (42.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1273 lib: 316 Shell: fish
  v: 3.3.1 default: Zsh v: 5.8 running-in: alacritty inxi: 3.3.11~~~

Steps I have taken to solve my problem:

  • I have tried chsh
  • Also going through the gardua assistant/welcome setup.

I am also trying to take make a change to zshrc and I get the standard fish shell error information when I try to source zshrc.

If I launch my terminal and then I try source .zshrc. I get this error which to me looks like a fish error.

[🔴] × source ~/.zshrc
~/.zshrc (line 185): Missing end to balance this if statement
if [[ -n "${key[Alt-Right]}" ]]; then
^
from sourcing file ~/.zshrc
source: Error while reading file “/home/userprofile/.zshrc”

Thanks.

It's garuda's configuration. Go to the settings of the terminal and change the command to none from /usr/bin/fish

5 Likes

Thank you so much, I guess I'm not used to a terminal controlling the shell that launches vs $SHELL being what sets it.

I am on sway so it's running alacritty for the terminal manager so I had to go into ~/.config/alacritty/alacritty.yml and change it.

But that worked, so I marked your comment as the solution.

Thank you sir, I've never used sway and alacritty, so didn't know that.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.