Where to write the connman wifi password in Wayfire live mode?

Garuda Wayfire today's download. Connman finds the wifi, but I can't find the place to write the wifi password to get the internet on.

Connman should ask if it needs one. Can you post the output of connman from when you try to connect?

Also please post the output of inxi -Fxxxa with ~~~ above and below it.


As it is wifi, I have to give the password, so there should be a place to fill that. Tried to get a screenshot, which is supposed to be saved in Pictures, but Files don't open at all. So, something must be wrong with this release. Anyway, I'll try again and give what you asked.

Tried again. Neither Files, nor Text Editor opens. I am writing this from another distro.

Which GPU you use?


We need information to help. Please try to help us help you - what chip/driver is in use for the WiFi adapter?
Are you using ConnMan on the command line or using it with a GUI front-end?
Can you open a console ctl-alt-F3? If so, can you li the directories you would store pictures and text in? What does it say about space taken?


I'll download afresh later in the evening and try it again. I cannot try now.
Like I mentioned before,

  1. I used the GUI frontend. Once, a wifi network is chosen (clicked on), it should ask for the password for the internet. It doesn't. I have only wifi. Wifi doesn't get enabled at start, have to do that manually.
  2. Neither the Files, nor the Text editor opened, so there's no place to find the stored screenshots etc.
  Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A6 
  cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 19048 
  Speed: 1100 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1100 2: 1030 
  3: 1100 4: 1100 5: 1099 6: 1100 7: 1100 8: 1101 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Iris Plus Graphics G1 vendor: Lenovo driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300 
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel modules: wl port: 3040 
  bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
  IF: wlan0 state: up mac: 10:63:c8:fd:fe:8b 

This is from Arch

This is a known bug, install connman-git as a workaround.