When i use built in mic when call or sound record then there are so many noice notice

when i use built in mic when call or sound record then there are so many noice notice how i resolve my mic. mic is good there are no issue in windows, how i resolve this issue please reply i use garuda xfce desktop environment

Hi there, a simple search would have told the answer.

But I am attaching link for the sake of ease.

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting

This should most probably solve issue.

1 Like

Use PulseEffect, awesome piece of software that uses RNNoise (IA based) for reducing noise

1 Like

hey i install PulseEffect but its not open

hey i install but there are so many software shown in multimedia section which one i choose

Well, it is clearly mentioned in link I posted above

If we are getting static noise in Skype, gnome-sound-recorder, arecord, etc.'s recordings, then the sound card sample rate is incorrect. That is why there is static noise in Linux microphone recordings. To fix this, we need to set the sampling rate in /etc/pulse/daemon.conf for the sound hardware.

In addition to the guide below, since PulseAudio 11 it is possible to set avoid-resampling = yes in daemon.conf.

Determine sound cards in the system (1/5)
This requires alsa-utils and related packages to be installed:

$ arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
The sound card is hw:x,y where x is the card number and y is the device number. In the above example, it is hw:0,0.

Determine sampling rate of the sound card (2/5)
We aim to find the highest sample rate supported by the hw:0,0 sound card using a trial-and-error procedure starting from a low value. When the top value is reached, we got a warning message:

arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav
"Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
Warning: rate is not accurate (requested = 60000Hz, got = 44100Hz)
please, try the plug plugin
observe, the got = 44100Hz. This is the maximum sampling rate of our card.

Setting the sound card's sampling rate into PulseAudio configuration (3/5)
The default sampling rate in PulseAudio:

$ grep "default-sample-rate" /etc/pulse/daemon.conf
; default-sample-rate = 48000
48000 is disabled and needs to be changed to 44100:

# sed 's/; default-sample-rate = 48000/default-sample-rate = 44100/g' -i /etc/pulse/daemon.conf
Restart PulseAudio to apply the new settings (4/5)
$ pulseaudio -k
$ pulseaudio --start
Finally check by recording and playing it back (5/5)
Let us record some voice using a microphone for, say, 10 seconds. Make sure the microphone is not muted and all

$ arecord -f cd -d 10 test-mic.wav
After 10 seconds, let us play the recording...

$ aplay test-mic.wav
Now hopefully, there is no static noise in microphone recording anymore.

2 Likes

hey Naman i am noob in linux so i not understand what should i do to you suggestion given upper can you remote my desktop and do it ?

how i adjust microphone setting for resolve noise when recording and calling and also adjust, my speaker my laptop have dts sound, when i use windows 10 then sound comes good its also good in garuda linux but not similar to windows 10 so how adjust to gui base package or software not to command

Noone here is going to provide personal technical support services for free.

If you would like someone to provide personal technical support then you can try another distribution, or offer to pay someone for their time.

7 Likes

Are you serious
:dizzy_face:
To be honest, if you can't simply copy and paste commands / text from given site, any Arch based distro isn't meant for you.

And if you'd asked for remote assistance on most of the other forms, anyone would simply ban you.

4 Likes

:joy: :joy: sorry but i do copy paste but still not work, its not work have any software gui based to resolve this issue

and i not understan which type of ban you mean say

❯ arecord --list-devices  100%  ─╯
zsh: correct 'arecord' to 'parecord' [nyae]?

see when i write command and enter then whats reply

Im not sure whether this is a language issue or not but you cant expect people to do literally everything for you :thinking:

A ban which prevents you from ever using this forum again.

Did you actually read the output and try what it tells you?

Not trying to be rude but thats not how it works, we cant handhold people with the most basic things since much more people are using the forum nowadays. Maybe start with linuxjourney.com which explains the basic stuff like shell & commands. :thinking:

3 Likes