What file is the grub menu editor?

inxi

System:
  Kernel: 6.6.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=61559364-8d16-4ba6-99f3-cd05e28287bd rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: Cinnamon v: 6.0.4 tk: GTK v: 3.24.39 wm: muffin vt: 7 dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 80R4 v: Flex 3-1580
    serial: <superuser required> Chassis: type: 10 v: Flex 3-1580
    serial: <superuser required>
  Mobo: LENOVO model: Flex 3-1580 v: SDK0J40700 WIN
    serial: <superuser required> UEFI: LENOVO v: D3CN39WW date: 06/26/2018
Battery:
  ID-1: BAT0 charge: 32.8 Wh (96.5%) condition: 34.0/45.0 Wh (75.4%)
    volts: 12.1 min: 11.1 model: SMP L14M3P21 type: Li-poly serial: <filter>
    status: not charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
    serial: <filter> charge: 5% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Pentium 4405U bits: 64 type: MT MCP arch: Skylake
    level: v2 built: 2015 process: Intel 14nm family: 6 model-id: 0x4E (78)
    stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 2 MiB desc: 1x2 MiB
  Speed (MHz): avg: 2100 min/max: 400/2100 scaling: driver: intel_pstate
    governor: performance cores: 1: 2100 2: 2100 3: 2100 4: 2100 bogomips: 16799
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel HD Graphics 510 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: HDMI-A-1
    empty: none bus-ID: 00:02.0 chip-ID: 8086:1906 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer KB272HL H serial: <filter>
    built: 2022 res: 1920x1080 hz: 75 dpi: 82 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: Vulkan v: 1.3.274 layers: 3 device: 0 type: integrated-gpu name: Intel
    HD Graphics 510 (SKL GT1) driver: mesa intel v: 23.3.3-arch1.1
    device-ID: 8086:1906 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 128 bits) driver: mesa llvmpipe v: 23.3.3-arch1.1 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  API: ALSA v: k6.6.10-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:3 chip-ID: 0cf3:e360
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 4.1 lmp-v: 7
    status: discoverable: no pairing: no
Drives:
  Local Storage: total: 931.51 GiB used: 14.2 GiB (1.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 14.19 GiB (24.2%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 5.7 MiB (1.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 14.19 GiB (24.2%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 14.19 GiB (24.2%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 14.19 GiB (24.2%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.56 GiB used: 256.8 MiB (3.3%)
    priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 52.0 C pch: 47.5 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 258 Uptime: 9h 26m wakeups: 0 Memory: total: 8 GiB
  available: 7.56 GiB used: 3.04 GiB (40.2%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1502 libs: 428 tools: pamac,paru,yay Shell: Bash v: 5.2.21
  running-in: qterminal inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2024-01-04
  Last full system update: 2024-01-12
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

I just want to clean up the menu, showing lots of recovery modes and kernel options on multi boot.
I think someone answered this before but I couldn’t find the post, and I didn’t make a note, I will though.
Is it boot/grub/grub-btrfs.cfg

Use garuda-boot-manager.

?

Post log from

efibootmgr

:warning: Don’t use the Grub customizer :warning:

2 Likes

Ok that works, what about on a legacy boot?

This is one machine that is efi:

efibootmgr
BootCurrent: 0003
Timeout: 10 seconds
BootOrder: 0003,0001,0014,0000,0015,0002,0016,0013,0017
Boot0000* Windows Boot Manager  HD(2,MBR,0x76931d19,0x39c2000,0x10000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d0000004d000100000010000000040000007fff0400
Boot0001* ubuntu        HD(1,GPT,7ae4f443-b673-439f-85ea-77a4cb308d23,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0002* kodachi       HD(1,GPT,d7c47425-6cd0-446f-9290-5d2d196e2854,0x800,0x100000)/File(\EFI\kodachi\shimx64.efi)
Boot0003* Garuda        HD(1,GPT,7ae4f443-b673-439f-85ea-77a4cb308d23,0x800,0x100000)/File(\EFI\Garuda\grubx64.efi)
Boot0010  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu     FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012  Diagnostic Splash     FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013* USB FDD:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0014* ATA HDD: Samsung SSD 870 EVO 1TB                      PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,0,0){5962af91-4456-419f-a7b9-1f4f892ab0f6}
Boot0015* USB HDD: Lexar JumpDrive      PciRoot(0x0)/Pci(0x14,0x0)/USB(13,0){aa21e833-33af-47bc-89bd-419f88c50803}
Boot0016* USB CD:       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0017* PCI LAN:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)

What’s the log for none EFI, I have one box on legacy boot.

I removed grub customizer and added disable_os_prober=true to the other os’s
grub.
Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.