Weird internet connection speed limited to 10 mb/s

Hi,
I just bought a new router because my old one was very slow. I tried it on windows and the download speed was about 50 mb/s on the torrent app . On Garuda it is limited to 10 mb/s (that was the max speed of the old router), I looked in the setting but i saw no speed limit, neither in the torrent app.
Thanks in advance.

System:
Kernel: 5.17.2-254-tkg-bmq arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: intel_pstate=passive
BOOT_IMAGE=/@/boot/vmlinuz-linux517-tkg-bmq
root=UUID=4c27e197-bd40-4566-9ca4-d959713ef278 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M-A PRO MAX (MS-7C52) v: 1.0
serial: <superuser required> BIOS: American Megatrends LLC. v: 3.C0
date: 05/19/2021
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 4007 high: 4199 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4162 2: 4034
3: 4171 4: 4171 5: 4181 6: 3794 7: 4199 8: 3713 9: 3775 10: 3814 11: 3967
12: 4105 bogomips: 86404
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 29:00.0 chip-ID: 10de:21c4 class-ID: 0300
Device-2: KYE Systems (Mouse Systems) Genius Webcam type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-1:2 chip-ID: 0458:6006
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.70x13.43")
s-diag: 692mm (27.24")
Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 163
size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 515.57 direct render: Yes
Audio:
Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel bus-ID: 5-1:2 v: kernel pcie: chip-ID: 0458:6006
gen: 3 class-ID: 0102 serial: <filter> speed: 8 GT/s lanes: 16
bus-ID: 29:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: KYE Systems (Mouse Systems) Genius Webcam type: USB
driver: snd-usb-audio,uvcvideo
Sound Server-1: ALSA v: k5.17.2-254-tkg-bmq running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.53 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.82 TiB used: 434.35 GiB (23.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 40.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WDS100T2B0A-00SM50 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
scheme: GPT
Partition:
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 434.35 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 434.35 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 434.35 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 434.35 GiB (46.6%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: zram size: 15.61 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 39 C
Fan Speeds (RPM): fan-1: 0 fan-2: 1662 fan-3: 0 fan-4: 0 fan-5: 0
gpu: nvidia fan: 55%
Power: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.36
Info:
Processes: 323 Uptime: 21m wakeups: 0 Memory: 15.61 GiB
used: 5.87 GiB (37.6%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 2048
lib: 555 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-02-17
Last full system update: 2022-07-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service nmb.service

??? Which one ???
Did you check the manual?
Did you check arch linux wiki?
Did you dual boot?
Did you try other kernel?

Seems we need more details.

I checked the manual, the router is Gigabit TENDA TX9 PRO, I didn't dual boot, and I tried another kernel and it was the same issue, the problem is surely not form the router as other computer in the house doesn't face the issue.

Without hard statitics your analysis is somewhat up to speculation. Have you used a speed test site on your other computer and compared the rates? Different torrent programs may rate speeds differently. Many times people complaining of different speeds on other machines aren't using a standardized method of rating the speeds and in actuality the speed attained on Linux is in the same ballpark.

Have you set a different DNS server on Linux?

The chip used inside your router may perhaps not have the best compatibility with Linux yet if the chip is rather new.

Have you searched online for issues with your router model and Linux?

Have you tried raising your speed for your Ethernet connection in Network Manager?

3 Likes

I used a speed test and the speed was the same, but the maximum real download speed is about 10-11 mbs and while downloading at this speed I can't even make a google search because it seems the internet is limited to that speed. My speed is on 100 mbs I can put it on 1000 but it makes no difference. I am not sure how to set a different DNS server but in Garuda Assistant DNS service is on default. I don't think the chip from the router is the problem because I tested on another computer that had Ubuntu on it and the internet speed was over 10 mbs. After that I made an Ubuntu live usb stick and I booted it on this computer and the internet speed wouldn't go over 10 mbs so it was the same issue. Is there any chance the issue is from the motherboard's bios settings or something?

Be sure to set your speed to 1000 in Network Manager.

Try installing the r8168-dkms driver from the AUR.

Test other kernels starting with the linux-lts and linux-mainline kernels.

Also make sure your bios is up to date.

4 Likes

Hi, it seems that the issue was from the ethernet cable. My computer isn't directly connected to the router, it is connected to an ethernet plug and the problem was from the cable that comes from the router to the plug. Now everything works how it should. Thanks anyway and sorry for wasting your time.

I would suggest purchasing new connectors for your ethernet cable. Similar issue happened to me a lot of times. My data rate was capped to half duplex ( 100 mbps ) till I replaced connectors. The connection is full duplex ( 1000 mbps ) and works like a charm now.

Anyway, I am glad that your issue has been solved.

The reason why this baffles people so often is because Linux behaves differently than Windows. The user will often complain Linux is slow, but when runing Windows with the same machine it has full speed capacity. Therefore, most people assume if they run Windows and everything is fine, it can't be the cables responsible. This is often not the case, as Linux will sometimes choke on cables that Windows has no problem with.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.