Webcam not working

i installed qtile on my laptop few days back. today i went for a google meet and the webcam was not working... it says no camera found. how to enable it ??

i use hp bs-15 179tx btw

Not enough details. Most forum helpers don't have enough spare time to search for every users system specs who makes a help request on the forum. It is the users responsibility to post adequate system specifications if they wish assistance.

Please read:

Pay particular attention to the section on posting your inxi output.

Welcome to Garuda.

4 Likes

here is the output... but my "Hp TrueHD webcam with integrated mic" is not there... may be there is a bug...

inxi -Fxxxza
System: Kernel: 5.11.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=fa042d7b-28b3-4f0c-b570-183b746744cf rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=dcb4dc77-49a7-49c5-ab4a-e1e97c8175c6 loglevel=3
Desktop: Qtile 0.17.0 wm: LG3D dm: SDDM Distro: Garuda Linux
Machine: Type: Laptop System: HP product: HP Laptop 15-bs1xx v: Type1ProductConfigId serial: Chassis: type: 10
serial:
Mobo: HP model: 832B v: 23.78 serial: UEFI: Insyde v: F.65 date: 12/06/2019
Battery: ID-1: BAT1 charge: 25.5 Wh condition: 25.5/41.4 Wh (62%) volts: 16.9/14.8 model: Hewlett-Packard PABAS0241231
type: Li-ion serial: status: Full
CPU: Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
model-id: 8E (142) stepping: A (10) microcode: E0 L2 cache: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800
Speed: 3401 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3401 2: 3402 3: 3400 4: 3400 5: 3400 6: 3400 7: 3399
8: 3402
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917
class ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Hewlett-Packard
driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0 chip ID: 1002:6660 class ID: 0380
Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 driver: loaded: ati,intel,radeon
unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes
Audio: Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 class ID: 0403
Sound Server: ALSA v: k5.11.6-zen1-1-zen
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: 4000 bus ID: 02:00.0 chip ID: 10ec:8168 class ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter vendor: Hewlett-Packard driver: rtw_8723de v: N/A
modules: rtw88_8723de port: 3000 bus ID: 03:00.0 chip ID: 10ec:d723 class ID: 0280
IF: wlo1 state: down mac:
IF-ID-1: virbr0 state: down mac:
Bluetooth: Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus ID: 1-4:5 chip ID: 0bda:b009
class ID: e001 serial:
Message: Required tool hciconfig not installed. Check --recommends
Drives: Local Storage: total: 931.51 GiB used: 89.62 GiB (9.6%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-60JC3T1 size: 931.51 GiB block size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: 1A02 scheme: GPT
Partition: ID-1: / raw size: 440.3 GiB size: 440.3 GiB (100.00%) used: 89.61 GiB (20.4%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 564 KiB (0.2%) fs: vfat dev: /dev/sda5
maj-min: 8:5
ID-3: /home raw size: 440.3 GiB size: 440.3 GiB (100.00%) used: 89.61 GiB (20.4%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
ID-4: /var/log raw size: 440.3 GiB size: 440.3 GiB (100.00%) used: 89.61 GiB (20.4%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
ID-5: /var/tmp raw size: 440.3 GiB size: 440.3 GiB (100.00%) used: 89.61 GiB (20.4%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
Swap: Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: partition size: 8.01 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda6 maj-min: 8:6
ID-2: swap-2 type: zram size: 983.7 MiB used: 23.5 MiB (2.4%) priority: 32767 dev: /dev/zram0
ID-3: swap-3 type: zram size: 983.7 MiB used: 26.7 MiB (2.7%) priority: 32767 dev: /dev/zram1
ID-4: swap-4 type: zram size: 983.7 MiB used: 24.1 MiB (2.4%) priority: 32767 dev: /dev/zram2
ID-5: swap-5 type: zram size: 983.7 MiB used: 24.3 MiB (2.5%) priority: 32767 dev: /dev/zram3
ID-6: swap-6 type: zram size: 983.7 MiB used: 28.8 MiB (2.9%) priority: 32767 dev: /dev/zram4
ID-7: swap-7 type: zram size: 983.7 MiB used: 26.1 MiB (2.7%) priority: 32767 dev: /dev/zram5
ID-8: swap-8 type: zram size: 983.7 MiB used: 28 MiB (2.8%) priority: 32767 dev: /dev/zram6
ID-9: swap-9 type: zram size: 983.7 MiB used: 23.6 MiB (2.4%) priority: 32767 dev: /dev/zram7
Sensors: System Temperatures: cpu: 51.0 C mobo: 29.8 C gpu: radeon temp: 48.0 C
Fan Speeds (RPM): N/A
Info: Processes: 304 Uptime: 10h 02m wakeups: 78 Memory: 7.69 GiB used: 3.05 GiB (39.7%) Init: systemd v: 247 Compilers:
gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1624 lib: 472 Shell: fish v: 3.1.2 running in: terminator inxi: 3.3.01

The first thing to do is to test alternate kernels such as the plain linux kernel or, the LTS, or mainline kernels.

2 Likes

ok will try that...

I assume this camera you speak of is your webcam integrated into ypour laptop, or is this an addon USB camera.

i am not sure it the webcan worked when i was using garuda i3 with previous kernel... may be it worked... will try installing lts and mainline kernel... if it works will let you know

integrated webcam

It would also be a good idea to go through your bios setting to see if anything there applies to your webcam. You should also check to be sure your bios is up to date.

Has this webcam worked in the past with Linux?

If so, which distros and how long ago?

Does the webcam work on any live boot environments?

If it works on any other live environments such as Ubuntu be sure to record the the versions of the kernel and linux-firmware they are using.

well no option in bios for webcam... last worked on all distros i used starting from archlinux (gnome, kde, i3) back in january and most recently garuda kde i3 with linux-tbq version of kernel

works on all live iso except this time in qtile

i just remebered that my webcam worked perfectly fine 2weeks back when i was using garuda i3 i.e before 2 major kernel updates

webcam worked on linux-lts & linux kernel....

maybe webcam driver modules are not there in zen kernel at the moment....

thanx for the assistance @tbg

appreciate your kind patience...

1 Like

No problem, glad that fixed you up.

1 Like

its good to be back

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.