Wayland / X11 problem when launching Goxel

Hello,

I am trying to launch Goxel. And I am presented with this error message:

╭─[email protected] in ~
╰─λ goxel
glfw error 65544 (Wayland: Failed to connect to display)
glfw error 65537 (The GLFW library is not initialized)
glfw error 65537 (The GLFW library is not initialized)
goxel: /build/glfw/src/glfw-3.3.8/src/monitor.c:445: glfwGetVideoMode: Assertion `monitor != NULL' failed.
fish: Job 1, 'goxel' terminated by signal SIGABRT (Abbruch)

so, I tought that goxel wants to start on wayland, which I thought is default.
To check, I ran:

╭─[email protected] in ~ took 347ms
[:zap:] × echo $XDG_SESSION_TYPE
x11

Somewhere on the web, I read that changing to sddm (wich I also thought, its the default) would activate wayland:

╭─[email protected] in ~
╰─λ sudo systemctl enable --now sddm.service
[sudo] Passwort für voidbyte:
Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is a symlink to /usr/lib/systemd/system/sddm-plymouth.service.

I guess I was wrong. Sadly, I have no other Idea how to start the program now.
Does anyone have an Idea what to do?

Thanks

Please post the output of garuda-inxi.

3 Likes
╭─[email protected] in ~ took 15ms
[⚡] × garuda-inxi
System:
Kernel: 6.1.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=38d11f49-afe0-4b6b-953b-9addc52154a9 rw [email protected]
splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=6d7a35cf-7ffb-4292-914c-96f115fef57f loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: H97-D3H v: N/A
serial: <superuser required> Chassis: type: 3 serial: <superuser required>
Mobo: Gigabyte model: H97-D3H-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F7 date: 09/19/2015
CPU:
Info: model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4306 high: 4410 min/max: 800/4400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 4370 2: 4328 3: 4400
4: 3775 5: 4365 6: 4410 7: 4400 8: 4400 bogomips: 63858
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ZOTAC driver: nvidia
v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 91 s-size: 535x301mm (21.06x11.85")
s-diag: 614mm (24.17")
Monitor-1: DVI-I-1 pos: primary res: 1920x1080 hz: 60 dpi: 92
size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
Monitor-2: HDMI-0 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce GTX
970/PCIe/SSE2 direct render: Yes
Audio:
Device-1: Intel 9 Series Family HD Audio vendor: Gigabyte
driver: snd_hda_intel bus-ID: 3-9:6 v: kernel chip-ID: 08bb:2902
bus-ID: 00:1b.0 class-ID: 0300 chip-ID: 8086:8ca0 class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
Device-3: Texas Instruments PCM2902 Audio Codec type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.1.1-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: kernel
port: f040 bus-ID: 00:19.0 chip-ID: 8086:153b class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
RAID:
Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020
bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: class-ID: 0104
Drives:
Local Storage: total: 2.05 TiB used: 55.68 GiB (2.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS541075A9E680
size: 698.64 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: B480 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Hitachi model: HDP725050GLA360
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: A52A scheme: MBR
ID-4: /dev/sdd maj-min: 8:48 vendor: Hitachi model: HDT725050VLA360
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: A7BA scheme: MBR
Partition:
ID-1: / raw-size: 681.23 GiB size: 681.23 GiB (100.00%)
used: 55.68 GiB (8.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 681.23 GiB size: 681.23 GiB (100.00%)
used: 55.68 GiB (8.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 681.23 GiB size: 681.23 GiB (100.00%)
used: 55.68 GiB (8.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 681.23 GiB size: 681.23 GiB (100.00%)
used: 55.68 GiB (8.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.56 GiB used: 3.2 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.11 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 51 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 63%
Info:
Processes: 264 Uptime: 24m wakeups: 0 Memory: 15.56 GiB
used: 2.98 GiB (19.2%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 2096 libs: 570 tools: pamac,paru Shell: fish v: 3.5.1
running-in: konsole inxi: 3.3.24
Garuda (2.6.12-1):
System install date:     2022-11-28
Last full system update: 2022-12-22
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

It looks like there is a Wayland back end that is causing grief for some folks (here, here). The referenced workaround is to replace glfw-wayland with glfw-x11.

sudo pacman -S glfw-x11
3 Likes

That solved the problem in an instant. Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.