Wayland still not working (Nvidia)

Hey, i have updated the Nvidia drivers, but Wayland still doesn't work... when i try to log in using it i still get a black screen for a second and back to login screen... am i doing something wrong?

System:    Kernel: 5.14.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a2edb1d1-2b71-4078-8e7e-5c1eddf533f9
rw [email protected] quiet
cryptdevice=UUID=53f62651-9e7c-4ac4-9ddc-9ae7a1225771:luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
root=/dev/mapper/luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771 splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop System: Micro-Star product: MS-7B79 v: 3.0 serial: <filter>
Mobo: Micro-Star model: X470 GAMING PLUS MAX (MS-7B79) v: 3.0 serial: <filter>
UEFI: American Megatrends v: H.60 date: 06/11/2020
CPU:       Info: 8-Core model: AMD Ryzen 7 1800X bits: 64 type: MT MCP arch: Zen family: 17 (23)
model-id: 1 stepping: 1 microcode: 8001138 cache: L2: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 121604
Speed: 3800 MHz min/max: N/A Core speeds (MHz): 1: 3800 2: 3800 3: 3800 4: 3800 5: 3800 6: 3800
7: 3800 8: 3800 9: 3800 10: 3800 11: 3800 12: 3800 13: 3800 14: 3020 15: 3800 16: 3800
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 Rev. A] vendor: ASUSTeK driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 27:00.0 chip-ID: 10de:1e87 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 122 s-size: 533x302mm (21.0x11.9") s-diag: 613mm (24.1")
Monitor-1: DP-4 res: 2560x1440 dpi: 123 size: 527x296mm (20.7x11.7") diag: 604mm (23.8")
OpenGL: renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 27:00.1
chip-ID: 10de:10f8 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus-ID: 29:00.3 chip-ID: 1022:1457 class-ID: 0403
Sound Server-1: ALSA v: k5.14.15-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
driver: r8169 v: kernel port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.56 TiB used: 525.11 GiB (32.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC49 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37480G size: 447.13 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 1103 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: SUV400S37240G size: 223.57 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 37R5
scheme: GPT
Partition: ID-1: / raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 59.96 GiB (26.8%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 706 KiB (0.3%) fs: vfat
dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 59.96 GiB (26.8%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
ID-4: /var/log raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 59.96 GiB (26.8%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
ID-5: /var/tmp raw-size: 223.31 GiB size: 223.31 GiB (100.00%) used: 59.96 GiB (26.8%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-53f62651-9e7c-4ac4-9ddc-9ae7a1225771
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 1.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 34.8 C mobo: N/A gpu: nvidia temp: 52 C
Fan Speeds (RPM): fan-1: 0 gpu: nvidia fan: 0%
Info:      Processes: 391 Uptime: 12m wakeups: 1 Memory: 15.57 GiB used: 4.98 GiB (32.0%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: 1790 pacman: 1780 lib: 500 flatpak: 10
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.08
1 Like

Wayland and NVidia, generally not good friends.

I'm also experiencing this issue trying to test out Wayfire today. Is there a flag in place preventing Nvidia users from starting these environments or something?

System:
  Kernel: 5.10.76-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
  root=UUID=b2181aa8-0372-476e-ab6a-446404c64987 rw [email protected] quiet
  splash rd.udev.log_priority=3 vt.global_cursor_default=0
  systemd.unified_cgroup_hierarchy=1 loglevel=3 nvidia-drm.modeset=1
  Desktop: Cinnamon 5.0.6 tk: GTK 3.24.30 wm: muffin dm: LightDM 1.30.0
  Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Micro-Star product: MS-7B51 v: 1.0 serial: <filter>
  Mobo: Micro-Star model: MPG Z390 GAMING PLUS (MS-7B51) v: 1.0
  serial: <filter> UEFI: American Megatrends v: 1.10 date: 08/22/2018
Memory:
  RAM: total: 15.57 GiB used: 6.38 GiB (41.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10)
  microcode: EA cache: L2: 12 MiB bogomips: 88796
  Speed: 4300 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 4300 2: 4300
  3: 4300 4: 4300 5: 4300 6: 4300 7: 4300 8: 4300 9: 4300 10: 4300 11: 4300
  12: 4300
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
  xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2070 Rev. A] vendor: Micro-Star MSI
  driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
  chip-ID: 10de:1f07 class-ID: 0300
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org 1.20.13 compositor: wayfire driver:
  loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0")
  s-diag: 1245mm (49")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 75 dpi: 102
  size: 480x270mm (18.9x10.6") diag: 551mm (21.7")
  Monitor-2: DP-4 res: 2560x1440 dpi: 109 size: 596x335mm (23.5x13.2")
  diag: 684mm (26.9")
  OpenGL: renderer: NVIDIA GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44
  direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
  bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9
  class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  bus-ID: 1-2:3 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Device-4: JMTek LLC. JOUNIVO JV605PRO type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:6 chip-ID: 0c76:605d
  class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.10.76-1-lts running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
  v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtl88x2bu
  bus-ID: 1-10:10 chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
  IF: wlp0s20f0u10 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
  bus-ID: 1-4.3:9 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
  bt-service: enabled,running rfk-block: hardware: no software: yes
  address: <filter>
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 1.42 TiB used: 280.61 GiB (19.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH31000G
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 70RL scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDH3500G
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 70RL scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Generic model: Flash Disk
  size: 58.59 GiB block-size: physical: 512 B logical: 512 B type: SSD
  serial: <filter> rev: 8.07 scheme: MBR
  Optical-1: /dev/sr0 vendor: _NEC model: DVD+-RW ND-6650A rev: 102C
  dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
  rw: cd-r,cd-rw,dvd-r state: running
Partition:
  ID-1: / raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
  used: 36.21 GiB (82.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: b2181aa8-0372-476e-ab6a-446404c64987
  ID-2: /boot/efi raw-size: 250 MiB size: 246.1 MiB (98.44%)
  used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
  uuid: D71B-E3EC
  ID-3: /home raw-size: 887.32 GiB size: 872.33 GiB (98.31%)
  used: 234.05 GiB (26.8%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
  uuid: 49d89e7a-3920-46db-900b-87a6484dd220
  ID-4: /root raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
  used: 36.21 GiB (82.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: b2181aa8-0372-476e-ab6a-446404c64987
  ID-5: /run/media/elliot/D9AE-3423 raw-size: 58.59 GiB
  size: 58.58 GiB (99.98%) used: 10.36 GiB (17.7%) fs: vfat dev: /dev/sdc1
  maj-min: 8:33 label: N/A uuid: D9AE-3423
  ID-6: /srv raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
  used: 36.21 GiB (82.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: b2181aa8-0372-476e-ab6a-446404c64987
  ID-7: /var/cache raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
  used: 36.21 GiB (82.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: b2181aa8-0372-476e-ab6a-446404c64987
  ID-8: /var/log raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
  used: 36.21 GiB (82.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: b2181aa8-0372-476e-ab6a-446404c64987
  ID-9: /var/tmp raw-size: 43.95 GiB size: 43.95 GiB (100.00%)
  used: 36.21 GiB (82.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: b2181aa8-0372-476e-ab6a-446404c64987
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.57 GiB used: 3.8 MiB (0.0%) priority: 100
  dev: /dev/zram0
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Razer USA Razer BlackWidow V3 Tenkeyless
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 4 rev: 2.0
  speed: 12 Mb/s power: 500mA chip-ID: 1532:0a24 class-ID: 0300
  Device-2: 1-2:3 info: Logitech Webcam C270 type: Video,Audio
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
  power: 500mA chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Device-3: 1-3:4 info: Initio INIC-1511L PATA Bridge type: Mass Storage
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 2mA
  chip-ID: 13fd:1040 class-ID: 0805 serial: <filter>
  Hub-2: 1-4:5 info: VIA Labs VL812 Hub ports: 4 rev: 2.1 speed: 480 Mb/s
  chip-ID: 2109:2812 class-ID: 0900
  Device-1: 1-4.1:7 info: Valve Wireless Steam Controller type: Keyboard,HID
  driver: hid-steam,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 28de:1142 class-ID: 0300
  Device-2: 1-4.3:9 info: Broadcom BCM20702A0 Bluetooth 4.0 type: Bluetooth
  driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:21e8
  class-ID: fe01 serial: <filter>
  Device-3: 1-4.4:11 info: Razer USA RZ01-0321 Gaming Mouse [DeathAdder V2]
  type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 4 rev: 2.0
  speed: 12 Mb/s power: 100mA chip-ID: 1532:0084 class-ID: 0300
  Device-4: 1-5:6 info: JMTek LLC. JOUNIVO JV605PRO type: Audio,HID
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
  speed: 12 Mb/s power: 100mA chip-ID: 0c76:605d class-ID: 0300
  serial: <filter>
  Device-5: 1-9:8 info: Alcor Micro Flash Drive type: Mass Storage
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
  chip-ID: 058f:6387 class-ID: 0806 serial: <filter>
  Device-6: 1-10:10 info: Realtek RTL88x2bu [AC1200 Techkey] type: Network
  driver: rtl88x2bu interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 500mA
  chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.1
  speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 69 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 59%
Info:
  Processes: 362 Uptime: 16m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: 1532 pacman: 1520 lib: 360 flatpak: 12
  Shell: Zsh v: 5.8 running-in: tilix inxi: 3.3.08
1 Like

Linux is so free that every user can and may do what he wants with his PC. :slight_smile:

If Garuda set up a block, the outcry (from those who also always scream bloat) would be a million times greater and would be called dictatorship. :smiley:

3 Likes

they added GBM support in the latest drivers... i thought it would at least start

I have been successfully running wayland with nvidia for a while now. This was the forum post that started me down the rabbit hole. I have an intel i7 cpu with an nvidia 2060 encased in a MSI laptop. good times.

1 Like

I know GNOME had a Udev rule set up or something a while back...

Either way, I'm able to launch Wayfire via a TTY but not via Lightdm. Could that be the issue?

mmmmh. i tried that, can't find the "sddm-wayland-git" package i got "sddm" tho, modified the "dr460nized.conf" but still getting the same issue, black screen for a second and back to login screen

I believe that sddm-wayland-git was rolled into sddm-git.

is the non -git version viable too?

I just installed the sddm-wayland-git, which then turned into sddm-git. I did not try to boot with sddm. So I coudn't help you there.

ok, i will be switching to the -git version and give you an update soon

Edit: welp, had to restore a snap cuz it broke on me, it got stuck at loading the kernel...

try a different kernel. I use cacule. Love it!

1 Like

i was looking into xanmod but it's not supported T_T (i don't really want to patch every update, that's annoying)

which one you suggest? i don't play games only, i'm an artist and use krita and opentoonz.
i wish GPUs weren't so expensive, i want to buy a RX 6800 XT and skip all this Nvidia crap