Wayland Kinda Destroyed Everything in Dr460n1zed

Hello! I tried to use wayland with KDE Dr460n1zed by installing plasma-wayland-session and everything kinda became half-dead. Latte dock bottom panel is just a black box and hovering over it just showed a box with "dolphin" written on it, rofi opened and didn't close, ulauncher didn't work, my second monitor got stuck at login screen etc. I had to switch back to x11 to fix everything. It seems that optimus-manager-qt didn't autostart. Any idea why this might be? I suspect thats due to me not doing a very simple step as always.

Thanks for helping!

System:    Kernel: 5.11.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=babfeca7-69ba-4aac-bc94-681f770f0c20 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1 
Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: H310M PRO-VDH (MS-7B29) v: 1.0 serial: <filter> 
UEFI: American Megatrends v: 1.20 date: 03/30/2018 
CPU:       Info: Quad Core model: Intel Core i3-8100 bits: 64 type: MCP arch: Kaby Lake note: check 
family: 6 model-id: 9E (158) stepping: B (11) microcode: DE L2 cache: 6 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800 
Speed: 3600 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 3600 2: 3600 3: 3600 4: 3600 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
Type: mds mitigation: Clear CPU buffers; SMT disabled 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 8th Gen Core Processor Gaussian Mixture Model vendor: Micro-Star MSI 
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e91 class ID: 0380 
Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 460.56 
alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c82 class ID: 0300 
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: modesetting,nvidia 
display ID: :0 screens: 1 
Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 867x285mm (34.1x11.2") s-diag: 913mm (35.9") 
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 size: 480x270mm (18.9x10.6") 
diag: 551mm (21.7") 
Monitor-2: DP-1-1 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1") diag: 470mm (18.5") 
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 class ID: 0403 
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
chip ID: 10de:0fb9 class ID: 0403 
Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-14:7 
chip ID: 046d:081b class ID: 0102 serial: <filter> 
Sound Server: ALSA v: k5.11.7-zen1-1-zen 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 chip ID: 10ec:8168 class ID: 0200 
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Device-2: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee v: kernel port: 3000 
bus ID: 03:00.0 chip ID: 10ec:8179 class ID: 0280 
IF: wlp3s0 state: down mac: <filter> 
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8 
bus ID: 1-1:2 chip ID: 0a12:0001 class ID: e001 
Report: ID: hci0 state: up running bt-v: 2.1 lmp-v: 4.0 sub-v: 22bb hci-v: 4.0 rev: 3120 
address: <filter> 
Info: acl-mtu: 640:4 sco-mtu: 64:8 link-policy: rswitch hold sniff park link-mode: slave accept 
Drives:    Local Storage: total: 1.72 TiB used: 30.88 GiB (1.7%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DX001-1NS162-SSHD size: 931.51 GiB 
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
rev: HP76 scheme: GPT 
ID-2: /dev/sdb maj-min: 8:16 vendor: Gigabyte model: GP-GSTFS31240GNTD size: 223.57 GiB 
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> 
rev: 61.2 scheme: GPT 
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: HP model: v221w size: 14.86 GiB block size: 
physical: 512 B logical: 512 B serial: <filter> rev: 1100 scheme: MBR 
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Western Digital model: WD6400BPVT-16HXZT1
size: 596.17 GiB block size: physical: 512 B logical: 512 B rotation: 5400 rpm serial: <filter>
rev: 2.12 scheme: GPT
Partition: ID-1: / raw size: 48.85 GiB size: 48.85 GiB (100.00%) used: 23.06 GiB (47.2%) fs: btrfs
dev: /dev/sdb5 maj-min: 8:21
ID-2: /boot/efi raw size: 953 MiB size: 951.1 MiB (99.80%) used: 576 KiB (0.1%) fs: vfat
dev: /dev/sdb6 maj-min: 8:22
ID-3: /home raw size: 587.07 GiB size: 587.07 GiB (100.00%) used: 7.82 GiB (1.3%) fs: btrfs
dev: /dev/sdd2 maj-min: 8:50
ID-4: /var/log raw size: 48.85 GiB size: 48.85 GiB (100.00%) used: 23.06 GiB (47.2%) fs: btrfs
dev: /dev/sdb5 maj-min: 8:21
ID-5: /var/tmp raw size: 48.85 GiB size: 48.85 GiB (100.00%) used: 23.06 GiB (47.2%) fs: btrfs
dev: /dev/sdb5 maj-min: 8:21
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 3.88 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: 1024 dev: /dev/sdd3
maj-min: 8:51
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 41 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:      Processes: 258 Uptime: 50m wakeups: 0 Memory: 15.5 GiB used: 3.6 GiB (23.2%) Init: systemd
v: 247 Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1527 pacman: 1521 lib: 444 flatpak: 6
Shell: fish v: 3.1.2 running in: konsole inxi: 3.3.01

My personal experience with Wayland on KDE: lots of stuff is not ready yet (appmenu support was not working properly for example along with applications like flameshot not working at all)
So unless you have a good reason to use Wayland I'd just stick to X11

4 Likes

Oh alright then. Wayland worked fine in gnome and I saw KDE got some support as well, didn't expect anything this bad. x11 is pretty old now and I would like to something new which works faster, but I think that I have to just wait for now.

Yes, KDEs support for Wayland got better with the last updates but for my personal taste its not usable with dr460nized (force blur is also not working, ugh! :joy:)

2 Likes

GNOME wayland support is most likely the best of the desktops.

1 Like

nope, pretty expected, as its what happened to me also. Sorry

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.