Wayland , global menu

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:

garuda-inxi

Kernel: 6.1.4-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5fbd1add-9f9f-492d-bf66-9f61355d7cdc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 amd_iommu=on iommu=pt video=efifb:off ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_wayland vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 4403
date: 04/28/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse PID:003f
serial: N/A charge: 55% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard PID:0065
serial: N/A charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64
type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 3530 high: 4100 min/max: 1400/4100 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1636 2: 4097
3: 4085 4: 4088 5: 2048 6: 4100 7: 4091 8: 4099 bogomips: 65594
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
vendor: Sapphire driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1,DP-2,HDMI-A-1 empty: DP-3 bus-ID: 03:00.0
chip-ID: 1002:73df class-ID: 0300
Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: ASUSTeK driver: N/A alternate: amdgpu arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0d:00.0 chip-ID: 1002:15d8 class-ID: 0300
Device-3: Sunplus Innovation AUSDOM FHD Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 7-1.4:4 chip-ID: 1bcf:2286
class-ID: 0102
Display: wayland server: X.org v: 1.21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_wayland driver: X: loaded: modesetting unloaded: vesa
alternate: fbdev dri: radeonsi gpu: amdgpu d-rect: 6560x3060 display-ID: 0
Monitor-1: DP-1 pos: bottom-c res: 2560x1080 size: N/A modes: N/A
Monitor-2: DP-2 pos: top-right res: 1440x900 size: N/A modes: N/A
Monitor-3: HDMI-A-1 pos: middle-l res: 2560x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 22.3.2 renderer: AMD Radeon RX 6750 XT (navi22
LLVM 14.0.6 DRM 3.49 6.1.4-zen2-1-zen) direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 5-3:3 chip-ID: 0951:16df gen: 4 speed: 16 GT/s class-ID: 0300
lanes: 16 serial: <filter> bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Raven/Raven2/Fenghuang HDMI/DP Audio
vendor: ASUSTeK PRIME B450M-A driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:15de class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 0d:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-4: Kingston HyperX QuadCast type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-5: Sunplus Innovation AUSDOM FHD Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 7-1.4:4 chip-ID: 1bcf:2286
class-ID: 0102
Sound API: ALSA v: k6.1.4-zen2-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 7-1.1.3:8 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 6.03 TiB used: 2.73 TiB (45.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T2B0C size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 211210WD temp: 42.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:10 vendor: Patriot model: M.2 P300 1024GB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: T0918A0L temp: 31.9 C scheme: GPT
ID-3: /dev/nvme2n1 maj-min: 259:5 vendor: Crucial model: CT1000P1SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: P3CR013 temp: 40.9 C scheme: GPT
ID-4: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EALX-009BA0
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 1H15 scheme: GPT
ID-5: /dev/sdb maj-min: 8:16 vendor: SanDisk model: Emtec X150 480GB
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 656 scheme: MBR
ID-6: /dev/sdc maj-min: 8:32 vendor: Toshiba model: TR150 size: 447.13 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 12.3 scheme: GPT
ID-7: /dev/sdd maj-min: 8:48 vendor: Toshiba model: MK6465GSXN
size: 596.17 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: 1M scheme: GPT
ID-8: /dev/sde maj-min: 8:64 vendor: Seagate model: ST9500325AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: HPM1 scheme: GPT
ID-9: /dev/sdf maj-min: 8:80 type: USB vendor: JMicron Tech model: N/A
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B type: N/A
serial: <filter> rev: 0213 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 219.9 GiB size: 219.9 GiB (100.00%)
used: 135.64 GiB (61.7%) fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:7
ID-2: /boot/efi raw-size: 2.05 GiB size: 2.05 GiB (99.80%)
used: 633.9 MiB (30.2%) fs: vfat dev: /dev/nvme2n1p1 maj-min: 259:6
ID-3: /home raw-size: 306.04 GiB size: 306.04 GiB (100.00%)
used: 238.16 GiB (77.8%) fs: btrfs dev: /dev/nvme2n1p3 maj-min: 259:8
ID-4: /var/log raw-size: 219.9 GiB size: 219.9 GiB (100.00%)
used: 135.64 GiB (61.7%) fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:7
ID-5: /var/tmp raw-size: 219.9 GiB size: 219.9 GiB (100.00%)
used: 135.64 GiB (61.7%) fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 29.28 GiB used: 879.2 MiB (2.9%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 56.4 C mobo: N/A gpu: amdgpu temp: 43.0 C
mem: 42.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 566 Uptime: 2h 4m wakeups: 4 Memory: 29.28 GiB
used: 12.51 GiB (42.7%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 3585
pm: pacman pkgs: 3248 libs: 628 tools: octopi,pamac,paru,trizen,yay
pm: flatpak pkgs: 337 Shell: Zsh v: 5.9 running-in: yakuake inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-01
Last full system update: 2023-01-12 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut(custom) mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            logrotate.service numlockx_on.service samba.service systemd-networkd-wait-online.service XranDR_HDMI-0_HDMI-1.service

I have problems with waylan and the global menu in plasma, does anyone have it working ?

It should be working, though some applications don't support it natively afaik. At least that's my personal experience :eyes:

I use Global Menu widget with Wayland and it works great (no glitches).
What is your "problem" that you are talking about?

Here it works fine for Qt apps, LibreOffice, GTK apps running via Xwayland but not for most GTK apps via native Wayland. AFAIK this is because GTK developers chose not to support server side decoration in Wayland.

2 Likes

I have reset, generated a new panel and again added global menu, it works on almost everything but does not work with obs 29 (I don't know how to activate obs own menu either). (plasma)

Encontré una solución al menú de obs
qdbus org.kde.kded5 /kded org.kde.kded5.unloadModule "appmenu" && /obs & sleep 30 && qdbus org.kde.kded5 /kded org.kde.kded5.loadModule "appmenu"

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.