Visual bug when snapping some windows

Hello! It seems that while snapping some windows (e.g. Emacs or Timeshift) to an edge of the screen, a small gap followed by a thin line appears where the window's border should be. This appears to only affect the Sweet theme. Does anyone have the same issue? If it's a Sweet bug, why does it happen only on some windows?

Edit: Tried turning off window borders from theme settings to no avail.

Please open issue.

Or on KDE, IDK :slight_smile: but IIRC there are open ~ 30,000 issues.


Will do. But can you reproduce it?

Nope, I changed the theme, icons and so on. I am not the pink and apple lover, so I changed most to blue :slight_smile: :wink:

Oops, I use KDE only for playing around, my basic workflow is on i3wm

1 Like

(I personally kept Sweet but changed wallpapers + papirus icon theme cause there was too much purple/orange). I'll report to Sweet then.

You might want to try this as well.

1 Like

Thanks, no luck unfortunately.

did yours just start to do this a few days ago? thats about when mine started..

I'm not sure when it started, I don't snap windows very often. Also, did you reboot after selecting the smoothest animations (cause I didn't)? Weird that the compositor options have an effect on this...

Edit: Forgot to mention, changing any of those options, redraws the desktop, temporarily solving the issue. Snap the window again and the problem persists (on my case at least).


so mine is still doing it also but it just seems to happen when i close a window and the existing one moves to fill in its place,

so i have the same issue still going on

Setting XRender as a rendering backend solves the issue for me, but now blur does not work. Confirmed with other themes as well, so it's a KDE issue. Good luck getting it fixed anytime soon.

Edit #1: Seems it's a GTK thing; Qt works fine. So, for example, most KDE applications are unaffected, whereas Emacs, Timeshift, Transmission-gtk etc have the issue.

i have my setting to OpenGL 2.0, i cant remember now why i switched from 3.1 to 2.0 now, i think i had an issue with LatteDock, and switching fixed that issue for me then around a month later this has,, at least im not the only one so im sure the bug will be addressed eventually, not the end of the world :joy:

Try a kwin restart as a simple workaround (or restart plasma). .


... that worked. But why? So all I got to do is schedule a kwin restart when I log in?

kwin_x11 --replace & disown

Edit: The issue reappeared a few moments later. Does anyone now if this bug has been reported?

1 Like
check it out and see if any have been reported,,

1 Like

Not likely, I don't see anything. There are a lot of bugs regarding snapping.

What are your theme settings for GNOME/GTK in KDE Settings Manager?


The default ones. I'm starting to believe it's a GTK thing. For example, transmission-qt doesn't have the issue, while transmission-gtk has it. And the issue has to do with the window decorations, not the theme in gereral.

1 Like

The issue was fixed with kwin 5.23.0-1 (or maybe it was kde-gtk-config 5.23.0-1).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.