Vfs unable to mount root fs on unknown-block(0 0)

I recently moved free space between partitions and made my Garuda non-usable. I get this when I boot in Garuda(Here showed main part. Output is more):
vfs unable to mount root fs on unknown-block(0 0)

I could only boot into 3rd option in Advanced options for Garuda

Users in arch forums prefered update-initramfs with -k -u but I found that it replaced with mkinitcpio in Garuda and I used mkinitcpio -P for all presets. After that I rebooted and still same error. I tried update-grub but it not worked too. My fs is ext4 so tried adding ext in Modules="" at /etc/mkinitpcio.conf and reran mkinitpcio -P but still same. Tried sudo pacman -Syu(hoped that it will fix something) but it not worked too. What can I do? I have access to 2 other Debian based distros,1 Windows and Garuda's 3rd option in this laptop. How can I fix it??

For the features of Garuda it must be Btrfs.

chroot in Garuda with live ISO and repair grub. Only Garuda can boot all other OS.
Win and some other OS dosn't see Garuda :slight_smile:

Check you file systems and /etc/fstab

sudo lsblk --paths --tree --include 8 --output parttype,partlabel,uuid,name,fstype,label,mountpoint
4 Likes

Yes, yes, my Win10 is ready for use in the bootloader.

I fixed it thanks to my friend. Checked fs hundred times but it not helped. We worked on it like 4 hours and now Garuda works. My grub messed up + UUID problems after moving partitions and etc. Anyways,thanks for reply.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.