Vertical Lines on Screen During Intensive Use

Recently installed Garuda Linux, and was previously running Windows on this machine. It seems whenever I do something like play a game or do other intensive tasks, I get weird vertical lines covering sections of my screen that vary in color form blue to green. I have suspicions that it depends on what color the monitor is showing in that area. The screen also occasionally flickers have tried using this monitor with another computer running windows, and it worked fine. I have also tried reinstalling the proprietary drivers. Sort of new to this kind of thing, so I apologize if I have not provided any useful information, but I would be happy to provide anything to help solve this problem. Any help is greatly appreciated.

Kernel: 6.1.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1c57906c-e1ce-4ad1-8048-3d8e227f0919 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 3603
date: 03/20/2021
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 2199 high: 2201 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: powersave cores: 1: 2200 2: 2200
3: 2200 4: 2201 5: 2200 6: 2198 7: 2200 8: 2200 9: 2200 10: 2200 11: 2198
12: 2200 bogomips: 86407
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Micro-Star MSI
driver: nvidia v: 525.85.05 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2022-12) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.0 chip-ID: 10de:1e89 class-ID: 0300
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
s-diag: 693mm (27.28")
Monitor-1: DP-2 res: 1920x1080 dpi: 82 size: 598x336mm (23.54x13.23")
diag: 686mm (27.01") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA GeForce RTX
2060/PCIe/SSE2 direct render: Yes
Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus-ID: 1-2.2:6 pcie: chip-ID: 0d8c:0005 class-ID: 0300 gen: 3
speed: 8 GT/s serial: <filter> lanes: 16 bus-ID: 09:00.1
chip-ID: 10de:10f8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media Blue Snowball type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-4: Oculus VR Rift S type: USB
driver: cdc_acm,hid-generic,snd-usb-audio,usbhid bus-ID: 7-2.2:4
chip-ID: 2833:0051 class-ID: 0300 serial: <filter>
Sound API: ALSA v: k6.1.8-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
v: 0.8 bus-ID: 3-5:2 chip-ID: 8087:0025 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 4.66 TiB used: 181.89 GiB (3.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 37.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: A-Data model: SP550 size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 0C scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 870 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Toshiba
model: External USB 3.0 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 5438 scheme: MBR
ID-1: / raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 27.79 GiB (56.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 26 MiB (5.1%) fs: vfat dev: /dev/sdb3 maj-min: 8:19
ID-3: /home raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 27.79 GiB (56.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-4: /var/log raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 27.79 GiB (56.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 48.83 GiB size: 48.83 GiB (100.00%)
used: 27.79 GiB (56.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 35.6 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 317 Uptime: 23m wakeups: 0 Memory: 31.26 GiB
used: 5.09 GiB (16.3%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1928
pm: pacman pkgs: 1918 libs: 513 tools: octopi,paru pm: flatpak pkgs: 10
Shell: fish v: 3.6.0 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2023-01-30
Last full system update: 2023-02-01
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Welcome :slight_smile:

Try to start your games in terminal and check the log of errors.
Check in second terminal also the output from top/htop.

If you do not find something about in Whoogle post the log as text like your garuda-inxi.


I ran a test on Team Fortress 2, Valheim, and Minecraft. TF2 and Valheim provided very similar errors. Minecraft provided no errors, but the line effect still took place when flying quickly. I want to also add Minetest gave no errors and had I did not notice the effect. Thank you for your help. Below will be the log form TF2, but with some duplicate Xlib errors removed that also occurred while playing Valheim. I tried to search the errors but could not find anything.

edit: I also would like to add that one time I ran Valheim windows mode and I noticed the lines turned blue like my latte dock on the bottom of my screen.

Xlib: sequence lost (0x10000 > 0x8794) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x8796) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x8798) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x879a) in reply type 0xc!
src/steamexe/main.cpp (254) : Assertion Failed: reaping pid: 2680 -- gameoverlayui

src/steamexe/main.cpp (254) : Assertion Failed: reaping pid: 2680 -- gameoverlayui

(steam:1762): GLib-CRITICAL **: 20:42:46.694: g_main_context_push_thread_default: assertion 'acquired_context'failed

(steam:1762): GLib-CRITICAL **: 20:42:46.694: g_main_context_pop_thread_default: assertion 'g_queue_peek_head (stack) == context' failed
Xlib: sequence lost (0x10000 > 0x879c) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x879e) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x87a0) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x87a2) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x87a4) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x87a6) in reply type 0xc!
Xlib: sequence lost (0x10000 > 0x87a8) in reply type 0xc!

Check in the system settings the status of the "compositor", and try changing those settings. Sorry it's just a random testing, but sometimes it was useful in the past. E.g. a user solved a similar problem disabling "Allow applications to block mode with graphical effects".
Try also playing with the compositor disabled. You can enable / disable the compositor on the fly with alt+shift+F12.


It seems after turning it off, and leaving it on but changing the settings didn't affect the lines. For some reason though it seems to be happening randomly less. At first it happened a lot on TF2, now its more rare. It still happens a lot on other games like Valheim though. Thank you for the recommendation, I really appreciate the help.

edit: I also want to add I have been trying to set up a vm that won't start, and whenever it fails to start the area around my latte dock gets strong vertical blue lines covering it.

edit 2: I have now noticed it only flickers on the edge of the screen, and rounds off on the corners.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.