Using pacdiff

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

garuda-inxi
[email protected] in ~
 λ garuda-inxi
System:
  Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c4c19518-b086-4a0d-86b1-6b98a7a5fc2e rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
    v: 059A100000204610000020100 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 1697 v: KBC Version 16.24
    serial: <superuser required> BIOS: Hewlett-Packard v: F.44 date: 11/14/2011
Battery:
  ID-1: BAT0 charge: 35.4 Wh (100.0%) condition: 35.4/35.4 Wh (100.0%)
    volts: 12.4 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: Full
CPU:
  Info: model: AMD Athlon II P360 bits: 64 type: MCP arch: K10
    family: 0x10 (16) model-id: 6 stepping: 3 microcode: 0x10000C8
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 256 KiB
    desc: d-2x64 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
  Speed (MHz): avg: 1250 high: 1700 min/max: 800/2300 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1700 2: 800
    bogomips: 9177
  Flags: ht lm nx pae sse sse2 sse3 sse4a svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD RS880M [Mobility Radeon HD 4225/4250] vendor: Hewlett-Packard
    driver: radeon v: kernel alternate: amdgpu bus-ID: 01:05.0
    chip-ID: 1002:9712 class-ID: 0300
  Device-2: Alcor Micro HP Webcam-101 type: USB driver: uvcvideo
    bus-ID: 2-2:2 chip-ID: 058f:a001 class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.3 compositor: gnome-shell driver:
    loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0")
    s-diag: 338mm (13.3")
  Monitor-1: VGA-0 res: 1024x768 hz: 60
  Monitor-2: LVDS res: 1024x768 hz: 60 dpi: 76 size: 344x194mm (13.5x7.6")
    diag: 395mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD SBx00 Azalia vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD RS880 HDMI Audio [Radeon HD 4200 Series]
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 01:05.1
    chip-ID: 1002:970f class-ID: 0403
  Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus-ID: 02:00.0
    chip-ID: 10ec:8136 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter
    vendor: Hewlett-Packard U98Z062.12 802.11bgn driver: ath9k v: kernel
    bus-ID: 03:00.0 chip-ID: 168c:002b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 4-1:2 chip-ID: 0a12:0001 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 447.13 GiB used: 33.95 GiB (7.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0101 scheme: MBR
Partition:
  ID-1: / raw-size: 447.13 GiB size: 447.13 GiB (100.00%)
    used: 33.95 GiB (7.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 447.13 GiB size: 447.13 GiB (100.00%)
    used: 33.95 GiB (7.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 447.13 GiB size: 447.13 GiB (100.00%)
    used: 33.95 GiB (7.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 447.13 GiB size: 447.13 GiB (100.00%)
    used: 33.95 GiB (7.6%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.51 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.8 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 238 Uptime: 1h 30m wakeups: 1 Memory: 7.51 GiB
  used: 2.71 GiB (36.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1653 lib: 371 Shell: fish
  v: 3.3.1 running-in: alacritty inxi: 3.3.12
Garuda (2.5.4-2):
  System install date:     2022-01-16
  Last full system update: 2022-02-03
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:

 [email protected] in ~ took 2s
 λ

And I used pacdiff for the first time. Results follow.

sudo pacdiff --find
[sudo] password for arthur:
==> pacnew file found for /etc/pacman.d/mirrorlist
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] o
renamed '/etc/pacman.d/mirrorlist.pacnew' -> '/etc/pacman.d/mirrorlist'
==> pacnew file found for /etc/sudoers
:: (V)iew, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q] o
renamed '/etc/sudoers.pacnew' -> '/etc/sudoers'

Then I ran garuda-update and got no merge warnings.
My question . Is this the right thimg to do? I am an arch newby btw

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

What you should with each file depends totally on what the file is.

The first file is your mirrorlist. Overwriting your mirrorlilst with a default file is probably not the right option. You should probably resort your mirrors to fix that.

The second is sudoers. If you can any custom sudo changes in there, you overwrote them. If not, no big deal either way.

In general, if you are going to overwrite a file, you should understand why you are overwriting it and not do it blindly.

6 Likes

Also worth reading:

https://wiki.archlinux.org/title/Pacman/Pacnew_and_Pacsave

5 Likes

Thanks for the heads up. Garuda-update rebuilt my mirror list for me so I dodged a bullet there.

1 Like

Thanks also. Thats where I read about pacdiff , knowing just enough to be dangerous lol

2 Likes

You can also explore meld once installed you can issue sudo DIFFPROG=meld pacdiff to manage .pacnew files.

5 Likes

I have just installed meld and looks promising. I have historical .bashrc files I can test it out on. And thanks for the tip.

Make an alias :slight_smile:
alias pacdif='sudo DIFFPROG=meld pacdiff'

7 Likes

For the amount of times I use it...I just type it out. :hugs:

3 Likes

This was actually a helpful thread for me... I kept seeing the .pacnew messages during my upgrades and had been meaning to learn more about what they were but hadn't done so, yet. So it seems like something easy to take a look at and try to handle the merge conflicts to get rid of those messages.

1 Like

Hi , same here tho everytime I got mirror timing out I used refresh mirrors in garuda assistant. So when i did a pacdiff that was one of my merge items , which I probably shouldnt have overwritten, but running garuda update in terminal twice seemed to fix any issues and restored my mirrors plus no merge nags, Just so you know lol
P.S. Asbackup. I have a copy of every mirror in the world as backup asonce somehow my mirrorlist got itself empt[ed out. I put about 20 Canadian mirrors in the file and boom. It worked. I almost sprained my shoulder patting myself on the back.

The Canadian mirrors seem a little slow to update, the US mirrors seem to update about 6 hours sooner but the end result is the same.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.