USB not detected by Garuda?

So I want to use my usb on Garuda Linux, I plugged it in and noticed it isn't being detected by the system. When I input

sudo blkid -o list

The only devices detected are /dev/nvme0n1p1, and /dev/nvme0n1p2
which are partitions of my ssd I believe. I also tried packages suggested by other threads like the usb 3.0 firmware from AUR.

I know for a fact the usb works, when I plug it into a mac or windows computer it functions just fine

I guess you came accross also this one, but just in case...:

1 Like

yes that was the one, I installed it but it did not fix anything

1 Like

Try to check usb port 's version , sometimes usb 3.1 is not backward compatible .
Also try to check the bios if the pendrive works really it will show for your system.
3rd- try to format the pendrive with other pc.

1 Like

Yeah its a 2.0 it would work, the bios picked it up too. I reinstalled the xhci_pci module, for some reason it didnt work the first time and it worked.

1 Like

If you update the kernel then new devices (like USB flash drives) won't be detected until after you reboot.


If its a laptop try plugging in your usb while having your charger disconnected, sometimes its a broken charger i had the same issue

You never provided your system specs.

As text post:

inxi -Fxxxza

If this is an older Gigabyte mobo this may be a bios issue that requires adding the iommu=soft grub kernel boot parameter for your USB ports to work.

However, without your system specs it's impossible to say.

You should never open a technical help request without providing your system specs in full via an inxi output.