Usb boot with nvidia: error after 'automatic driver instalation via MHWD'

First of all thanks to anyone who's taking their time to read this I hope you can help.

I flashed the latest garuda i3wm edition to a usb stick and tried booting with proprietary drivers. It seems not not get passed the MHWD section. Sorry to break the rules but I cannot copy this text. Because I am a new user I cannot upload so here is a link using imgbb: 1658927943899357855243839535341 — ImgBB

Hi there, welcome to the forum.
First thing to try would be to boot with free drivers (proprietary drivers can be installed later).
If this is not working, you should specify what you did so far.
iso checksum verified?
What tool did you use to flash the USB?
Etc. (ref. also installation instructions on web site and Wiki page),


Thanks for the quick response! I have already tried using the free drivers before and that worked but I ran into issues mainly a black screen after trying to install the proprietary drivers afterwards so I tried taking a step back. For the flashing I used the newest version of rufus on windows 11. I'll try installing the free drivers again.


Usually we prefer / suggest Ventoy or Balena Etcher, but this shouldn't be the issue probably. Let's just keep this in mind. Just in case.

How did you do it / are you going to do it again? I assume you'll install again with free driver and install after the proprietary drivers.
Best thing would be to use Garuda Welcome - > Garuda Settings Manager - > Hardware Configuration.
After installing with free drivers and before trying with the proprietary one, you could take the chance to provide your garuda-inxi information from terminal.


Create a bootable USB using Garuda Downloader or (DD/Etcher/Ventoy/Rufus).

Garuda Downloader

Garuda Downloader is a user-friendly ISO downloader focusing on saving bandwidth via delta downloads by utilizing zsync2. It provides an easy UI for downloading the latest (official, not development) live images of all official editions. On Linux, you can manually select an older ISO file as a "seed" file in order to save bandwidth.
After an ISO file has been downloaded, it provides a button to quickly launch a recommended flashing tool (Etcher on Linux, Rufus on Windows (only because the Rufus executable is tiny)). This is the recommended way to download Garuda Linux.


All in all, Ventoy is the easiest way :slight_smile:

Normally the installer falls back to the open source version if the proprietary drivers do not work.
Are you using very old or very new hardware?


I see in the profile :slight_smile:

CPU: Intel i7 12th gen
GPU: Nvidia GeForce RTX 3080 laptop

This reminds me of this old but still open (I think) issue:

Probably the first garuda-update doesn't "see" the Nvidia drivers and does not add the
ibt=off kernel parameter
So after installing proprietary drivers you could try to add it manually or boot to a tty and garuda-update again.
Edit: actually it is garuda-migrations to do the ibt=off job, but the concepts remain valid.


Hey so I just installed the free driver version. So here is the garuda-inxi:

  Kernel: 5.18.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=9218818d-7611-43bd-b185-d23cef38ae52 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
  Desktop: i3 v: 4.20.1 info: i3bar dm: LightDM v: 1.30.0
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: Vector GP76 12UH v: REV:1.0
    serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Micro-Star model: MS-17K4 v: REV:1.0 serial: <filter>
    UEFI: American Megatrends LLC. v: E17K4IMS.404 date: 01/21/2022
  ID-1: BAT1 charge: 60.0 Wh (98.4%) condition: 61.0/63.2 Wh (96.4%)
    volts: 17.0 min: 15.2 model: MSI BIF0_9 type: Li-ion serial: N/A
    status: N/A
  Info: model: 12th Gen Intel Core i7-12700H socket: U3E1 bits: 64
    type: MST AMCP arch: Alder Lake gen: core 12 built: 2021
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x41C
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 500 high: 1363 min/max: 400/4679:4700:3500
    base/boost: 4059/4700 scaling: driver: intel_pstate governor: powersave
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1363 2: 499 3: 432 4: 407
    5: 425 6: 419 7: 440 8: 474 9: 403 10: 418 11: 447 12: 789 13: 528
    14: 528 15: 446 16: 400 17: 400 18: 400 19: 400 20: 399 bogomips: 107520
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB]
    vendor: Micro-Star MSI driver: nouveau v: kernel non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16
    ports: active: none empty: DP-3, DP-4, HDMI-A-1, eDP-2 bus-ID: 01:00.0
    chip-ID: 10de:249c class-ID: 0300
  Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-7:4
    chip-ID: 5986:211c class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 driver: X:
    loaded: modesetting,nouveau alternate: fbdev,intel,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: Sharp LQ173M1JW08 built: 2021 res: 1920x1080
    hz: 60 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
    diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Micro-Star MSI driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
  Sound Server-1: ALSA v: k5.18.12-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.55 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:6
    chip-ID: 8087:0033 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Local Storage: total: 982.2 GiB used: 6.3 GiB (0.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron
    model: 2450 MTFDKBA1T0TFK size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: V5MA010 temp: 38.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB model: FNK TECH size: 28.33 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
    rev: 1.30 scheme: MBR
  ID-1: / raw-size: 434.94 GiB size: 434.94 GiB (100.00%)
    used: 6.27 GiB (1.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
    used: 28.1 MiB (9.5%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 434.94 GiB size: 434.94 GiB (100.00%)
    used: 6.27 GiB (1.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-4: /var/log raw-size: 434.94 GiB size: 434.94 GiB (100.00%)
    used: 6.27 GiB (1.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-5: /var/tmp raw-size: 434.94 GiB size: 434.94 GiB (100.00%)
    used: 6.27 GiB (1.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.33 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 425 Uptime: 4m wakeups: 1025 Memory: 15.33 GiB
  used: 2.1 GiB (13.7%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1189 lib: 313
  Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: alacritty
  inxi: 3.3.19
Garuda (2.6.5-1):
  System install date:     2022-07-27
  Last full system update: 2022-07-27
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:
[[email protected] ~]$
So you could try to add it manually or boot to a tty an
bash: So: command not found

Please read

I don't think tty wanted to open when I tried it last time.
I will try again though using the steps you told me.

If you cannot switch to a tty, boot to a tty.
When you're in the grub line you use press button E, go to the end of the line starting with linux and add 3 (with a space before), then ctrl+x
Same to add there (temporarily, for that boot) ibt=off (just to see if it works, if you boot, a garuda-update will put it there for the next times).
Edit: actually it is garuda-migrations to do the ibt=off job, but the concepts remain valid.


Do you want me to change the l\oglevel=3 to l\oglevel= 3?

No, after loglevel=3 add a space and a 3


I got into the tty and did another garuda-update still not fixed after normal reboot is there another step?

Please try, with the same procedure, adding ibt=off instead of 3


That works! So do i need to make that default somehow?

To add the parameter to grub, open a terminal, and type the following:

  1. sudo micro /etc/default/grub
  2. Add the kernel parameter ibt=off to the following line: GRUB_CMDLINE_LINUX_DEFAULT .
  3. ctrl+q to exit and “Y” to save.
  4. sudo update-grub

Done, thank you very much!

1 Like

It is still open. STILL.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.