USB Boot Not Working

I used Etcher, Rufus and even CMD commands to make bootable flash drive but none of them worked. Tried Checking on Forum/FAQ/Telegram support as well but nothing.
I get the option to boot into Garuda Linux properly but when I select the option it does not boot and a black screen appears for ever.

I am using a 8GB Sony Flash Drive.
System Config
Processor AMD A12-9720P RADEON R7, 12 COMPUTE CORES 4C+8G, 2700 Mhz, 4 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM) 8.00 GB

Change driver to free, instead of nonfree. This is only about nvidia GPU systems.
For every system with any GPU except Nvidia, always use this at ISO grub menu

1 Like

I did try that option too. As it was suggested in FAQ for NVIDIA drivers and some issues with driver updates too. Tried accessing Bootloader suggested in FAQ but that too did not work.

Press ESC on boot and post messages as text, mhwd need sometimes 4 min.

1 Like

Hi , made a bootable USB using mint tools formating and creating . Unfortunately after grub , can see option screen ok , have modified to my preferences , incl. non free and free driver , but nothing happens screen .....
Has someone an idea ?


1 Like

All right , will give it a try again , and I'll come back

Pressing escape on grub , didn't change anything .
Black screen , nothing else
what else can I do
I have tried Garuda KDE Dr460nized and Garuda KDE Multimedia.

Use search function.
And I wrote on boot not on grub.


I tried every aspect that newbies can from everywhere else and none worked. Someone from MODS suggested me to wait for a new update with open source drivers, I did same and it worked. I am posting this from my GARUDA KDE Multimedia DE. It just worked with open source drivers option available in boot menu.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.