Updating wrecks performance

Hi

After updating using the setup assistant and manually with pacman -Syu (both reproduce the same issues) my system works really slow.
My fps drops in World of warcraft from betwen 60-100fps(stable) at install, down to 5-15fps after updating.
Logging in, launching applications and even navigating firefox tabs are sluggish and unresponsive (works great ootb).

I've tried both video-nvidia-dkms and the video-chaotic-nvidia-dkms-tkg (default after updating iirc)

gpu driver

Selected option on image broke it further. And the snapshot uses chaotic-nvidia.dkms-tkg without issues, so the video driver rabbit hole seems bust.

One option I did chose while updating was to "Replace knetattach with extra/plasma-desktop?" which I was prompted by pacman when first initializing the update (both using the Setup manager and manually with pacman). It seemed to be the defaul option (capital -Y).
I'm really uncertain if this is relevant or not.

Using timeshift to bring me back to the initial installation solves these things. I'm at a loss as to what's breaking my system.
Any and all input is greatly appriciated.

System

OS: Garuda Linux x86_64
5.10.8-112-tkg-bmq
CPU: Intel i5-9400F (6) @ 4.1GHz
Memory: 4327MiB / 48104MiB (8%)

GeForce GTX 980
NVIDIA-SMI 460.32.03 Driver Version: 460.32.03 CUDA Version: 11.2

Which packages are being updated?

1 Like

I encountered the same behaviour:

I think there is a bug regarding auto-cpufreq.service.
After the first update my desktop run at lowest possible speed, but there is no battery to save!
So my first action after a fresh install of garuda is:

systemctl disable auto-cpufreq
reboot

Thereafter everything runs as expected

If it does´nt help undo by
systemctl enable auto-cpufreq
reboot

Give it a try

4 Likes

If that doesn't work then test at least 3 alternate kernels.

2 Likes

It's a fresh install, straight from the inital setup to updating as I do for most installs.
So I imagine almost everthing (did try both with the 'ultimate' packages installed, and without). In this snapshot I can't seem to locate the old log files (I assume as I've never used pacman before, that it does log?)

I will see if I can update packages only and not the Kernel, as a pacman -Syu does update kernel aswell?


I'll give this a go first and see, it does sound promising.


If this fails I'll go down the alternate kernels route. I'm somewhat of a novice, so I imagine I'll get utterly get lost there :slightly_smiling_face:

Changing kernels doesn't get much simpler than with Garuda. You can use the terminal (pacman or MHWD) or the GUI kernel update/install utility.

You can also freeze/hold packages from being updated either through Pacman or with the GUI updater Pamac.

Search the forum for more info.

2 Likes

Go to program that controls the CPU and switch it from On Demand mode to Performance. It helped me at least

1 Like

How can I make this persistant? Anytime I update now, the problem return. Do I need to exclude it from pacman?

Try using mask instead of disable, but that might not be enough. It might take creating a post install pacman hook to disable it after every update.

1 Like

Check

systemctl status auto-cpufreq
systemctl --now disable auto-cpufreq
systemctl status auto-cpufreq
1 Like

You could also create a systemd start up service using "disable --now" to disable it at each startup (no reboot required using --now").

@SGS spellcheck added extra spaces in your commands. :wink:

https://wiki.archlinux.org/index.php/Systemd

Have a read on writing Systemd services. If you can't make heads or tails of it I can help you. It's pretty easy once you've written a few for your self.

1 Like

_Nope_maybe_look_like,_but_work_in_terminal :smiley:

2 Likes

Ok then never mind.

Spellcheck is always doing that on my phone (it drives me crazy). :grinning_face_with_smiling_eyes:

2 Likes

Until this is fixed in the relevant package, you should keep disabling auto-cpufreq after garuda-common-settings upgrade.

@librewish @dr460nf1r3 garuda-common-settings re-enables services after each upgrade. I think this should be done only on install.
The package needs some love.

3 Likes

Yeah its on todo list
We will remove performance-tweaks being a dep of other packages
And also remove service enabling things from setting packages
And add option in garuda-assistant to remove performance-tweaks.

4 Likes