Updating garuda/mhwd-nvidia fails

When I try to update the system, it fails:

 ╭─mast@mast in ~ took 1ms
 ╰─λ garuda-update --skip-mirrorlist
[sudo] password for mast:
:: Synchronizing package databases...
 garuda is up to date
 core is up to date
 extra is up to date
 multilib is up to date
 chaotic-aur                                    762.5 KiB   294 KiB/s 00:03 [-------------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (1)         Old Version  New Version    Net Change

garuda/mhwd-nvidia  555.58.2-1   555.58.02.1-1    0.00 MiB

Total Installed Size:  0.02 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
(1/1) checking keys in keyring                                              [-------------------------------------------] 100%
error: failed to commit transaction (could not find or read package)        [Co  o  o  o  o  o  o  o  o  o  o  o  o  o  ]   0%
Errors occurred, no packages were upgraded.

I’ve tried clearing the pacman cache but that didn’t help.
I also searched online and found a few similar issues like this one from arch wiki but it didn’t look like the same problem I was having so here I am.

System:
  Kernel: 6.9.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d769ad28-a2e1-4ec6-9b61-fefbcafad6a2 rw rootflags=subvol=@
    quiet resume=UUID=eba03232-f5b8-453b-90fe-348deec90307 loglevel=3
    nvidia-drm.modeset=1 ibt=off
  Desktop: Hyprland v: 0.41.2 with: Docker,waybar tools:
    avail: swayidle,swaylock vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G15 GA503RW_GA503RW
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: GA503RW v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: GA503RW.313
    date: 01/17/2023
Battery:
  ID-1: BAT1 charge: 66.0 Wh (74.6%) condition: 88.5/90.2 Wh (98.1%)
    volts: 16.2 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: not charging
CPU:
  Info: model: AMD Ryzen 7 6800HS with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404101
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1532 high: 4401 min/max: 400/4785 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 2394 2: 400 3: 1615
    4: 1387 5: 2009 6: 400 7: 2394 8: 400 9: 3562 10: 1986 11: 1971 12: 400
    13: 400 14: 400 15: 4401 16: 400 bogomips: 102209
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GA104 [Geforce RTX 3070 Ti Laptop GPU] vendor: ASUSTeK
    driver: nvidia v: 555.58.02 alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
    lanes: 8 link-max: lanes: 16 ports: active: none off: HDMI-A-1,eDP-1
    empty: DP-1 bus-ID: 01:00.0 chip-ID: 10de:24a0 class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-2,
    DP-3, DP-4, DP-5, DP-6, DP-7, DP-8, DP-9, Writeback-1, eDP-2
    bus-ID: 06:00.0 chip-ID: 1002:1681 class-ID: 0300 temp: 67.0 C
  Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 13d3:56eb
    class-ID: fe01 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: Hyprland v: 0.41.2 driver: X: loaded: amdgpu,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
    gpu: nvidia,nvidia-nvswitch d-rect: 4480x1440 display-ID: 1
  Monitor-1: HDMI-A-1 pos: primary,left model: ViewSonic VG2439 Series
    serial: <filter> built: 2018 res: 1920x1080 hz: 60 dpi: 94 gamma: 1.2
    scale: 1 size: 521x293mm (20.51x11.54") diag: 598mm (23.5") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  Monitor-2: eDP-1 pos: right model: BOE Display 0x0a07 built: 2021
    res: 2560x1440 hz: 165 dpi: 189 gamma: 1.2 scale: 1
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 2560x1440
  API: Vulkan v: 1.3.279 layers: 9 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3070 Ti Laptop GPU driver: nvidia v: 555.58.02
    device-ID: 10de:24a0 surfaces: xcb,xlib,wayland device: 1
    type: integrated-gpu name: AMD Radeon 680M (RADV REMBRANDT)
    driver: mesa radv v: 24.1.3-arch1.1 device-ID: 1002:1681
    surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
    18.1.8 256 bits) driver: mesa llvmpipe v: 24.1.3-arch1.1 (LLVM 18.1.8)
    device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 06:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
    snd_sof_amd_acp63 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.9.7-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 02:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: Foxconn / Hon Hai Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:4 chip-ID: 0489:e0e2
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
  Local Storage: total: 953.87 GiB used: 124.95 GiB (13.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
    SN735 SDBPNHH-1T00-1002 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 70626000 temp: 49.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 279.66 GiB size: 279.66 GiB (100.00%)
    used: 27.36 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 279.66 GiB size: 279.66 GiB (100.00%)
    used: 27.36 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 279.66 GiB size: 279.66 GiB (100.00%)
    used: 27.36 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 279.66 GiB size: 279.66 GiB (100.00%)
    used: 27.36 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 30.59 GiB used: 221 MiB (0.7%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 33.65 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 74.8 C mobo: 46.0 C gpu: amdgpu temp: 68.0 C
  Fan Speeds (rpm): cpu: 5100
Info:
  Memory: total: 32 GiB note: est. available: 30.59 GiB used: 11.6 GiB (37.9%)
  Processes: 439 Power: uptime: 2h 11m states: freeze,mem,disk
    suspend: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.19 GiB services: upowerd Init: systemd
    v: 256 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1481 libs: 485 tools: pacseek,paru Compilers:
    gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: alacritty
    inxi: 3.3.35
Garuda (2.6.26-1):
  System install date:     2024-07-06
  Last full system update: 2024-07-09 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:
1 Like

the swosh sign says to restart the system , I guess you might have already did it , but telling if just in case you didn’t tried it .

Next if it didn’t solved your problem so I think you can try this command

garuda-update remote fix 

But be aware that if you have edited you pacman.conf then it will reset that config to default :slightly_smiling_face:

if it still doesn’t fix it, so it might be server side problem :eyes:

6 Likes

Hi there,
Just to say I have the exact same error trying to update than OP, and the “garuda-update remote fix” seems to have works.
I don’t know if the error is coming back, but for the time being, this fix works, thanks!

1 Like

Restarting didn’t fix it but, the garuda-update remote fix worked.

1 Like

Restarting didn’t fix it but, the garuda-update remote fix worked.

Can confirm, it was the same for me.

Thanks!

Hi.
Somehow, duplicate of Updating garuda/mhwd-nvidia fails - #2 by Ankur ?
I just had the same issue and, actually, I wonder why I have this package installed, as I don’t have any nvidia card on my machine?

Same here… Discord iss buggy too

We do not know the specs from OP, so.

Please, we do not support Discord, IIRC, and always one issue per topic :slight_smile:

1 Like

I could fix this by just downloading mhwd-nvidia-555.58.02.1-1-any.pkg.tar from the mirror of University of São Carlos and installing it manually.

Afterwards I was able to update my installation.

I was wondering this also. This build has never had an Nvidia card.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.