Update problems (conflicting files and read errors)

I just installed Garuda as a fresh install and I’m getting a bunch of errors every time and no matter what options I pick the update ends in failure.

error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
resolving dependencies...
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
:: There are 2 providers available for nvidia-utils=545.29.06:
:: Repository chaotic-aur
1) nvidia-utils-beta  2) nvidia-utils-nvlax

Enter a number (default=1): 1
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
error: could not parse package description file 'haskell-hie-bios-0.11.0-70/desc' from db 'extra'
error: could not read db 'extra' (Truncated input file (needed 1024 bytes, only 0 available))
:: There are 2 providers available for dbus-units:
:: Repository core
1) dbus-broker-units  2) dbus-daemon-units

Enter a number (default=1):
looking for conflicting packages...
:: nvidia-utils-beta and nvidia-utils are in conflict. Remove nvidia-utils? [y/N] y
:: chaotic-kf5-dummy and kirigami-addons5 are in conflict (kirigami-addons). Remove kirigami-addons5? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (74.2-1) breaks dependency 'libicuuc.so=73-64' requiredby gspell
:: installing icu (74.2-1) breaks dependency 'libicuuc.so=73-64' requiredby harfbuzz-icu
:: removing kirigami-addons5 breaks dependency 'kirigami-addons5' required by kdeconnect
:: removing nvidia-utils breaks dependency 'nvidia-utils=535.113.01' required by nvidia-dkms
:: installing icu (74.2-1) breaks dependency 'libicuuc.so=73-64' requiredby raptor

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

1 Like

My bad. I’ve been messing with some things and tried garuda-update remote fullfix and that ended up working partially. I did manage to at least get my graphics drivers updated so my resolution isn’t all messed up now. Now I just can’t install any new packages.

My inxi:

System:
Kernel: 6.7.0-zen3-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0412b07d-c105-4744-b28d-289c2d5b2c41 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: iBUYPOWER product: INTEL v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: PRIME Z790-P WIFI v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 1604
date: 12/15/2023
CPU:
Info: model: 13th Gen Intel Core i7-13700KF bits: 64 type: MST AMCP
arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
microcode: 0x11F
Topology: cpus: 1x cores: 16 mt: 8 tpc: 2 st: 8 threads: 24 smt: enabled
cache: L1: 1.4 MiB desc: d-8x32 KiB, 8x48 KiB; i-8x32 KiB, 8x64 KiB
L2: 24 MiB desc: 8x2 MiB, 2x4 MiB L3: 30 MiB desc: 1x30 MiB
Speed (MHz): avg: 837 high: 1100 min/max: 800/5300:5400:4200 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 1100 4: 800
5: 800 6: 800 7: 1100 8: 800 9: 1099 10: 800 11: 800 12: 800 13: 800
14: 800 15: 800 16: 800 17: 800 18: 800 19: 800 20: 800 21: 800 22: 798
23: 800 24: 800 bogomips: 164044
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA AD102 [GeForce RTX 4090] vendor: PNY driver: nvidia
v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:2684 class-ID: 0300
Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: 0
Monitor-1: DP-1 res: 2560x1440 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia
x11: drv: zink inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4090/PCIe/SSE2
memory: 23.43 GiB display-ID: :1.0
API: Vulkan v: 1.3.274 layers: 1 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 4090 driver: nvidia v: 545.29.06
device-ID: 10de:2684 surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:7a50
class-ID: 0403
Device-2: NVIDIA AD102 High Definition Audio vendor: PNY
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:22ba class-ID: 0403
Device-3: Blue Microphones Yeti Stereo Microphone
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-11.4:10 chip-ID: b58e:9e84 class-ID: 0300
serial: <filter>
API: ALSA v: k6.7.0-zen3-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 00:14.3
chip-ID: 8086:7a70 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 4000 bus-ID: 06:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:9 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c0104
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
driver: vmd v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:a77f rev:
class-ID: 0104
Drives:
Local Storage: total: 16.43 TiB used: 10.49 GiB (0.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Western Digital
model: WD BLACK SN770 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 731100WD temp: 37.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Corsair model: MP600 PRO XT
size: 7.28 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EIFM51.3 temp: 33.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST8000VN0022-2EL112
size: 7.28 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: SC61 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 model: USB DISK 3.0 size: 58.24 GiB
block-size: physical: 512 B logical: 512 B type: USB rev: 2.1 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 307.24 GiB size: 307.24 GiB (100.00%)
used: 10.46 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:8
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 26.8 MiB (27.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:4
ID-3: /home raw-size: 307.24 GiB size: 307.24 GiB (100.00%)
used: 10.46 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:8
ID-4: /var/log raw-size: 307.24 GiB size: 307.24 GiB (100.00%)
used: 10.46 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:8
ID-5: /var/tmp raw-size: 307.24 GiB size: 307.24 GiB (100.00%)
used: 10.46 GiB (3.4%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.15 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 422 Uptime: 20m wakeups: 0 Memory: total: 32 GiB
available: 31.15 GiB used: 3.2 GiB (10.3%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1221 libs: 349 tools: octopi,paru Shell: fish v: 3.7.0
running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
System install date:     2024-01-23
Last full system update: 2024-01-23
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

1 Like

Did you read

and the risks about remote commands?

Yes I read all of that before I even tried the command.

This can be closed. It turns out it was just a mirror issue. The US mirrorlist is just down at the moment it seems. I switched to UK mirrors and was able to install things just fine.

1 Like

Hmm. Worked for me this morning too - after it didn’t, exact same thing, yesterday - but by now it doesn’t work anymore.

Fehler: Konnte Datei 'extra.db' nicht von sg.mirrors.cicku.me übertragen : transfer closed with 366986 bytes remaining to read
:: Starting full system upgrade...
warning: lilv: local (0.24.24-1) is newer than extra (0.24.22-1)
warning: python-toolz: local (0.12.1-1) is newer than extra (0.12.0-3)
warning: serd: local (0.32.2-1) is newer than extra (0.32.0-1)
warning: xdg-utils: local (1.2.0r28+g9b7d253-1) is newer than extra (1.2.0r25+g0f49cf5-1)
 there is nothing to do

What’s wrong with the mirrors lately?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.