Update not working

rror: could not open file /var/lib/pacman/local/kwidgetsaddons-5.88.0-3/desc: No such file or directory
resolving dependencies...
looking for conflicting packages...
warning: could not fully load metadata for package kwidgetsaddons-5.88.0-3
error: failed to prepare transaction (invalid or corrupted package)

Hello.

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Search is your friend:

https://forum.garudalinux.org/search?q=(invalid%20or%20corrupted%20package)

Probably answered scores of times.

4 Likes

And please do not post twice.
I'm going to unlist the other topic.

4 Likes

i have tried all this and it still takes the same error.

I think you could try with something like this

1 Like

Perhaps try reinstalling kwidgetsaddons, or try installingkwidgetsaddons-git to see if it will install.

You may need to use pacman's force option. However, you must be cautious using the force flag.

You really provided very little in the way of background details about what happened, or what you have tried to resolve this. For example, did your system crash in the middle of an install? You need to keep records of everything you have tried and post the terminal outputs of any command you have run. Failing to do so results in nothing but wasted time for assistants helping on the forum. Helpers quickly tire of making suggestions to lost users and getting vague answers like "I tried all that" in return. Detailed terminal outputs solve problems, vague generalities are of little help.

Not technically a solution, but have you tried rolling back your system using a snapshot to before the botched update occurred?

You still have not posted the output of the inxi -Faz command as requested in the help template (that you quoted in your OP). Please post this information so that we may help you better. If you fail to do so your thread may be locked for failing to adhere to our forum guidlines (also quoted by yourself in your OP).

Please help us, to help you.

4 Likes

how do reinstall kwidgetaddons.git? here is the output from the terminal
: Synchronizing package databases...
core 137,5 KiB 948 KiB/s 00:00 [------------------------------------] 100%
extra 1568,8 KiB 2,70 MiB/s 00:01 [------------------------------------] 100%
community 5,9 MiB 3,89 MiB/s 00:02 [------------------------------------] 100%
multilib 150,3 KiB 1138 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur 1702,9 KiB 1701 KiB/s 00:01 [------------------------------------] 100%

Checking for keyring update before starting full system update..
warning: garuda-hotfixes-1.0.4-1 is up to date -- skipping
warning: archlinux-keyring-20211028-1 is up to date -- skipping
warning: chaotic-keyring-20210617-2 is up to date -- skipping
there is nothing to do
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: could not open file /var/lib/pacman/local/kwidgetsaddons-5.88.0-3/files: No such file or directory
warning: could not fully load metadata for package kwidgetsaddons-5.88.0-3
error: failed to prepare transaction (invalid or corrupted package)
Press enter to exit

and i have tried to reload the keys and still it did not work.

Have you tried the suggestion I posted above?
I'd give it a chance. It sounds reasonable...

3 Likes

You still have not provided your inxi -Faz terminal output. As it is Christmas today I will gift you one more opportunity to post this information before your post is locked/trash binned. If your next post does not contain the required inxi -Faz terminal output your help request will be locked for failing to meet our forum's expectations.

Best of the season to you.

Edit:

You will need to familiarize yourself with the usage of Pacman if you intend to use an Arch Linux based distro. If you would rather not learn how pacman actually works, then perhaps a distro that does not use pacman would be more attuned to your needs.

Here are some links to the Arch Wiki with information on pacman usage so that you may research options available to you.

https://wiki.archlinux.org/title/pacman

https://wiki.archlinux.org/title/Pacman/Tips_and_tricks

Search for references to the following errors:

More specifically, search for information on usage of the pacman --overwrite switch to eliminate the error pertaining to installation of the kwidgetsaddons package. Use caution when attempting to use the --overwrite option, and always take a system snapshot before testing out new fixes.

Good luck.

5 Likes

Ξ» inxi -Faz
System:
Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6e6c0e77-d5ce-44d6-a079-53e5b8b7d0d3 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Vmware System: VMware product: VMware Virtual Platform v: N/A
serial: Chassis: No Enclosure type: 1
serial:
Mobo: Intel model: 440BX Desktop Reference Platform
serial: BIOS: Phoenix v: 6.00 date: 11/12/2020
CPU:
Info: model: AMD Ryzen 5 2600X bits: 64 type: SMP arch: Zen+
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 2x cores: 1 smt: cache:
L1: 2x 96 KiB (192 KiB) desc: d-1x32 KiB; i-1x64 KiB
L2: 2x 512 KiB (1024 KiB) desc: 1x512 KiB L3: 2x 8 MiB (16 MiB)
desc: 1x8 MiB
Speed (MHz): avg: 3593 min/max: N/A cores: 1: 3593 2: 3593
bogomips: 14372
Flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.19.0.0 bus-ID: 00:0f.0
chip-ID: 15ad:0405 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: gnome-shell driver:
loaded: vmware unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1718x920 s-dpi: 96 s-size: 455x243mm (17.9x9.6")
s-diag: 516mm (20.3")
Monitor-1: Virtual1 res: 1718x920 hz: 60
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 driver: snd_ens1371
v: kernel bus-ID: 02:02.0 chip-ID: 1274:1371 class-ID: 0401
Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine
type: network bridge driver: N/A modules: i2c_piix4 port: N/A
bus-ID: 00:07.3 chip-ID: 8086:7113 class-ID: 0680
Device-2: Intel 82545EM Gigabit Ethernet
vendor: VMware PRO/1000 MT Single Port driver: e1000 v: kernel port: 2000
bus-ID: 02:01.0 chip-ID: 8086:100f class-ID: 0200
IF: ens33 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 64 GiB used: 12.12 GiB (18.9%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: VMware model: Virtual S size: 64 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: N/A rev: 1.0
scheme: MBR
Partition:
ID-1: / raw-size: 63.99 GiB size: 63.99 GiB (100.00%)
used: 12.12 GiB (18.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 63.99 GiB size: 63.99 GiB (100.00%)
used: 12.12 GiB (18.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 63.99 GiB size: 63.99 GiB (100.00%)
used: 12.12 GiB (18.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 63.99 GiB size: 63.99 GiB (100.00%)
used: 12.12 GiB (18.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.73 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 235 Uptime: 1m wakeups: 3 Memory: 7.73 GiB
used: 1.37 GiB (17.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 Packages: pacman: 1078 lib: 287 Shell: fish v: 3.3.1
default: Bash v: 5.1.12 running-in: gnome-terminal inxi: 3.3.11

here ya go.

i am still waiting on a response. i have tried reloading the keys and all that. still cannot upgrade the system with the terminal. fails with this
--> hecking for keyring update before starting full system update..
warning: garuda-hotfixes-1.0.4-1 is up to date -- skipping
warning: archlinux-keyring-20211028-1 is up to date -- skipping
warning: chaotic-keyring-20210617-2 is up to date -- skipping
there is nothing to do
:: Starting full system upgrade...
warning: garuda-settings-manager-git: local (1.0.0.r1.g15c4106-3) is newer than chaotic-aur (1.0.0.r1.g15c4106-1)
resolving dependencies...
looking for conflicting packages...
error: could not open file /var/lib/pacman/local/kwidgetsaddons-5.88.0-3/files: No such file or directory
warning: could not fully load metadata for package kwidgetsaddons-5.88.0-3
error: failed to prepare transaction (invalid or corrupted package)

i do not know what command s to use to fix it. i use the gui interface to work around it, but i would rather use terminal...

You were provided with plenty of good reading material. It’s not fair to expect people to give you all of the exact answers, but rather you should learn the answers from reading detailed explanations and documentation that has been given to you, because that way you will understand what the commands you are typing actually do and why. This is free software, not paid support. Regardless, try this.

sudo pacman -S --overwrite kwidgetsaddons

3 Likes

No, we are waiting for a feedback on several suggestions:

3 Likes