Update Issues

Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ba2fb729-b4b9-49f0-8223-47f0378d19c9 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Type: Laptop System: ASUSTeK product: ROG Strix G513QM_G513QM v: 1.0
serial: <filter>
Mobo: ASUSTeK model: G513QM v: 1.0 serial: <filter>
UEFI: American Megatrends LLC. v: G513QM.314 date: 09/03/2021
ID-1: BAT0 charge: 81.7 Wh (100.0%) condition: 81.7/90.0 Wh (90.8%)
volts: 16.1 min: 15.9 model: AS3GWAF3KC GA50358 type: Li-ion
serial: <filter> status: Discharging
Info: model: AMD Ryzen 9 5900HX with Radeon Graphics socket: FP6 bits: 64
type: MT MCP arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000B
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3300 min/max: 1200/4889 boost: enabled
base/boost: 3300/4650 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3300 2: 3300 3: 3300 4: 3300
5: 3300 6: 3300 7: 3300 8: 3300 9: 3300 10: 3300 11: 3300 12: 3300
13: 3300 14: 3300 15: 3300 16: 3300 bogomips: 105400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
chip-ID: 10de:2520 class-ID: 0300
Device-2: AMD Cezanne vendor: ASUSTeK driver: amdgpu v: kernel
bus-ID: 06:00.0 chip-ID: 1002:1638 class-ID: 0300
Display: server: X.Org compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 142
size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.2-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.4 direct render: Yes
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 06:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.43 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: MEDIATEK vendor: AzureWave driver: mt7921e v: kernel port: N/A
bus-ID: 03:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 3-4:2 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 1.4 TiB used: 259.58 GiB (18.1%)
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: SK Hynix model: HFM001TD3JX013N
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41000C20
temp: 25.9 C scheme: GPT
SMART: yes health: PASSED on: 91d 21h cycles: 4,180
read-units: 7,387,018 [3.78 TB] written-units: 9,316,303 [4.76 TB]
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Intel model: SSDPEKKW512G8
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
temp: 32.9 C scheme: GPT
SMART: yes health: PASSED on: 1y 185d 5h cycles: 5,955
read-units: 60,609,247 [31.0 TB] written-units: 60,188,852 [30.8 TB]
ID-1: / raw-size: 476.94 GiB size: 476.94 GiB (100.00%)
used: 259.56 GiB (54.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p1
maj-min: 259:1
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.5 MiB (26.6%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:3
ID-3: /home raw-size: 476.94 GiB size: 476.94 GiB (100.00%)
used: 259.56 GiB (54.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p1
maj-min: 259:1
ID-4: /var/log raw-size: 476.94 GiB size: 476.94 GiB (100.00%)
used: 259.56 GiB (54.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p1
maj-min: 259:1
ID-5: /var/tmp raw-size: 476.94 GiB size: 476.94 GiB (100.00%)
used: 259.56 GiB (54.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme1n1p1
maj-min: 259:1
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.12 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 39.0 C mobo: N/A gpu: amdgpu temp: 32.0 C
Fan Speeds (RPM): cpu: 0
Processes: 417 Uptime: 5m wakeups: 4 Memory: 15.12 GiB
used: 4.65 GiB (30.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1868 lib: 551
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
System install date:     2022-01-27
Last full system update: 2022-01-26
Is partially upgraded:   No
Using TLP:               No
Windows dual boot:       Yes

Report everything you have already attempted to solve your problem.

When I attempt to run garuda-update it seems to complete but fine but after shutting down and rebooting my system comes up practically unusable. ksoftirqd will be using 100% of CPU and all networking access is lost and I'm unable to modprobe due to the teh IOwait from ksoftirqd
[ 492.585926] INFO: task modprobe:8252 blocked for more than 368 seconds.
Rolling back a snapshot resolves this no problem, and I've attempted the update 3 times now to make sure nothing else was going on, all with the same result.

That sounds like it may be a common problem and possibly a common solution. You sound like an experienced user, so you know the drill. Where in your journal output did it choke, can you pinpoint it, and are there existing bugs reports?

Did you scour this forum & wiki, the Arch forum, the Arch Wiki, and Google? What were the results?

You run an nVidia chipset. Always problematic. If I still ran one--and there are good reasons not to--I might start there. But then again, that may be totally off base.

P.S Thanks for reading instructions and posting the inxi output.


umbrachimera: Has something been changed since last night? That was when the update kept breaking my system.

Me: i saw your post on the forum, I'll try updating myself
garuda doesn't really have control over the update cycle of arch, so this is kinda out of my control
ksoftirqd sounds like a kernel process, have you tried linux-lts?

Adding the telegram conversation here

1 Like

Thanks for linking in. No, I've not tried another kernel yet. But I can try that here in a bit after another update trial time.

I didn't think to check journal last night night, I just did dmesg to see what was holding up the other processes.

I did my normal google around to see if I can any major bug post. I searched this forum and arch forum; not the wiki's as I didn't think sudden bugs would be in wiki over forum. My last update was only 3-4 days ago.

I don't think nvidida was updated in the last list of things I was updating, I can check again in a bit. It doesn't seem like an nvidia breakage because the gpu seemed to be functioning normal after the boot it's just everything is at a crawl and no networking.

Hey, thanks for the reply. It is very nice that you explained what you have resourced. It tends to cut down on troubleshooting questions from those that would help. :slight_smile:

I don't know enough about nVidia hybrid drivers to even know if you have them. I'm no help there. But I read all forum posts and did just note another new problem post involving them and a solution may have been provided by @jonathon...I think.

1 Like

Alright small update, it looks to be something with the kernel. I booted into 5.16.2-prexan0-rog-1 kernel and it seems like that unbotched the system. I was looking for easy way to rollback from latest kernel but I don't see a way to do that built in; I've not done kernel rollbacks in a hot minute.

Ah, but it looks like Nvidia and VirtualBox both don't play nice with this kernel.

Is there a flag I can put on garuda-update or yay -Syu to make it not update kernel?

Your normal /etc/pacman.conf file contains a commented out IgnorePkg line.
Add your kernel to IgnorePkg like so:

IgnorePkg = linux-zen linux-zen-headers

Don't forget about this, tho. You should remove it at a future date when the kernel is back to being stable for you.


Updating with this blacklisted didn't break system!


Linux lessons delivered for free...by @TNE! :smiley:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.