Update issue: "nodejs-lts-gallium and nodejs are in conflict"

hi all!

latest update gives:

:: Starting full system upgrade...
warning: garuda-settings-manager-git: local (1.0.0.r1.g15c4106-3) is newer than chaotic-aur (1.0.0.r1.g15c4106-1)
warning: zsh-theme-powerlevel10k-git: local (r4021.65599411-1) is newer than chaotic-aur (r4021.6559941-1)
resolving dependencies...
looking for conflicting packages...
:: nodejs-lts-gallium and nodejs are in conflict. Remove nodejs? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nodejs-lts-gallium and nodejs are in conflict

and a bit of research suggests saying yes is dangerous, anyone tried this? and if so, how did it work out?

<< q

Link, please?

2 Likes

I am also curious to learn more about the research you mentioned.

If you do not have a compelling reason for wanting to keep nodejs, my instinct would be to trust the replacement that your upgrade is suggesting. If you experience an issue you can always roll back to the pre-upgrade snapshot and reassess.

5 Likes

This is what I did. I opted to remove nodejs, as suggested. No issues here so far.

I ran garuda-update again and didn't see any further issues with updates.

1 Like

Maybe czrpb is thinking about the recent node-ipc err... issue? I could certainly understand being nervous about java script related packages after what happened with that...

hi!

well, my 1st worry was that it was defaulting to N: y/N

and i believe this the link where things seemed less than 100%:

all that, ill give it a shot now!

thx!

done a couple of days back .. nothing negative so far.

thx everyone!

1 Like

Hello,

Glad your issue is resolved!

Please flag/mark the appropriate post/reply as Solved

Peace :v:

1 Like

Marking as solved is important.
Anyway, in my opinion, the initial suggestion (to accept replacement) was here:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.