Update has killed my system

Now I'm really alarmed!
I updated my system, now have 5.1.5.86-1-lts.
On restart I get the conky window and the welcome screen. And Stacer, where I got the information about the current kernel.
But when I am finished with that, all I have on the black screen is conky, and the Plank panel which I had before.
All the setups I did, with panels, activities etc have disappeared.
In the applications menu in the plank (at least I have that!) I can go to Settings and then System settings. Here, when I check the desktop settings, the menu item for activities has disappeared. Only virtual desktops. How that?
Does this version not support the activities anymore? That was my main reason to switch to KDE and made me come to Garuda! I put about 10 hours of work into setting them up!
Plus, there are no panels at all. And right click on the desktop to set something up has no effect at all.
What can I do to get my setup back? Different kernel?
Yes, I know, again no inxi output. But I am stuck with a barely working system, I don't know how to get that.
One more info: When I start the system, after the Grub the screen goes black and for quite some time I see in the right upper corener 'KDF function not implemented '?

Could it be that Plasma has stopped wotking?
When I type plasmashell -version in the Konsole I get unknown option. When I type killall plasmashell the response is 'no process found'.

Have you tried restoring the latest working snapshot?
From konsole you could provide your garuda-inxi, if you can start a browser with krunner, or using
garuda-inxi | tb
From your previous topics it looks like you customized your system quite a bit, but never in 9 topics provided your garuda-inxi :wink:

4 Likes

You are right. I'm still at odds with inxi. Just don't know how to use it.
I do have the konsole in my plank, so that's what I can use...
I tried going back to earlier versions in Grub, but that doesn't make a difference.

Here is the "Inxi" now

System:
  Kernel: 6.1.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 parameters: BOOT_IMAGE=/vmlinuz-linux-zen
    root=UUID=989f2a45-81a4-4b15-b3aa-69e6d95fe452 rw
    [email protected] quiet quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: plank
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: P8H67-M PRO v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 3904
    date: 04/27/2013
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270
    serial: <filter> charge: 100% (should be ignored)
    rechargeable: yes status: discharging
CPU:
  Info: model: Intel Core i7-3770K bits: 64 type: MT MCP
    arch: Ivy Bridge gen: core 3 level: v2 built: 2012-15
    process: Intel 22nm family: 6 model-id: 0x3A (58) stepping: 9
    microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled
    cache: L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB
    desc: 4x256 KiB L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3294 high: 3900 min/max: 1600/3900 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 3900
    2: 3900 3: 1648 4: 3900 5: 3563 6: 3900 7: 3900 8: 1648
    bogomips: 57684
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel IvyBridge GT2 [HD Graphics 4000] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-7 process: Intel 22nm
    built: 2012-13 ports: active: HDMI-A-2 empty: DP-1, DP-2,
    HDMI-A-1, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0162
    class-ID: 0300
  Device-2: Generalplus 808 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 2-1.3:7
    chip-ID: 1b3f:2002 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
    s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-2 mapped: HDMI-2 model: BenQ GW2780
    serial: <filter> built: 2017 res: 1920x1080 hz: 60 dpi: 82
    gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: OpenGL v: 4.2 Mesa 22.3.2 renderer: Mesa Intel HD
    Graphics 4000 (IVB GT2) direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition
    Audio vendor: ASUSTeK P8H67 driver: snd_hda_intel
    bus-ID: 2-1.3:7 v: kernel chip-ID: 1b3f:2002 bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0102 class-ID: 0403
    serial: <filter>
  Device-2: Generalplus 808 Camera type: USB
    driver: snd-usb-audio,uvcvideo
  Device-3: Creative USB Sound Blaster HD type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1.4:5
    chip-ID: 041e:30d7 class-ID: 0300 serial: <filter>
  Sound API: ALSA v: k6.1.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8P67 and other motherboards driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full
    mac: <filter>
  Device-2: TP-Link TL-WN823N v2/v3 [Realtek RTL8192EU]
    type: USB driver: rtl8xxxu bus-ID: 3-1.3:4 chip-ID: 2357:0109
    class-ID: 0000 serial: <filter>
  IF: wlp1s0u1u3 state: down mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode)
    type: USB driver: btusb v: 0.8 bus-ID: 7-1:2 chip-ID: 0a12:0001
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
  Device-2: Integrated System Solution Bluetooth Device
    type: USB driver: btusb v: 0.8 bus-ID: 7-2:3 chip-ID: 1131:1004
    class-ID: fe01
  Report: ID: hci1 rfk-id: 1 state: up address: N/A
Drives:
  Local Storage: total: 5.46 TiB used: 3.67 TiB (67.2%)
  SMART Message: Unable to run smartctl. Root privileges
    required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung
    model: SSD 870 QVO 2TB size: 1.82 TiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 2B6Q scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD20EZBX-00AYRA0 size: 1.82 TiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: 1A01 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate
    model: ST1000DX002-2DV162 size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: CC41 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate
    model: ST31000528AS size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
    serial: <filter> rev: CC49 scheme: MBR
Partition:
  ID-1: / raw-size: 254.39 GiB size: 254.39 GiB (100.00%)
    used: 11.13 GiB (4.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot raw-size: 19.53 GiB size: 19.53 GiB (100.00%)
    used: 266.2 MiB (1.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.53 TiB size: 1.5 TiB (98.36%)
    used: 1.24 TiB (82.6%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 254.39 GiB size: 254.39 GiB (100.00%)
    used: 11.13 GiB (4.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 254.39 GiB size: 254.39 GiB (100.00%)
    used: 11.13 GiB (4.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60)
    cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.4 GiB used: 0 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 261 Uptime: 27m wakeups: 6 Memory: 11.4 GiB
  used: 2.2 GiB (19.3%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages:
  pm: pacman pkgs: 1677 libs: 450 tools: octopi,pamac,paru
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.13-1):
  System install date:     2023-01-03
  Last full system update: 2023-01-03
  Is partially upgraded:   No
  Relevant software:       timeshift(custom) NetworkManager mkinitcpio
  Windows dual boot:       <superuser required>
  Failed units:

garuda-inxi | tb gives me command not found

I don't think it's the kernel though, more likely something messed up in $HOME.
Can you make a new user and log into that to see if the system works normally?
If the GUI tools are inoperable, press Ctrl-Alt-F2, type username then password, sudo useradd whatever ("whatever" is the new user name), passwords, reboot, log into that.

Does garuda-inxi |nc termbin.com 9999 work?
If it does, post the URL that is printed when it's done.
(edit: for the next time, in case you restore some snapshot or upgrade again.)

P.S. don't fret, your system isn't killed, just a little discombobulated.

2 Likes

You can try launching GUI tools with krunner (alt+space).
I agree that it should be a matter of something messed up in home.
When you manage to get it fixed, you could give a try to a tool like the "plasma customization saver" (plasmaconfigsaver) widget.
I used it in the past and it was very useful, although now I've read some complains on the latest KDE releases. I'm sure there are alternatives though.

1 Like

I can start krunner, but all I get is the little search window at the top?

Can't you type there e.g. System Settings and see it in the list and launch it?

The termbin worked.
Setting up a new user didn't work. I don't get to logging in for that user.
May I repeat: Problem one: No way to configure the desktop with widgets etc.
Problèm two: No activities can be configured.
And of course, as there is no side panel, there is also no activity switcher to try and find them.

Maybe try with

sudo useradd -m <username>

to create also the home directory?
If it doesn't work:

2 Likes

Uh yes, useradd -m, my bad. It's not default. No wonder it did not work duh.

Well.... as I mentioned, I don't have any snapshots in Grub. I am using Timeshift, maybe that's why. The last snapshot in Timeshift was done before my configuring work, so it's kind of last resort.
The additional user with separate $Home has worked, but the password I gave him didn't.
I noticed that my Dolphin had disappeared..... possibly because I uninstalled poppler. At least when I reinstalled it, I had to uninstall poppler-git first to solve the conflicts.
Btw, I also logged into then'root' user. That worked, but no usable GUi at all.
Is there a way to reinstall Plasma?
Is it an option to use 'reinstall all packages ' in the Garuda Assistant?

One more puzzle: When I look at my Grub, i seem to have unknowingly been using two kernels: -zen and -lts. Does that make sense? Isn't one enough?

Hm.... Timeshift is available in the app list, but does not start.....

We replaced timeshift with snapper long ago. At that time, we shipped it with timeshift-autosnap and additional configurations to have the snapshots in the grub.
If you decided to change that too you should have made sure to configure it properly.
Your configuration should be in the home directory, which is normally not covered by snapshots, so you should be fine in that regard if you manage to restore.
No problem to have more than one kernel.

1 Like

Ok, so much for hope.
I used Tiimeshift for ages, also because I could add associated storages. So if all else fails, I will have to start from live usb to run timeshift from there ....
But is there no way to get plasma updated without going the long way?

Well, I understand that. It seems there is no config file for the plasma desktop anymore. That would be where the description of widgets etc should be, and also the existing activities.
The whole thing is very strange, I know for sure I didn't apply any changes in $Home.
Well, I do know that one Timeshift backup worked which I did shortly after installation. As I cannot get it to work again, all I can do is try from the live usb image. If that doesn't work under Garuda, I will have to use some other distro's live image.
The most frustrating thing is that there is no explanation why this has happened.

I highly doubt that it would be anything specifically traceable back to Garuda. Why KDE lost its config files I don't know, and I doubt anyone but maybe some of the most enthused KDE developers knows either. The pacman package manager does not touch your home folder. The only thing I could imagine is config file corruption from loading a very old snapshot with incompatible KDE options, but that is a problem between the chair and the screen in almost all cases.

3 Likes