Update fails, probably too little RAM

OK guys and gals Ive just done a fresh install on my dads PC and went to do updates with yay and dohhh it dosn't work .can someone please explain .

Use last snapshot. Use forum search function first.

Do you still think we're psychic?

Doesn't work, it's definitely not the error message in the terminal.

Read

please
and post

inxi -Fxxxza

as text!

Even if you personally think it is unnecessary.

Please search any errors you receive in the terminal before opening a help request.

However, if you do need to open a help thread, then be sure to always post the error messages you receive as text only in your opening post.

C'mon Rob, you've been a forum member for 4 months now. You've come a very long ways in your Linux journey, but we still shouldn't need to be repeating this stuff to you at this point.

You've made great strides though, so congrats on that.

3 Likes

I mean. 

1 Like

Thanks and all was great until i went to update with yay has the cmd changed ?

paru is the new yay, but why you do not post the error message?

2 Likes

Apologies team i just thought it was an easy question ill post with inxi

OMG thankyou and i can not post the error message as the pc im talking about is 20 km away thanks for your help

Sorry to bother everyone with such a petty question .Many thanks to those who helped .

Cheers Rob

It's difficult enough for us to troubleshoot a remote PC that has someone in front of it. It's very, very difficult to troubleshoot a remote PC that's 20km away from the other person. :stuck_out_tongue_winking_eye:

Although, for the future, you could look into some sort of remote access software, e.g. SSH or a remote desktop.

4 Likes

@mcdragon

4 Likes

Yes and thanks mate i realize that .I just assumed it would be an easy cmd.i will be getting the pc today then ill post the inxi.Oh by the way paru dosnt work .why cant the developers keep it the same.its like you have to constantly be researching this distro to keep up to date .
Asi i said i downloaded the latest iso and now cant update with yay.

Oh ok then thanks for the update i got dad to type paru and he gets a message unrecognized.ill post inxi today thanks.

Have you installed yay?

2 Likes

hmm no i havnt i just assumed it would be on the updated iso Tnanks for your help .


.%;888:8898898:              robdick@robdick-herobook
x;XxXB%89b8:b8%b88:            ------------------------
.8Xxd                8X:.         OS: Garuda Linux x86_64
.8Xx;                    8x:.       Kernel: 5.11.16-zen1-1-zen
.tt8x          .d            x88;     Uptime: 7 mins
.@8x8;          .db:              xx@;    
,tSXX°          .bbbbbbbbbbbbbbbbbbbB8x@;  Packages: 1664 (pacman)
.SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;  Shell: zsh
,888S                                     pd!  Resolution: 1920x1080
8X88/                                       q   Terminal: konsole
GBB.                                             
x%88        d888@8@X@X@X88X@@XX@@X@8@X.        CPU: Intel Atom x5-E8000 (4) @ 2.0GHz
dxXd    dB8b8b8B8B08bB88b998888b88x.         Memory: 1389MiB / 3772MiB (36%)
dxx8o                      .@@;.             
dx88                   .t@x.                                       
d:SS@8ba89aa67a853Sxxad.                                         
.d988999889889899dd.                   

[WARN] - (starship::configs::starship_root): Unknown config key 'docker'
[WARN] - (starship::configs::starship_root): Did you mean 'docker_context'?
[WARN] - (starship::configs::starship_root): Unknown config key 'haskell'
[WARN] - (starship::configs::starship_root): Did you mean 'shell'?
[WARN] - (starship::configs::starship_root): Unknown config key 'docker'
[WARN] - (starship::configs::starship_root): Did you mean 'docker_context'?
[WARN] - (starship::configs::starship_root): Unknown config key 'haskell'
[WARN] - (starship::configs::starship_root): Did you mean 'shell'?
[WARN] - (starship::configs::starship_root): Unknown config key 'docker'
[WARN] - (starship::configs::starship_root): Did you mean 'docker_context'?
[WARN] - (starship::configs::starship_root): Unknown config key 'haskell'
[WARN] - (starship::configs::starship_root): Did you mean 'shell'?
[WARN] - (starship::configs::character): Unknown config key 'use_symbol_for_status'

╭─robdick@robdick in ~  
╰─λ inxi
CPU: Quad Core Intel Atom x5-E8000 (-MCP-) speed/min/max: 1852/480/2000 MHz  
Kernel: 5.11.16-zen1-1-zen x86_64 Up: 13m Mem: 2380.7/3772.3 MiB (63.1%) Storage: 57.62 GiB (42.8% used)  
Procs: 219 Shell: fish inxi: 3.3.04  

╭─robdick@robdick in ~ took 1s
╰─λ inxi fxxxza
Error 22: Unsupported option: fxxxza
Check -h for correct parameters.

╭─robdick@robdick in ~ took 775ms
[] × inxi -Fxxxza
System:    Kernel: 5.11.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=3d83b1b7-6d71-4015-b66d-cd7d5f07e4c0  
rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: CHUWI product: HeroBook v: N/A serial: <filter>  
Mobo: N/A model: N/A v: Type2 - Board Version serial: <filter> UEFI: INSYDE v: E115C.CHUWI.E002  
date: 01/19/2019  
Battery:   ID-1: BAT1 charge: 40.5 Wh (100.0%) condition: 40.5/40.5 Wh (100.0%) volts: 8.4 min: 8.8  
model: LG Harris Beach type: Li-ion serial: <filter> status: Full cycles: 46  
CPU:       Info: Quad Core model: Intel Atom x5-E8000 bits: 64 type: MCP arch: Airmont family: 6  
model-id: 4C (76) stepping: 4 microcode: 411 cache: L2: 1024 KiB  
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8320  
Speed: 1934 MHz min/max: 480/2000 MHz Core speeds (MHz): 1: 1934 2: 1869 3: 1954 4: 1894  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds mitigation: Clear CPU buffers; SMT disabled  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass status: Not affected  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics  
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:22b1 class-ID: 0300  
Device-2: Realtek USB Camera type: USB driver: uvcvideo bus-ID: 1-1:2 chip-ID: 0bda:5806  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") diag: 354mm (13.9")  
OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (BSW) v: 4.6 Mesa 21.0.3 compat-v: 3.0  
direct render: Yes  
Audio:     Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio dr
iver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:2284 class-ID: 0403                                
Sound Server-1: ALSA v: k5.11.16-zen1-1-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: yes  
Sound Server-4: PipeWire v: 0.3.26 running: yes  
Network:   Message: No device data found.  
IF-ID-1: wlp0s20u5i2 state: up mac: <filter>  
Bluetooth: Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB driver: btusb,rtl8xxxu  
bus-ID: 1-5:5 chip-ID: 0bda:b720 class-ID: e001 serial: <filter>  
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:    Local Storage: total: 57.62 GiB used: 24.68 GiB (42.8%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: ISOCOM size: 57.62 GiB block-size: physical: 512 B
logical: 512 B rotation: SSD serial: <filter> rev: 0x8 scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
Partition: ID-1: / raw-size: 57.36 GiB size: 57.36 GiB (100.00%) used: 24.68 GiB (43.0%) fs: btrfs
dev: /dev/mmcblk0p2 maj-min: 179:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 546 KiB (0.2%) fs: vfat
dev: /dev/mmcblk0p1 maj-min: 179:1
ID-3: /home raw-size: 57.36 GiB size: 57.36 GiB (100.00%) used: 24.68 GiB (43.0%) fs: btrfs
dev: /dev/mmcblk0p2 maj-min: 179:2
ID-4: /var/log raw-size: 57.36 GiB size: 57.36 GiB (100.00%) used: 24.68 GiB (43.0%) fs: btrfs
dev: /dev/mmcblk0p2 maj-min: 179:2
ID-5: /var/tmp raw-size: 57.36 GiB size: 57.36 GiB (100.00%) used: 24.68 GiB (43.0%) fs: btrfs
dev: /dev/mmcblk0p2 maj-min: 179:2
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 943.1 MiB used: 512 KiB (0.1%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 943.1 MiB used: 512 KiB (0.1%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 943.1 MiB used: 512 KiB (0.1%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 943.1 MiB used: 512 KiB (0.1%) priority: 32767 dev: /dev/zram3
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 220 Uptime: 14m wakeups: 1 Memory: 3.68 GiB used: 2.38 GiB (64.7%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1664 lib: 530
Shell: fish v: 3.2.1 default: Zsh v: 5.8 running-in: konsole inxi: 3.3.04

╭─robdick@robdick in ~ took 5s
╰─λ```

Search the forum. This isn't new.

2 Likes

oh ok thanks i must be searching the wrong topics.searching for updates must not be the topic
Cool found the solution thanks everyone .help vamp out lol

sudoo - pacman -sextra / kwin

Actually, topic search is not up to date in most recent iso, you might want to try paru -S updated-topics yay-or-nay next time you are logged in and don't forget to update the keyring with pamac.

1 Like

i tried paru it dosnt work yay works now,Key ring huh need to research that one thanks.