Update breaks LightDM

So my Garuda system is broken by something in the last few days. It won't start LightDM. I can still use the TTY and start X from there, whereupon everything works just fine. But I don't know how to fix the main issue. I tried using systemctl to disable LightDM, but that did not work either. I don't mind logging in through the console, I just don't want to have to switch to a different TTY every time I boot up. Can someone help me to either fix LightDM or disable it completely?

6 Likes

That fixed it! I could kiss you. Thank you so much. But I do have to ask, why was that an issue? How was optimus-manager related to my LightDM setup?

1 Like

BTW :wink:

:slight_smile:

3 Likes

optimus-manager uses Python, and Python was updated from 3.8 to 3.9 recently. Big updates to interpreted programming languages normally mean software using that language need to be rebuilt.

If optimus-manager doesn't load then it will prevent anything it affects from loading - in this case it's not specifically LightDM but your graphical interface.

5 Likes

Ah, that makes sense. Thanks for the insight. I really appreciate it. I learned something today.

Thank you. I feel welcome already.

3 Likes