Unresolvable Package Conflicts Detected?

This morning I went to do updates to my box (sudo pacman -Syu) just to get off a fresh start to the day. When I came across:

╭─[email protected] in ~
╰─λ sudo pacman -Syu
[sudo] password for joshua:
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: poppler-git and poppler are in conflict. Remove poppler? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing poppler breaks dependency 'poppler=21.07.0' required by poppler-qt5

Can we see the output of:

pacman -Qs poppler
pactree -r poppler

See below post.

3 Likes

I did not receive this error at update?


pacman -Qs poppler
local/poppler 21.07.0-3
    PDF rendering library based on xpdf 3.0
local/poppler-data 0.4.10-1
    Encoding data for the poppler PDF rendering library
local/poppler-glib 21.07.0-3
    Poppler glib bindings
local/poppler-qt5 21.07.0-3
    Poppler Qt5 bindings

On second review, that it a pretty strange error. I wonder if you tried to update against a partially updated mirror.

I would just try updating again. If you get the same error, try resorting your mirrors.

1 Like

Why is poppler-git installed? If you removed poppler-git, would that not solve the problem?

Thanks for the clarification dalto!

It isn't. It is trying to install it.

1 Like

Yes, but the question is why?

Would adding poppler-git to ignore pkg line, at least temporarily, allow the update to proceed?

1 Like

Thanks for all the responses, I meant to add more to the thread after I accidently posted, then saw a post from a team member to read the FAQ, then saw the thread deleted, I read the FAQ couldn't find anything about this, then saw the thread was back haha. I'm so confused! :rofl:

Anyways, I tried to install poppler-git with pacman and wasn't able to do so. I then tried to remove poppler but too much is dependant on it to remove so that didn't work either. So tried to update poppler itself and it wouldn't because it's conflicting with poppler-git which I don't understand because it's not installed.

Not sure what to do next.

It seems it already happened in the past here, although it is not clear to me if and how it was solved

Could pactree be used to find the dependency call for poppler-git?

pactree -r poppler-git

pactree is part of pacman-contrib, so that would need to be installed to use pactree.

One reason could be that since poppler-qt requires a certain version and, potentially, his repo doesn't have that version it is asking to install poppler-git.

Did you try updating your mirrorlist as recommended above?

I don't think so, because it isn't installed. Also, it provides poppler so I don't think the output would be terrible illuminating.

2 Likes

Thanks, learned something new every day. :slight_smile:

I guess the easiest method to resolve this might be to try rolling your system back to a point before you attempted to install poppler-git.

However easy that may be (if it works), it doesn't teach you anything about package conflict resolution.

1 Like

Another would be to remove poppler-qt5, let it install poppler-git and then fix it afterwards. After the fact it should be easier to find what is demanding poppler-git.

1 Like

You might have missed this part^^^

I researched what poppler-qt5 is and even tried to remove it as well, but once again it yells at me that there are too many dependants...

I'm working on my mirror list atm in between work issues to see if that could be a fix.

But, yeah I want to understand this situation so I know more about the system, how things work, and know how to take care of other similar issues I might run into in the future.

1 Like

Missed what part? Something is trying to install poppler-git. However, that would require removing poppler which it can't do because poppler-qt5 requires a certain version. So removing poppler-qt5 would be one suggestion.

Can we see pactree -r poppler-qt5

Now things are just getting confusing.

Which came first, the chicken or the egg? :smiley:

1 Like

Now I'm really confused... I opened up my mirrorlist but didn't change anything at all yet. Decided to do a pacman -Syu for I don't know... The 10th time, and it worked... No longer barking about any poppler-git/poppler conflictions...

Maybe there was a mirror that was having issues like was suggested?? I dunno... But I wish I understood it better before it decided to fix itself...