Unable to transfer data with android

Hello,
guys i wanted to transfer some files from my mobile to laptop but when i connect it, it gets detected but i cannot view any files and dolphin gives this error

No storage media found. Make sure your device is unlocked and has MTP enabled in its USB connection settings.

I have already enabled USB debugging and selected both file transfer (which gave the above error)
and image transfer which gave

The file or folder udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb1/1-2 does not exist.

I also tried with other device with same result.
I also tried using mtpfs which gave this output

╰─λ mtpfs
Listing raw device(s)
Device 0 (VID=04e8 and PID=6860) is a Samsung Galaxy models (MTP).
Found 1 device(s):
Samsung: Galaxy models (MTP) (04e8:6860) @ bus 1, dev 8
Attempting to connect device
libusb_claim_interface() reports device is busy, likely in use by GVFS or KDE MTP device handling alreadyLIBMT
P PANIC: Unable to initialize device
Unable to open raw device 0

Here is my inxifaz

[] × inxi -Faz
System:    Kernel: 5.13.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=99c4694c-a63d-4e07-8562-56bdc42b086b  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: LENOVO product: 80U0 v: Lenovo Yoga710-15ISK serial: <filter> Chassis:  
type: 10 v: Lenovo Yoga710-15ISK serial: <filter>  
Mobo: LENOVO model: Lenovo Yoga710-1 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO  
v: 0GCN24WW(V1.08) date: 06/22/2018  
CPU:       Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake family: 6  
model-id: 4E (78) stepping: 3 microcode: EA cache: L2: 3 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200  
Speed: 2720 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 2720 2: 2790 3: 2757 4: 2756  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel  
bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300  
Device-2: Realtek EasyCamera type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:57f8  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")  
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.2.0 direct render: Yes  
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel  
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.10-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.33 running: yes  
Network:   Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel port: 4040 bus-ID: 01:00.0  
chip-ID: 8086:24f3 class-ID: 0280  
IF: wlp1s0 state: up mac: <filter>  
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:4
chip-ID: 8087:0a2b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 62.6 GiB (26.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SK Hynix model: HFS256G39MND-3310A size: 238.47 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2P00
scheme: GPT
Partition: ID-1: / raw-size: 90 GiB size: 90 GiB (100.00%) used: 46.21 GiB (51.3%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 130.5 MiB (51.0%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 90 GiB size: 90 GiB (100.00%) used: 46.21 GiB (51.3%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 90 GiB size: 90 GiB (100.00%) used: 46.21 GiB (51.3%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 90 GiB size: 90 GiB (100.00%) used: 46.21 GiB (51.3%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.62 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 247 Uptime: 13m wakeups: 1 Memory: 7.62 GiB used: 2.73 GiB (35.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1436 lib: 412
flatpak: 0 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

First update your system.
Second, KDE Dolphin bug? No, work fine here.

3 Likes

it worked after system update. But it wasnt working 10-15days ago also when my system was uptodate

Kde had major update recently, including dolphin. This might have fixed the issue.

For more info, search for KDE Gear.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.