Unable to login to my account after garuda-update

Hello there. As the title says, I upgraded my system using garuda-update and now I can't login to my account or to the root account. I can only login to the guest account using the same password. I don't think its the password, coz, if I gave wrong creds, it shows me wrong password error, but if I try the correct password, it goes dark as if it is going to login and goes back to the login screen and ask for password again. Same goes using tty.

Here is my garuda-inxi command output

System:
Kernel: 5.19.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6cf89fd0-e2b7-421e-916e-0a1a4089fe17 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Inspiron 5559 v: N/A
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 062HKX v: A00 serial: <superuser required>
UEFI-[Legacy]: Dell v: 1.1.6 date: 01/12/2016
Battery:
ID-1: BAT0 charge: 1.5 Wh (100.0%) condition: 1.5/41.4 Wh (3.6%)
volts: 16.5 min: 14.8 model: LGC-LGC2.80 DELL 991XP69 type: Li-poly
serial: <filter> status: not charging
CPU:
Info: model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake
gen: core 6 built: 2015 process: Intel 14nm family: 6 model-id: 0x4E (78)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2724 high: 3099 min/max: 400/3100 scaling:
driver: intel_pstate governor: powersave cores: 1: 2600 2: 2600 3: 3099
4: 2600 bogomips: 20799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915
v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1916
class-ID: 0300
Device-2: Intel RealSense 3D Camera (Front F200) type: USB
driver: uvcvideo bus-ID: 2-3:2 chip-ID: 8086:0a66 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x10ed built: 2016 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 22.1.6
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-2-zen running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: no
Sound Server-4: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:08b3 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-8:4 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 51.96 GiB (5.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
ID-1: / raw-size: 244.14 GiB size: 244.14 GiB (100.00%) used: 51.96 GiB
(21.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 244.14 GiB size: 244.14 GiB (100.00%) used: 51.96
GiB (21.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 244.14 GiB size: 244.14 GiB (100.00%) used: 51.96
GiB (21.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 244.14 GiB size: 244.14 GiB (100.00%) used: 51.96
GiB (21.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.4 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 9.77 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
System Temperatures: cpu: 61.0 C pch: 53.0 C mobo: 41.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 2249
Info:
Processes: 208 Uptime: 13m wakeups: 1 Memory: 11.4 GiB used: 2.61 GiB
(22.9%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pacman: 2510 lib: 579
Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-07-30
Last full system update: 2022-08-22
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

Another way that I know it's not the password is that, in the guest account if I try to login to the terminal to su with the password it works as it should.
Also that issue is in the snapshots to which is irritating giving that I can't even restore the system using the snapshots

So, I update Garuda, with different DE's for ~ 850 days (before that other OS and DE's for years) several times a day, and never has my password been changed.
How would that be possible?

Have you tried with root, even in tty?

Which programs have root privileges?
Check passwd and shadow.

Yes I have checked root using tty. Same issue. And I have tried to change my password, but I still got the same issue. Like I said I don't think the issue is with password coz I can login in to my account in the terminal from the guest account with the same password

Unable to login to my account after garuda-update

But which part of garuda-update change it?

You are making an assertion here without substantiating it.

How can I figure that out?

If you can list in the terminal the contents of the home folder of your user, check if the permissions of the .Xauthority file are set to root instead of your username.
In that case, gain back ownership with chown.

1 Like

Create a new user from tty, set it a password and try logging in to that.

2 Likes

Ok. So here is the output for the ls -la /home/ale.

ls -la /home/ale/
total 168
drwx------ 1 ale  ale   1502 Aug 22 09:04  .
drwxr-xr-x 1 root root    24 Aug 22 09:16  ..
drwxr-x--- 1 ale  ale    366 Aug 19 20:43  .android
drwxr-xr-x 1 ale  ale      6 Mar  9 23:39  Android
-rw------- 1 ale  ale   1543 Aug 22 08:28  .bash_history
-rw-r--r-- 1 ale  ale     21 Aug  1 09:14  .bash_logout
-rw-r--r-- 1 ale  ale     57 Aug  1 09:14  .bash_profile
-rw-r--r-- 1 ale  ale    141 Aug  1 09:14  .bashrc
-rw-r--r-- 1 ale  ale   1547 Aug  1 09:14  .bashrc_garuda
drwxr-xr-x 1 ale  ale   1882 Aug 22 00:52  .cache
-rw-r--r-- 1 ale  ale    418 Aug  2 23:29  .chromium-bsu
drwxr-xr-x 1 ale  ale   4106 Aug 22 09:27  .config
drwxr-xr-x 1 ale  ale    298 Aug 22 00:01  .conky
drwxr-xr-x 1 ale  ale     72 Jul 31 21:41  .dart
drwxr-xr-x 1 ale  ale    116 Aug 15 02:00  .dartServer
drwxr-xr-x 1 root root    28 Aug  5 21:41  data
-rw-r--r-- 1 ale  ale    520 Aug 14 14:14  demo.dart
drwxr-xr-x 1 ale  ale     46 Aug 19 21:01  Desktop
drwxr-xr-x 1 ale  ale    376 Aug 19 11:40  Documents
drwx------ 1 ale  ale     36 Aug  3 07:33  .dosbox
drwxr-xr-x 1 ale  ale    636 Aug 22 00:34  Downloads
-rw------- 1 ale  ale     16 Aug  4 00:50  .emulator_console_auth_token
drwx------ 1 ale  ale   1496 Aug 22 09:27  .firedragon
-rw-r--r-- 1 ale  ale     78 Jul 31 19:32  .flutter
drwxr-xr-x 1 ale  ale     18 Aug 18 09:32  .flutter-devtools
drwxr-xr-x 1 ale  ale    600 Aug  1 21:40  .fonts
drwxr-xr-x 1 ale  ale     64 Aug  7 01:40  .Genymobile
-rw-r--r-- 1 ale  ale     88 Aug  5 20:45  .gitconfig
drwx------ 1 ale  ale     22 Jul 31 14:46  .gnupg
drwxr-xr-x 1 ale  ale    120 Aug 16 15:12  .gradle
-rw-r--r-- 1 ale  ale    262 Aug 22 00:52  .gtkrc-2.0
drwxr-xr-x 1 ale  ale     62 Jul 31 19:04  .icons
drwxr-xr-x 1 ale  ale      0 Aug  5 16:39  iso_file
drwxr-xr-x 1 ale  ale     40 Aug  7 19:31  .itch
drwxr-xr-x 1 ale  ale     42 Aug  1 21:11  .java
drwxr-xr-x 1 ale  ale     10 Nov 29  2021  .kde4
-rw------- 1 ale  ale     20 Aug 19 09:11  .lesshst
drwx------ 1 ale  ale     20 Aug  7 11:43  .lgames
drwxr-xr-x 1 ale  ale    492 Jul 31 16:33  Lightly
-rw-r--r-- 1 ale  ale    105 Aug  7 19:48  live_footbal.txt
drwxr-xr-x 1 ale  ale     32 Aug  7 22:39  .local
-rw-r--r-- 1 ale  ale     95 Aug 16 07:15  Main.java
drwxr-xr-x 1 ale  ale     20 Aug 22 00:47  .mcfly
drwx------ 1 ale  ale     64 Aug  4 00:25  .moc
-rw-r--r-- 1 ale  ale     61 Aug  9 22:54  movie_sites.txt
drwxr-xr-x 1 ale  ale     44 Aug  1 18:35  .mozilla
drwxr-xr-x 1 ale  ale     12 Aug  6 13:45  .mplayer
drwxr-xr-x 1 ale  ale      0 Jul 30 20:57  Music
drwxr-xr-x 1 ale  ale    186 Aug 20 10:29  Pictures
drwx------ 1 ale  ale     10 Jul 31 14:46  .pki
drwxr-xr-x 1 ale  ale    192 Aug  5 20:03  .PlayOnLinux
lrwxrwxrwx 1 ale  ale     35 Aug  5 19:58 "PlayOnLinux's virtual drives" -> /home/ale/.PlayOnLinux//wineprefix/
drwxr-xr-x 1 ale  ale     10 Aug  1 00:08  Postman
-rw-r--r-- 1 ale  ale    183 Aug  1 09:14  .profile
drwxr-xr-x 1 ale  ale    600 Aug 16 07:14  Projects
drwxr-xr-x 1 ale  ale     22 Jul 31 18:09  .pub-cache
drwxr-xr-x 1 ale  ale      0 Jul 30 20:57  Public
drwx------ 1 ale  ale    148 Aug 19 20:27  .purple
-rw-rw-r-- 1 ale  ale      0 Aug  7 20:48  rogue.scr
-rw-r--r-- 1 ale  ale      0 Aug  7 22:48  routersploit.log
-rw------- 1 ale  ale    214 Aug 21 23:27  .rsf_history
drwxr-xr-x 1 ale  ale    432 Jul 31 20:22  SoftMaker
drwxr-xr-x 1 ale  ale     80 Aug  3 07:52 'Standard Notes Backups'
-rw-r--r-- 1 ale  ale   2297 Mar 11 19:35  starship.toml
drwxr-xr-x 1 ale  ale    148 Aug  7 22:47  .steam
lrwxrwxrwx 1 ale  ale     28 Aug  7 18:02  .steampath -> /home/ale/.steam/sdk32/steam
lrwxrwxrwx 1 ale  ale     26 Aug  7 18:02  .steampid -> /home/ale/.steam/steam.pid
drwxr-xr-x 1 ale  ale      0 Jul 30 20:57  Templates
-rw-r--r-- 1 ale  ale   1807 Aug  9 10:50  testdisk.log
drwxr-xr-x 1 ale  ale    302 Aug  1 16:34  .themes
drwxr-xr-x 1 ale  ale    434 Aug  5 10:11  ventoy-1.0.79
drwxr-xr-x 1 ale  ale      0 Jul 30 20:57  Videos
drwxr-xr-x 1 ale  ale     38 Jul 31 18:00  .vscode-oss
-rw-r--r-- 1 ale  ale    205 Aug  7 22:55  .wget-hsts
drwxr-xr-x 1 ale  ale    126 Aug  8 07:55  .wine
-rw------- 1 ale  ale     48 Aug 22 09:04  .Xauthority
-rw-r--r-- 1 ale  ale    414 Aug  1 09:14  .xinitrc
-rw-r--r-- 1 ale  ale     25 Aug  2 15:32  .xprofile
-rw-r--r-- 1 ale  ale  49301 Aug  3 22:08  .zcompdump
drwxr-xr-x 1 ale  ale    162 Aug 13 22:16  .zenmap
-rw------- 1 ale  ale      0 Aug  3 22:08  .zhistory
drwx------ 1 ale  ale     80 Aug 21 22:50  .zoom
-rw-r--r-- 1 ale  ale   9022 Aug  1 09:14  .zshrc

If I understand you right, I should change the owner ship of .Xauthority file to the my user account instead of root. By the way, the file's owner ship is not root as you can see in the output

Yes, it is ok. Not the problem I expected.
You could anyway try to delete it, logoff and login again (without rebooting), according to
https://wiki.archlinux.org/title/SDDM#Hangs_after_login
But that says "hangs", while the issue in my mind is often referred to as "login loop"...

Unfortunately that didn't solve the issue too

Any new ideas. I'm kind of stuck here.
I don't know if this relevant or not, but if I try to reboot the system using the reboot command, it's giving me this

reboot
User ale is logged in on seat0.
Please retry operation after closing inhibitors and logging out other users.
Alternatively, ignore inhibitors and users with 'systemctl reboot -i'.

Just re-install it and save time from trying to fix it, that's what i did and this happened when I first started using Garuda a few days ago.

Reinstalling is indeed a solution, but not the desired one. I can't imagine how many times I would reinstall Arch if I gave up resolving every issue, one of which being a login issue :grin:
PS: Mine was caused not by an update but because SDDM tried to be smart and sourced my .bash_profile, which had readline in it so login would hang indefinitely.

1 Like

I agree with @mrvictory, reinstalling would be my last option. I don't like reinstalling that much, coz of all the customization done is going to be done again and again. Besides what if that same issue happen again after some time? Am still debugging it the issue to find out what could have caused the issue, but so far I'm no where near resolving it

1 Like

Can’t help you so I apologise for that but maybe an rsync after a significant amount of customisation would help for the future? That way you can reinstall and restore your system from before the issue assuming you don’t set up a cron job for boot or anything. Anyway though, good luck with your issue

2 Likes

Perhaps your system would prefer lager to ale. :rofl:

But seriously, if it were an update that caused this issue you should be able to roll your system back to a working pre-existing snapshot.

Did you create a new user from a TTY?

Another option might be a reinstall of all your packages that relate to login.

3 Likes

If you keep trying to log in, do you get any different results?

This person experienced something similar: [solved] SDDM kicks me back to login prompt after correct password / Newbie Corner / Arch Linux Forums

The person accidentally uninstalled a few needed dependencies. I'm not saying you did that, but if you did this would be a fix:

Despite being a Gentoo thread from Reddit, this thread is also interesting: SDDM login loop : Gentoo

In the last comment, a person mentions this happened to them because somehow they had not defined a shell for the user. I'm not sure how you would get to that state from a Garuda system, unless you tried to change the shell to something invalid.

This might be a stupid question, but you have tried rebooting right?

3 Likes

Yes I have read and tried those mentioned solutions but still not working. So my only option is to create another account with sudo privileged from the guest account, but not from TTY. TTY has the same issue, it wouldn't log me in with that password. So I had to use the guest account to create the new account with sudo privilege. So far that's the only thing that worked. What I don't get is, if the password doesn't work for the TTY and SDDM, how come it works to login using the konsole from the guest account. That's kind weird.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.