Unable to install proprietary NVIDIA drivers

Hi,

I had everything working until I was getting constant kioslave5 errors and read that reinstalling was my only hope after a new user account didn't help.

When I go into garuda manager, I am unable to auto install proprietary drivers. It says there is an error but when you expend, shows nothing. I am trying to install this, so I can go back to using optimus manager with Nvidia as that also gave me an error when trying to set that up again.

Is it possible that there is an old config file that could be the cause?

Thank you for your time

λ garuda-inxi

System:
Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=40488fe0-30e5-4d0a-94b4-7af6cca0df80 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Thirdwave product: GCR1650GF v: Standard
serial: <superuser required>
Mobo: TFH model: GK5CP5V v: Standard serial: <superuser required>
UEFI: American Megatrends v: N.1.03 date: 11/11/2019
Battery:
ID-1: BAT0 charge: 46.7 Wh (100.0%) condition: 46.7/46.7 Wh (100.0%)
volts: 12.9 min: 11.4 model: standard type: Li-ion serial: <filter>
status: full
CPU:
Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3682 high: 4349 min/max: 800/4500 scaling:
driver: intel_pstate governor: performance cores: 1: 4248 2: 4349 3: 2600
4: 2600 5: 4247 6: 2600 7: 4279 8: 4204 9: 4258 10: 2600 11: 4102
12: 4107 bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
vendor: Tongfang Hongkong driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: Tongfang Hongkong driver: N/A alternate: nouveau non-free: 515.xx+
status: current (as of 2022-07) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1f91 class-ID: 0300
Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:7
chip-ID: 04f2:b65a class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0700 built: 2016
res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa
22.1.6 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Tongfang Hongkong
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA vendor: Tongfang Hongkong driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Tongfang Hongkong driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:8 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.38 TiB used: 42.04 GiB (3.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Western Digital model: WD Blue
SN570 500GB size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 234100WD
temp: 36.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
temp: 30.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDS500G2B0A
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 90WD scheme: MBR
Partition:
ID-1: / raw-size: 86.66 GiB size: 86.66 GiB (100.00%) used: 17.48 GiB
(20.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:10
ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.45%) used: 1.7 MiB
(1.8%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /home raw-size: 108.2 GiB size: 108.2 GiB (100.00%) used: 24.56 GiB
(22.7%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:8
ID-4: /var/log raw-size: 86.66 GiB size: 86.66 GiB (100.00%) used: 17.48
GiB (20.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:10
ID-5: /var/tmp raw-size: 86.66 GiB size: 86.66 GiB (100.00%) used: 17.48
GiB (20.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:10
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.48 GiB used: 1.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.08 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:9
Sensors:
System Temperatures: cpu: 52.0 C pch: 61.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 344 Uptime: 35m wakeups: 1 Memory: 15.48 GiB used: 4.59 GiB
(29.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1812 lib: 508
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-18
Last full system update: 2022-08-18 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

here is the error i got with optimus

[7] INFO: # Xorg pre-start hook
[8] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'nvidia', 'current_mode': 'integrated'}
[8] INFO: Requested mode is: nvidia
[41] INFO: Available modules: ['nouveau', 'acpi_call']
[41] INFO: Unloading modules ['nouveau'] (if loaded)
[44] INFO: switching=none, nothing to do
[70] INFO: Loading module nvidia
[70] ERROR: Xorg pre-start setup error
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/optimus_manager/hooks/pre_xorg_start.py", line 51, in main
    setup_kernel_state(config, prev_state, requested_mode)
  File "/usr/lib/python3.10/site-packages/optimus_manager/kernel.py", line 22, in setup_kernel_state
    _nvidia_up(config, hybrid=(requested_mode == "hybrid"))
  File "/usr/lib/python3.10/site-packages/optimus_manager/kernel.py", line 95, in _nvidia_up
    _load_nvidia_modules(config, available_modules)
  File "/usr/lib/python3.10/site-packages/optimus_manager/kernel.py", line 164, in _load_nvidia_modules
    _load_module(available_modules, "nvidia", options=nvidia_options)
  File "/usr/lib/python3.10/site-packages/optimus_manager/kernel.py", line 241, in _load_module
    raise KernelSetupError(
optimus_manager.kernel.KernelSetupError: module nvidia is not available for current kernel. Is the corresponding package installed ?
[71] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
[71] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20220818T171821', 'requested_mode': 'nvidia'}

Looks like you updated your new install and haven't rebooted yet. Try again after you reboot.

2 Likes

I've actually gone through a few reboots since and nothing has changed

Run

sudo pacman -S nvidia-dkms lib32-nvidia-utils nvidia-utils nvidia-settings

and reboot

3 Likes