Unable to install Garuda kde

hi :wave: guys....i hust want some assistance...i tried installing garuda kde and kde dragonised version...3 to 4 times each...but im unable to install it...problem with it is that it just hangs sometimes after live boot and sometimes while in installation process...what should i do...
thanks in advance

Please post:

inxi -Fxxxza

Enter and post the command from within the live environment.

How could we possibly know that?

As you gave us zero information about your system in your OP or on your profile page. You then logged off the forum immediately after making your help request so that you weren't available to answer any questions afterwards either.

The crystal ball is currently in the shop, so until you provide us with some useful information you really can't expect a whole lot of assistance.

Welcome to the forum, but perhaps you should read more than a couple of posts on the forum (or the wiki) to familiarize yourself with how to post proper information on a help request.

1 Like

hey bud i tried for more than 5 times but it just gets hang... 2 times i was able to get the command but it just get hanged when i am opening browser sometimes when im logging into forum...and after trying many times i just gave a go to the gnome version and i was able to install it...can i post the command from garuda gnome if that helps you coz i want kde
thanks

You can post it from Gnome.

Well, my personal experience says that GNOME is a bit "lighter" and "efficient" then KDE. Though the difference is almost unnoticeable on high specs device, yet GNOME or Cinnamon or XFCE or LXQT are a better choice if you have lower specs hardware.

Also Please share your specs.

And welcome to Garuda Linux Forums.

1 Like

which specs are your computer
what version of garuda you use
how did you make the usb stick or from what you install

2 Likes

ive been telling everyone lately to just copy the iso to a Ventoy stick. So much easier.

3 Likes

Ventoy never work with my hardware inventory but a try can not hurt.
I use dd and for M$ is balena etcher maybe a good choice.

So, as always, many roads lead to Rom :slight_smile:

3 Likes

this one is from garuda Gnome

❯ inxi -Fxxxza  
System:
  Kernel: 5.10.3-106-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: intel_pstate=passive \\boot\vmlinuz-linux-tkg-bmq ro 
  root=UUID=59383376-362d-4710-a002-69576c0b42fd 
  initrd=boot\initramfs-linux-tkg-bmq.img 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2.1 
  Distro: Garuda Linux 
Machine:
  Type: Laptop System: ASUSTeK product: X540SA v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X540SA v: 1.0 serial: <filter> UEFI: American Megatrends 
  v: X540SA.207 date: 11/25/2015 
Battery:
  ID-1: BAT0 charge: 19.5 Wh condition: 25.6/33.2 Wh (77%) volts: 11.2/11.2 
  model: ASUSTeK X550A26 type: Li-ion serial: N/A status: Charging cycles: 284 
CPU:
  Info: Quad Core model: Intel Pentium N3700 bits: 64 type: MCP arch: Airmont 
  family: 6 model-id: 4C (76) stepping: 3 microcode: 34F L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12814 
  Speed: 480 MHz min/max: 480/2400 MHz Core speeds (MHz): 1: 480 2: 685 3: 1351 
  4: 1601 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated 
  Graphics 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1 
  Device-2: Realtek USB2.0 VGA UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-4:5 chip ID: 0bda:57de serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: gnome-shell driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :1 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (BSW) v: 4.6 Mesa 20.3.2 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:2284 
  Sound Server: ALSA v: k5.10.3-106-tkg-bmq 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK 
  driver: r8169 v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8136 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On 
  driver: rtl8723be v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:b723 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 935.25 GiB used: 14.81 GiB (1.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 2J 
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: SCSI size: 3.74 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
Partition:
  ID-1: / raw size: 30 GiB size: 29.4 GiB (98.01%) used: 7.31 GiB (24.9%) 
  fs: ext4 dev: /dev/sda10 maj-min: 8:10 
  ID-2: /home raw size: 100.91 GiB size: 98.82 GiB (97.93%) used: 7.5 GiB (7.6%) 
  fs: ext4 dev: /dev/sda6 maj-min: 8:6 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda7 maj-min: 8:7 
  ID-2: swap-2 type: zram size: 957.6 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-3: swap-3 type: zram size: 957.6 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-4: swap-4 type: zram size: 957.6 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-5: swap-5 type: zram size: 957.6 MiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
Sensors:
  System Temperatures: cpu: 6280.4 C mobo: 50.0 C 
  Fan Speeds (RPM): cpu: 4300 
Info:
  Processes: 254 Uptime: 5m wakeups: 6877 Memory: 3.74 GiB 
  used: 1.12 GiB (29.9%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: pacman: 1125 lib: 299 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.2.01

Edit preformatted text by SGS :slight_smile:

bhai specs are 4 gb ram intel pentium n3700 , 1 tb hdd , 64 bit sys

4 gb ram intel pentium n3700 and im using the latest version and i just use belena etcher

OK, so far I've caught several major issues.

Firstly 4 GB of RAM is really insufficient to have a good experience running Garuda KDE on an older laptop (especially if it's sharing the ram for the graphics). IMO if you want to have a half way decent experience using Garuda you really need to upgrade your ram. The Garuda OS is optimized for newer hardware and performance (not older hardware barely meeting minimum specs).

If you are using an older laptop then you really should have at least 6, but preferably 8 GB of RAM to run KDE. For an older laptop an SSD is really almost mandatory, running a spinner driver (especially a 5400 rpm drive will give terrible performance). I'm saying this for people considering running Garuda KDE on an older laptop lacking important hardware components.

The other thing from your outputs that is a real problem is you have installed Garuda in an unsupported fashion. Garuda only supports installation on the BTRFS file system. While it is possible to install Garuda on alternate file systems, the Devs have made it clear that altering their default configuration in such a drastic manner voids any support from Garuda.

You can test installing Garuda KDE with the Garuda barebones edition to see if it will install for you. However, the barebones edition is also only for advanced users and no support is provided for the barebones editions on the Garuda forum either.

If you are going to deviate drastically from the standard editions default installation methods you're basically on your own. It should be understood that only users experienced with using Linux should alter the standard file system or install the barebones editions. If you are an experienced Linux user and you choose to install using these methods it is assumed you are capable of resolving your own problems. Therefore, support is not provided on the Garuda forum for these installation methods.

Sorry for the bad news on both fronts.

2 Likes

I have tested on pc with pentium 2.2 GHz with 4 gb RAM and it worked fine.

How old is your hdd because I tested on a new SSD.

Also use btrfs in calamers.

3 Likes

okay I'll give barebones a try....and thanks for your help and time

1 Like

bhai mine is pentium 2.4 GHz and the hdd is quite old it is the one which came pre-installed with my laptop and I'll use btrfs next time

Garuda runs fine on low specs too. Of course you cant expect it to run butter smooth (cant magically enhance the specs) but it will run better than for example windows would :slight_smile:

3 Likes

I have run Garuda on a desktop with an SSD and 4 GB of RAM and it was fine as long as you were cautious about not taxing the system too much.

But at the same time I tried it on a laptop with 6 GB of RAM and a spinner drive and it was pretty much unusable. After replacing the spinner drive with an SSD it was better, but not a rig I'd actually ever want to use (it was for a family member).

Laptop's that are old aren't the best choice for Garuda IMO. They'll work, but don't expect a butter smooth experience by any means.

Oh, for sure it will run better than M$, and it's also more humane to let the chipmunks free from the spinning wheel that M$ uses to power Windows. :wink:

3 Likes

Would my T440p also fall into that category? :joy:
Its always about what people are used to - if you run that Windoze on a toaster the user is used to the sluggishness - Garuda will feel a lot better in this case (personal experience at least) and updates wont take 2 hours -> enhancement
If one is used to beefy machines however it will of course feel laggy
You get the idea :thinking:

3 Likes

I have 4 GB RAM and an older i3 cpu. I have KDE Garuda Barebones and every application GUI and CLI that I need. GIMP, libreoffice, digikam, mpv, SVP, fbreader etc. And everything works wonderfully. System performs very fast and smooth. :grinning: Loving Garuda so far, been over a month and no issues except the minor inconvenience because of chaotic-aur being rebuilt.

2 Likes

Awesome that's what I like to hear, a user that installed the barebones and has a nice snappy system because of its much lighter resource usage.

It would be great if every user was up to that challenge. Unfortunately, many install barebones editions then cry about it when they want support on the forum and it isn't forthcoming.

If you like to do stuff for yourself, and learn by doing, the barebones editions are a great option. However, the barebones editions are only suitable for self motivated users willing to learn how Linux actually works under the hood.

3 Likes